Examples: Monday, today, last week, Mar 26, 3/26/04

SOLVED: Acer Aspire One ZG5 AOA150 connects to router but not internet

Problem: Acer Aspire One model ZG5 AOA150, will connect to some routers and access the internet but not all routers. The driver that is in the driver support section for this model, is too old. 7.6.0.224 is the problem.  Acer USA has not posted the latest backward compatible Atheros driver 7.7.0.456 on this model's support page to assist users, another problem. It is available on a later model's support pages and I will guide you there now.

 

Solution: Go to USA site: http://support.acer.com/us/en/default.aspx 

Choose Netbook> Select your product> Netbook/Chromebook> AspireOne > AOD255 (yes, choose the wrong model) > Confirm.

Scroll down to bottom of page to Wireless LAN section and download:

Wireless LAN Driver  Atheros  7.7.0.456 

Save As.. to your directory of choice:  7.7.0.456_XPx86_A.zip

After downloading close all programs, right-click and extract to default directory. Make note of where it is.

Shut off wireless. Click on Setup icon in the directory.

Pop up will ask if you want to Update or Uninstall device.  Uninstall the device and reboot.

Windows may discover new hardware upon reboot. Cancel.

Turn on wireless.

Go back to directory and click on Setup icon in the directory again.

Install the device.

You should have wireless back and internet working.

-tikimouth

 

KEYWORDS: Acer Aspire One AOA150 ZG5 Atheros LAN Wireless Router Cannot Connect Internet Driver 7.6.0.224 Netbook

Answers

  • carrienrusscarrienruss Posts: 1Member

    Trying to get my Atheros wireless AR5007EG on my Aspire 1 to update drivers following instructions on this topic. Cannot get to the download location indicated on the post...at Acer's website clicking on "drivers and software", when I click on Netbooks, chromebooks (group) as indicated on post, nothing happens. No choices of "Series", then "product" are indicated. Does anyone know if Acer has stopped supporting the Aspire1 with downloads?  The post with instrctions to update the driver looks like it is from Feb 2013...not long ago.  Is there anywhere else I can get the updated driver?

     

  • dackeldackel Posts: 1Member

    I found it here:  http://us.acer.com/ac/en/US/content/drivers/-;83518183025;-

     

    On that site, you must choose the acer model the first author describes in his post, and continue from there to find that specific driver he mentions.

     

    I hope this helps others who might be searching as well!

  • ReggiZReggiZ Posts: 1Member
    You're the absolute best! I've been trying everything to figure out why I couldn't get on the internet. I googled and followed everyone's advice but still I couldn't get on. Then by chance I came across your advice... AND IT WORKED! Thank you so, so much.
  • ZacharyWrightZacharyWright Posts: 1Member

    Thank you so much! Followed the corrected link from the third reply. Then followed directions and FINALLY have internet again! 

  • xvmxvm Posts: 1Member

    Thank you so much!

     

    I found it here by S/N: http://www.acer.at/ac/de/AT/content/drivers

     

    There has only been one little difference between your recipe and my experience:

     

    After deinstallation of the old driver and rebooting and cancelling the new hardware message, I couldn't turn on wireless.

     

    Anyway I followed your instructions and finished the installation. Now turning on wireless is possible and everything works fine!

     

  • swingsrswingsr Posts: 1Member

    Thank you.  One of the cleanest set of instructions I've seen.  Worked great! 

     

    I've been trying to get this little thing to work for days . . . too bad I didn't run the right search the first time.

     

    Thanks again, I hope you know how much folks like you help the rest of us duffers.  I for one truly appreciate it.

  • BrianGarriganBrianGarrigan Posts: 1Member

    Much obliged!  This fixes the very annoying problem causing the Acer Aspire One ZG5 not to connect wirelessly to several modems (even though the wireless icon indicates a connection), including Comcast.  I love this little netbook, and have been annoyed not being able to connect wirelesssly to Comcast modems remotely.  Now that I've just installed Comcast at home, I had to address this problem or get a new laptop.  I'm happy to report that by following tikimouth's directions, the Acer ZG5 lives to see another day.  I've ditched the ethernet cable and am using WiFi with the new Comcast gateway modem.  It's now January 2014, however, and a few updates to tikimouth's original directions from almost a year ago are needed. 

     

    For starters, the Atheros 7.7.0.456 driver no longer appears for borrowing from the Acer driver site for the AOD225 anymore.  There's a different Atheros driver now listed there, and I didn't want to chance that one, as so many have indicated success with the Atheros 7.7.0.456 on this thread.  It's curious - Acer seems to be routinely updating wireless driver availability for other models on their website, but not for the ZG5.  Must be some contractual hangup between Acer and Atheros that the consumer pays the price for.  Anyone from Acer wanna weigh in on that?  I had to Google it to find it from another site.  Also, as stated by xzm, after uninstalling  the old driver and rebooting, the icon for "Wireless Network Connections" completely disappears from "Network Connections", so there is nothing to turn off.  However, as xzm correctly notes, by simply following the rest of the directions and installing the new driver, everything falls into place and the "Wireless Network Connections" icon reappears.  I have no technical backround, and a little common sense updating tikimouth's directions got me there.  It's pretty scary worrying about bricking the netbook's wireless for good, and the Atheros 7.7.0.456 driver works dandy on the Acer Aspire One AOA 150 (ZG5)!  Oh, and technically, this driver isn't free, as indicated during the installation.  You get a "trial" period.  Dunno if my wireless will brick after the 45 day "trial period" is over or not....  Anyone out there have experience with this?  Anyways, thanks, tikimouth.  Like others have said, after exhaustive Google research, you're the only one who's come up with the solution, no thanks to Acer.

  • kesabsykesabsy Posts: 1Member

    I love you man! You cannot imagine how long I have been trying this. I even installed Ubuntu on this Aspire one and it was connecting fine.I tried so many things and your recommendation worked.

     

    Someone needs to tell Acer that they need to update their drivers for this machine.

     

    Anyway your instructions are spot on, but here is the new link that you need to go to to start the journey:
    http://us.acer.com/ac/en/US/content/drivers

     

    I just went to the Acer.com site, then support, then chose US etc etc. (Just in case they change it again.

     

    Sorry, I have to say Thank you one more time, So Thank you Tikimouth.

     

    [edited to comply with guidelines]

  • MbblusMbblus Posts: 1Member

    This worked!!!!

    I've been trying over a year to solve this issue...I could connect to most wireless systems but not my own after replacing router...I tried other suggested fixes and drivers but nothing solved the issue...

    I could not follow the address as suggested hower I connected to Acer's support page and down loaded suggested driver...Followed the instructions as written by tikimouth and it worked...

    Thanks to Tikimouth I can now surf at home from my recliner again!!!!!

  • jpcjpc Posts: 1Member

    Thank you, thank you.  I've been battling with this for months.  Now solved. Smiley Happy

     

  • StremiziStremizi Posts: 1Member

    Evvaaaaiiiiii !!!!! Thank you and many greeting fron Italy. W Acer one zg5 forever ;-)

  • Atomicus11Atomicus11 Posts: 13Member
    What's the solution? Might help me ...
  • Atomicus11Atomicus11 Posts: 13Member
    Found remaining posts ... duh
  • sunaosunao Posts: 1Member

    Unfortunately I tried this method but still I cannot connect to the internet. I tried rebooting it after installation but it's not working. Any suggestions?

  • st_evest_eve Posts: 1Member

    God bless you, thanks for that post. It helped me, when I was already in despair from non-working wi-fi. 

  • cdxicdxi Posts: 1Member

    OMG thank you so much, I've been trying to fix this FOREVER thank you thank you.  Mine first said "limited connection"  I just right clicked & repaired after doing exactly what you said to do in your instructions and now it works

    hallejuahhh 

Sign In or Register to comment.

Who's Online161

Acer-Moses
Acer-Moses
Ella40
Ella40
ErikAlvarez00
ErikAlvarez00
gdragvik
gdragvik
Halandar
Halandar
JackE
JackE
kanopi
kanopi
Screenreplacement
Screenreplacement
SushrutRP
SushrutRP
sy58605588
sy58605588
ven98
ven98
Vicky007
Vicky007
YanDaoSky
YanDaoSky
+148 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Announcements

Predator Gaming

Unleash the beast within. The Orion 9000 is built for legendary power with Ice Tunnel 2.0 cooling tech and room for up to five 120 mm fans on the front panel.

Member Highlight

Look at ven98 go! Raising up the ranks, helping other users in the Predator forums. Thank you for your dedication!

Total Posts and Comments: 1232

Total Points:877

Total Accepted Answers: 121

ven98 Seasoned Specialist