Acer Aspire F5-571 - Need Windows 7 drivers

DonPhillipe Member Posts: 13 New User

This is a tough one.   Looking initially for the Qualcom Atheros QCA9377 drivers.   The one referenced elsewhere at does not have a reference for the   VEN_168C&DEV_0042&SUBSYS_E09A105B&REV_30 hardware of this laptop.   Forcing the install of this driver give an error 10, whatever that is.   Still no wireless devices found so that means it's not working.


I believe I found Ethernet drivers at


I believe I found USB 3 drivers at


This still leaves open in the Device Manager:


PCI Simple Communications Controller

Unknown device



Note also that I plugged in an external USB Network device and the system runs in a rapid loop of connecting and disconnecting this device.


Anyone else on this dark path?  


  • DonPhillipe
    DonPhillipe Member Posts: 13 New User

    Actually it is a wee bit more tricky  ....   I wanted to go to a dual boot system Win7/10 and wanted to gain control over the system so wanted to switch back to MBR file system and use boot manager.   To do this, I'd have to reinstall Windows 10.  I used a tool "Product Key" to get my Win 10 product key and then download the Windows 10 iso via   You'll have a table of selections for download  and just use the Windows Home edition if you are dwonloading from a different system.   Whatever you do, DO NOT select Windows 10 Home "Single Language" or you'll have to reinstall later because the SN will be wrong.  Now use free ImgBurn or other favorite to burn an install DVD of the Win 10 ISO.  Mark the Windows 10 serial number on the disc for future reference.   You might want to find a 16GB or larger USB Thumb drive and go through the acer system routine to make a factory restore image on a USB stick before you destroy your image, just in case you descide to go back to the old setup later.   Of course all data is lost when you reinstall Windows 10 so ensure you have any of your system info backed up if you were previously using the system.   (This procedure is really best on a fresh install.)  Then burn the Windows 10 ISO to DVD and get ready to delete the existing Windows 10 installation after copying down the Windows 10 serial number.  


    Begin the rebuild: I power on and spam F2 to get the bios menu and I switch from  UEFI to Legacy setting, reboot, spam the F2 again and set secure boot off and set the boot order to where the CD/DVD is first in the boot order (F5/F6).  Now this assumes dual boot Win7/10 desired from here on but if you want only one, e.g. Win 7 alone or Win 10 with MBR boot manager instead of UEFI, then leave all the empty space allocatable and install the single system on a empty partition instead of making two partitions and cutting it in half for 2.  Load the Win 10 DVD and reboot and re-install windows 10 first if you will be adding Win 7 next as dual boot; if not, then use only the DVD for the desired one.  If you'll be installing Win 7 alone then you'll need to find a working SN, there are ways you can legally transfer your SN from a crashed machine plus find various bargains on someonen selling same.   Most of the SNs you buy that are sold at less than the retain are called OEM installs and they require a different Win 7 install disk than the shrink wrap retail version.  Know what you are buying and what disk you need before you spend hours and learn you have to start over.


    Windows 10 should go on first or if you are only installing Win 7, just go with it.  Click Custom Install during the intial load of the DVD and delete all the partitions (including resotre) and start with a fresh empty drive, then you can optionally allocate around 50% to two partitions (one for each Win 7/10) and optionally select the top 500GB or so to install Windows 10 then.   Go through all the options, use the configure option always to set all the spyware off (although you'll never get it all off, even with tools) but try anyway.    I don't think you will need any of the drivers off the Acer support page but they're there if you do.   You'll lose Power DVD 12.  Oh well, try VLC Player.


    OK, if you downloaded the correct Win 10 DVD the system will auto register with your old SN and you won't have to do anything as far as authentication.   You can't use the same SN for Win10, however, you'll have to purchase a new SN for Win 7.   Now with the DVD for Win 7 (relative label to the SN you purchase OEM/Retail) start the Win 7 installation.   Same place as before on Win 10, only this time on Win 7, select Custom install.  HOWEVER this time choose the 500GB unallocated partition you DID NOT INSTALL win 10 on.  Let it rip.   Now soon you'll want to rearange the boot seq menu in the BIOS to stop the initial delay in waiting for the DVD, or leave it that way if you frequently boot that way (haven't found any Linux that will boot from this BIOS, believe some are downgrading to a 1.0V or much lower in order to run Linux; please report if you find a working solution.)


    A few of the following Win 7 drivers will work on the Acer but only select the ones I recommend!

    Google: HP ProBook 450 G2 15.6" LED Notebook - Intel Core i5-4210U 1.70 (go to driver downloads)


    Once Win 7 is installed, you'll need to install either

    Realtek Ethernet - ( seems to be down a lot, try using HP SP72443 from above)

    Atheros QCA9377 wifi -  (Thanks IronFly)


    Now get the network working first and before doing anything else, it's best to just allocate about 3 hours and let Windows 7 SP1 run through the first update phase, about 158 updates, 2 hours to figure out what it needs and about 1 hour to install.   (No telementary installed on first pass it appears as of today).   Once all the initial updates are done (and maybe a few more), it's time to open Device Manager and get rid of the hardware missing driver issues.


    Note: The suggested install of "Intel-ME-10-Management-Engine-Driver-for-Intel-NUC" will only "gray out" the entry under Other Devices for the PCI Simple..... .   If you want to get rid of it permanently, download the newer version 11; (Google: ME Consumer Win 7 64 and download from Intel).   Now there will still be an unknown device in the Other Devices tab you cannot get rid of and to fix this, you'll have to download a hotfix which means going to MS and giving them an email to send to.   Not sure if they spam or not but don't take chances.     The hotfix you need is Windows6.1-KB2920188-v7-x64.msu from MS.   Note it won't execute off a network drive; copy to local HD.   Viola, now the shadowed out "Unknown device" should have disappeared.


    Now download your other "mystery IO" to fix orphans in Device Manager.   More suggestions:

    (head back to our good friends at HP for these if you want to make it easy)

    Intel USB3 - use sp69862

    Realtek USB Card Reader - use sp69949


    (My apologies, if I missed a needed driver, please note it for others here.   Wouldn't it be nice if MS/Acer did not partner to keep Win 7 drivers from being published, even though they have been proven to clearly work on this device for Windows 7.)    Good luck.

  • DonPhillipe
    DonPhillipe Member Posts: 13 New User

    I just attempted to convert another F5-571 to Windows 7 and I must have left some steps out from before because basically I wasted and entire day trying to resolve the missing driver situation.   I found out I left out the step of installing the Intel chipset driver, which really confused things.   But before I begin explaining what I did to resolve that, let me tell you how to update the trackpad where it works as it is supposed to.  Trying to work and search for drivers without two-finger scrolling is a real pain, once you have gotten used to it.

    After I finished laptop 1, the trackpad was severely lacking in function, it lost a lot of function as compared to the sister Windows 10 version.   It worked like a simple mouse and that is all; now two finger scroll or zoom.   And no matter how you try to update the driver, it won't update.   It keeps telling you that the MS PS/2 Compatible Mouse driver is the best one.  WRONG!

    Start by downloading the Synaptics driver:
    Download Synaptics_v17_0_19_C_XP32_Vista32_Win7-32_XP64_Vista64_Win7-64_Acme_Inc
    Unzip this to a folder and open it, then find and run the install routine ....
    Run setup.exe

    But that still won't update your driver, even after a reboot.   No matter what you try, like going into device manager and delete and re-scan and nothing - it's just like you didn't install it.   So you have to "force feed" this driver to Windows:
    Open Device Manager
    Open up the twisty arrow in front of "Mice and other pointing devices"
    You should see "PS/2 Compatible Mouse"
    R-click on that entry
    Update driver software
    Browse My Computer option
    Skip the top search for software and choose "Let Me Pick"
    Do not select the options available e.g. PS/2 Mouse
    If the device type selection menu appears, just leave the default of "all devices" and click Next
    Select "Have Disc"

    Click the browse button and go find the driver package you unzipped before
    Select the Synapics folder you unziped and open folder "WinWDF"
    Open folder "X64"
    Select the file "SynPD.inf"
    Sel OK

    Now windows will tell you that it does not recommend that driver and you have to tell it to install the driver anyway with a YES response (not sure what the deal is here).

    (Now FINALLY "Synamtics PS/2 Port Touchpad" will appear)
    Select Synaptics PS/2 Port Touchpad and Next
    Says Installing this device driver is not recommended"  say YES

    Windows has successfully updated your driver, OK
    Restart your system.

    Now you will restore touchpad full functions.  But before continuing, you'll need to make some adjustments.

    The splash screen will appear after reboot ...

    Unclick "Show screen at Startup"    
    Go to device settings
    Select "Pointer Options", "Motion", "Select a Pointer speed"
    One slide the slider to within one notch of all the way to the right "Fastest"
    (One notch short of fastest)
    Click Apply and check to see if you like by moving the cursor around to see if it is responsive at the rate you like.  Adjust accordingly.

    Say OK to close   (Your trackpad should be back to being a trackpad.)

    Now stay tuned for more info on laptop #2.

  • DonPhillipe
    DonPhillipe Member Posts: 13 New User

    Basically what I did on the second laptop conversion was fail to realize that I needed to do the chipset install before working with the ME:11 install.   So I am not certain what this looks like when done in the right order; likely not as dissonant.  Perhaps when someone accomplishes it on their own conversion, they can also contributed and make this more clear and concise for those to follow.


     Now here is my confusion, and all of these things happened at the near the same time so I am not certain how one might have impacted the other.   Before I began to install the Management Engine, I noticed from Windows Update (on it's 258th iteration, incidentally) that MS had tried to install a version 10 of Management Engine that had failed under Windows Update.   Still I don't know how all of this relates.   What I do know is a major mistake of mine was before installing the chipset (DO NOT DO THIS; install the chipset first) I did a "force feed" of the ME:11 driver and received an error 10.  But do not do this.


    (see above where I have defined a "force feed" of the Synaptics driver if you do wind up needing to "force feed" Windows to take the Intel ME:11 Management Engine driver update later)


    So by not installing the chipset driver first,  that gave me a dual entry under Device Manger, System Devices, Intel Management Engine (paraphrasing the exact syntax).   So what I did to attempt to recover is go to Start, Control Panel, Programs and Features, remove the Intel ME:11 Management Engine and go to device manager and delete and uninstall the two identical entries (one with ! mark) and reboot the system. 


    Now once I installed the chipset driver, unzipping that file and running "SetupChipset.exe", then everything cleared up under Device Manager.    So what I would suggest is to install the chipset first and check your undefined drivers.  If you still see the undefined device, download the Intel ME:11 Management Engine at and install it as needed.


    I did notice that even though I had removed the Intel ME:11 Management Engine entry under "Programs and Features", still  when I looked under the Device Manager, System Devices, I still saw an entry for Intel Management Engine, the driver was at the level of this package, so I think what may have happened with the un-install was that the supporting software was removed while the driver remained installed.


    Regardless, my Device Manager is clean now and I again appologize for not offering a concise step by step procedure.


    Other notes, the DriverMax utility seems to find a newer driver no matter how long you search online for the newest one.  I will never know how they always find a more recent driver than I can locate after hours of research.   On my previous laptop 1 conversion, I finally gave up and just used the two free update tokens per day until I got all the drivers at the most current level


    Side note, I discovered Lenova has the Atheros Wi-Fi card driver if you want to skip wasting a token with the Driver Max installed at the beginning of this discussion.   It can be found here  


    There is only one site claiming to distribute drivers from Qualcomm Atheros and even it is like the rest, a fake font end to get you into some "driver master" site that wants to do the job for you at some cost.  This is a pity for someone who likes to build and renovate their software because this must prove that more and more the manufacturers, even Intel have gone to only distributing their drivers though the laptop vendors.  Not sure if this is due to cost cutting, or what but just keep it in mind that just becaue a driver cannot be found by any means, it doesn't mean it does not exist - so just keep looking.


    So to all, I hope you have enjoyed this little exercise and are enjoying Windows 7 while it lasts.   I tried Windows 10 for a month and there is just too much going on in the background for me personally.   If it meets your needs, by all means, use it.  However, if it doesn't, I hope I have helped you reach your goal of using Windows 7 on this nice piece of hardware.   Good luck!



  • DonPhillipe
    DonPhillipe Member Posts: 13 New User

    Another note or two on this device.   I am not certain how large the scope of this problem is, if it is just with this particular device, with all new Acers or if it somehow effects all of these new EFI bios types in general, but I will speak only to this device at the moment.   I first of all converted this BIOS to the legacy mode in hope of being able to boot Linux CDs.   It didn't help.   I have yet to find a Linux version of anything that will boot on this device.   After extensive research I have found some people reporting they have downgraded to a BIOS version 1.0 from another Acer device and they can run Linux, but that is currently something I don't have the patience for at the moment.   At the shipped version of the BIOS (2.3 I believe???) Linux of any flavor I have tried just won't work.


    This sounds great and good to some, as they say who needs Linux if I am running Windows 10?   Well there are several programs that require rebooting where a stub Linux operating system is created for a moment while the software executes against the disk drive.   Two that hit me up front were Acronis True Image Home (2016) and EaseUS Partition manager.    I did get them both to work, but by side stepping anything Linux based.   In the case of Acronis it involves creating a boot USB stick with a WinPE USB drive after downloading a couple of their additional software packs.    In the case of EaseUS and a dual boot system, you always run EasUS from the opposite system that you want to resize the partition and the Linux re-boot OS stem will (hopefully) never load.