image

Pen not working on Switch 11 V

ochsskochssk Member Posts: 2

I recently received a stylus (NP.STY1A.002) for my Switch 11V (SW5-173-648Z).  The pen tracks on the screen but the buttons do nothing and the writing or drawing do not work at all.  I can use my finger to write or draw.  Did I get a bad pen?  HID compliant pen driver is listed in system.  No synaptic drivers from what I can tell.

FAQ & Answers

  • ochsskochssk Member Posts: 2

    Cannot find any solution so assuming pen was DOA on arrival.  Planning to return on Monday and will probably try the dell pen instead.  Anyone have any ideas?

  • luisf371luisf371 Member Posts: 2

    I'm actually having the *same* exact issue but with the dell pen (750-AAGN), i bought it cause its cheaper, heard it was the same techonology as the acer pen (synaptics) and prime on amazon. I was actually gonna order the official acer pen but i'll hold off as its obviously something else.

    I tried updating drivings from manufactors, installing synaptics drivers, ntrig drivers, updating the hid pen on device manager and nothing has worked.

    At this point only thing i can think of is a fresh window re-install but i dont want to go thru that trouble just yet.

  • luisf371luisf371 Member Posts: 2

    I side loaded a fresh install of Win10 on a USB stick and same exact issue.

    Anyone has any ideas before ideas or suggestions before i return the stylus as well?

  • TomasBTomasB Member Posts: 6

    Does Switch 11 V support active stylus at all? Switch 11 does, but if you look at: 

     

    http://store.acer.com/store/aceremea/en_GB/pd/ThemeID.26339800/productID.311144200/categoryId.52467700

     

    only Aspire Switch 11 (SW5-111, SW5-171) is listed, i.e. no Switch 11 V. Hopefully this is only be because the list was made before Switch 11 V was released, or not Smiley Sad

     

    I am thinking of buying a stylus for mine, can anyone confirm that their Acer Aspire Switch 11 V (not just Switch 11 without the V!) works with an active stylus, pen button, hovering, pressure, is any of that working?

     

    (Since everyone that replied so far said had the same problem, I am suspecting it's not all their pens but the Switch 11 V itself that doesn't support it)

  • billseybillsey ACE Posts: 24,738 Trailblazer

    The specs I see for the SW5-173 say it supports an active stylus.

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • TomasBTomasB Member Posts: 6

    Could you give a link and specify which property to look for. I fail to find anything regarding stylus support on https://store.acer.com/en-us/aspire-switch-sw5-173-65r3-convertible-notebook

    But on the other hand I don't see it specified for the SW5-171 versions either (Switch 11 without V  https://store.acer.com/en-us/aspire-sw5-171-86ee-convertible-notebook), which are specified as supported if you look at the stylus' specs 

     

    The closest spec I find is:

    Display Screen Type :
    Active Matrix TFT Color LCD
    But that has nothing to do with touch, laptops without any touch support has that too.

     

     

    update:

    After digging some more I found an article in italian, I'll translate the most important part:

     

    http://www.tabletpc.it/it/2015/10/13/acer-porta-nuovi-digitalizzatori-sugli-aspire-switch-11-v-ed-aspire-r13/

     

    "i nuovi Acer Aspire Switch 11 V e gli Acer Aspire R13 non sono infatti compatibili con la normale penna Synaptics “Acer Active Stylus” ma con un nuovo, misterioso stilo."

     

    Translation: "The new Acer Aspire Switch 11 V and the Acer Aspire R13 are in fact not compatible with the normal pen Synaptics “Acer Active Stylus” but with a new, mysterous stylus.

     

    In the end it mentions that the new pen is (was?) not yet availabe (as of 13 oct 2015) but should probably arrive in a couple of weeks.

     

    A couple of weeks has passed since then but I can't find it, maybe a couple more weeks...

     

    Update 2:

     I found a new stylus in the acer US store, https://store.acer.com/en-us/np-sty1a-005

    Compatibility
    SW5-173, SW5-014, SW7-272, R7-371T

     

    So I guess this clears things up, the old stylus, and many other brands based on the same (synaptics?) technique are not supported. A new generation stylus is needed, it seems to be available in the acer.com store (US) but not yet in the European stores (acer.co.uk, acer.de, acer.it etc). Unless styli of other brands specifically states as supported devices it seems difficult to know if it will work or not without trying.

     

     

  • billseybillsey ACE Posts: 24,738 Trailblazer

    Yeah, I'm afraid I don't have any more info on the actual stylus differences... I'll keep digging though.

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • ACorbettACorbett Member Posts: 2

    ochssk,

     

    Did you ever resolve this problem or find a pen that works with the Switch 11V?

     

    Recently got the Switch 11V with the same stylus and am having the same behavior.

     

    thanks!

    andrew

  • TomasBTomasB Member Posts: 6

    Not ochssk, but I can add an update on my last post, I have since then bought the stylus I linked to, i.e. the acer one with serial number ending with 005 instead of 002. It's working perfectly!

    my only issue was to find a replacement battery, AAAA batteries seems hard to find.., until I discovered that 9V batteries are actually packs of 6 AAAA batteries if you open them up!

     

    [edited to comply with guidelines]

  • ACorbettACorbett Member Posts: 2

    Thanks TomasB.  I just confirmed the same thing with sales and will be swapping for that pen.  Glad to hear it is working!

  • coverpagecoverpage Member Posts: 1

    Hi guys, I had the same problem as you. The pen work intermittently and then not at all. I have solved my problem.

     

    First a disclaimer, I do believe this work but I won't be responsible for any damage that might happen.

     

    So the problem for me was that the battery spring was getting weaker due to continued use. So the battery is connected only at one side. The remedy is easy, just crumple up a piece of aluminium foil and drop it into the spring side of the pen. So in between the spring is now a piece of aluminium foil and then the battery.

     

    Then you screw the pen back in, and you will feel much more tension now from the spring, pushing the battery forward. You can try again, this time the pen should work.

Sign In or Register to comment.

Who's Online1K

dokuur
dokuur
TeeArr
TeeArr
toko1231
toko1231
+1K Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers