Examples: Monday, today, last week, Mar 26, 3/26/04

5755g broadcom ethernet problem on win10

wh1tewh1te Posts: 8Member

Hi folks,

 

So i will try to cut this as short as possible but don't expect only a couple of lines.

 

I have the aspire 5755g with specs:

 

i72670qm

geforce gt540m

8gb ddr3

1tb wd scorpio blue

 

windows 10 pro x64

 

 

I have upgraded to windows 10 back in july(?) when it came out. For a couple of months it worked just perfectly fine. After a while probably because of some updates my ethernet stopped to operate normally, in a nutshell randomly but really often and on high download speeds simply stops workin.. i mean by that that my network becomes restricted ...running troubleshootin solves the problem 9/10 times.  If i dont run troubleshooting (resetting the adapter) the device manager shows an error "Code 10" in the device's description.

So i started to read after the problem. Ive found many similar problems but none of those solutions worked for me, but found out it will be probably a driver problem. Contacted several forums and maybe microsoft community site offered the solution which was simply don't use the driver windows automaticly installs but the one on the acer support site... fine altough the last driver available only win7 compatible it worked just fine.

 

Until this week ....when  "the first major upgrade" came for win10.

In fact i had to reinstall some stuff to make them work properly but i forgot about drivers because everything seemed fine. Then i connected through the LAN interface and the error came up again so here is what i have tried so far:

 

  • tried to upgrade the driver because i found a forum where some guy advised that these devices can operate with a wide variety of drivers of the same category(there is a newer driver on broadcom's site) ...was unable to install manually because windows said my driver is up to date
  • let windows to find or reinstall the driver by itself
  • tried to roll back to the driver available on acer's site - windows didnt let me always installed back the driver which is "default"
  • ..... so i forbid windows to install drivers automatically (in advanced system settings)
  • tried acer's driver again it's been installed but the device was malfunctioning with Code 10 in device manager, but if i hit toubleshooting windows set back the "default" driver
  • contacted microsoft support where they said its a compatibility issue try to install the acer's driver with last known working compatibility mode.... doesnt work either windows rolls back to "default" driver or the install wizard exits with a message(not an error message just simply finishes installation) that says it was unable to finish installation
  • tried to install the default driver manually, same effect as if windows installed

the version numbers:

default by windows : 15.6.0.14  release: 18/08/2015

acer's: 14.8.0.5 release: 06/07/2011

broadcom "latest": 17.2.0.2 release : 27/10/2015

 

I need to use somtimes wired network because the wifi is weak and unstable some places where i use my computer.

 

Any advice would be welcome!

 

(sorry for bad english ... if somthing not clear please ask me Smiley Happy )

 

 

 

FAQ & Answers

  • The old driver isn't doing you any good.Uninstall it and try the other drivers you downloaded.

  • wh1tewh1te Posts: 8Member

    The initial problem is caused by the newer drivers which is installed by windows, it randomly restricts the connection.

    I tried the older driver available on acer's site because before this week's major update on windows automaticly installed the newer driver and because it worked before the update.

    Anyway i let windows to install back the driver it wants to avoid errors but still doesnt works.

  • wh1tewh1te Posts: 8Member

    Also i cant install the newest driver because windows says when i try to install that the driver is up to date.

  • Go to Control Panel/ Programs and Features and uninstall anything that says wifi.Then try to install the other driver.

  • wh1tewh1te Posts: 8Member

    My wifi works perfectly fine.  There are no programs(drivers) listed regarding the ethernet LAN interface. Probably because windows automaticly installs the <sarcasm>"latest" "comaptible"</sarcasm> version of the driver.

    Uninstalling the driver in control panel is not an option---> see above.

  • Yes, I was thinking wifi when it clearly says ethernet.

     

    http://gadgets.ndtv.com/laptops/features/how-to-disable-windows-10-automatic-updates-728049

     

     

     

  • wh1tewh1te Posts: 8Member

    Hi,

    yeah that didnt work, it eventually prevents windows from getting updates, driver porblem remains..... the windows default driver is still not useable the latst working driver is "incompatible" either windows doesnt let it install or if i force it .... code 10 error....

  • wh1tewh1te Posts: 8Member

    The solutin offered by microsoft community site was i should install the driver running the setup.exe in compatibility mode. After a lot of failure succesfully installed in win7 compatibility mode but the device is again(still) has code 10 error... the event log for device in device manager says the device is configured and installed but didnt started, the entry didnt started has a text box which contains this:

     

    Device PCI\VEN_14E4&DEV_16B5&SUBSYS_05041025&REV_10\4&2b4e00c3&0&00E0 had a problem starting.
     
    Driver Name: oem2.inf
    Class Guid: {4D36E972-E325-11CE-BFC1-08002BE10318}
    Service: k57nd60a
    Lower Filters:
    Upper Filters:
    Problem: 0x15
    Problem Status: 0x0

     

  • Thomas1100101Thomas1100101 Posts: 4Member New User

    Hello,

     

    I have exactly the same Notebook and exactly the same problem (well, I upgraded to SSD, but that should not matter).

    First, your "latest" driver is the wrong one. Your broadcom adapter is the model "BCM57785".

    According to the Broadcom-Website, the latest driver is 15.6.0.14. Windows 10 does not use this Version, but the Version 15.6.1.3 from the date you mention (18.08.2015). So per default it is not possible to revert to an older driver.

    I managed to install the older driver. I describe it here: http://answers.microsoft.com/de-de/windows/forum/windows_10-hardware/windows-lan-treiber-vs-hersteller-lan-treiber/cad67796-18c7-4059-8880-bdad1c58afbf

    It is in German, tell me, if you have problems understanding it.

     

    But the sad fact: the older driver does not resolve the network problem. I even installed the old Win7 driver, but I got the same error like you: (10). So it is possible to install the broadcom driver (even latest), but it does not resolve the problem!

     

    ~Thomas

  • Thomas1100101Thomas1100101 Posts: 4Member New User

    I finally solved it:

     

    You have to install the "wrong" driver 17.2.0.2. According to Broadcom, it's not made for the BCM57785, but it works! How to install:

    1. Delete all suitable drivers with the method provided in my previuos post.
    2. Afterwards, Windows won't find a suitable driver for the adapter and the NIC will be listed with a warning in the device-manager (no driver found).
    3. Install the driver 17.2.0.2 by "right click > install" on the b57nd60a.inf. Now this driver is (just) available on your system.
    4. Right click your NIC in the device-manager. Select "Update Driver Software". Select "Browse my computer for driver software". Select "Let me pick from a list of device drivers on my computer". Select "Broadcom" on the left and then "Broadcom NetLink (TM) Gigabit Ethernet" on the right. Install.
    5. Now the NIC uses the driver 17.2.0.2.
    6. ATTENTION: Windows immediately replaces this driver on its own by the version 15.6.0.14.
    7. You can revert to the "older" but newer version 17.2.0.2 by right clicking the NIC > Properties > Drivers and then choosing "Roll Back Driver". After that, Windows won't replace it again.

    And the best: after that the BCM57785 Adapter works without freezing anymore :-)

  • Hippo5750gHippo5750g Posts: 1Member

    Just had to reply, to thank you for your post.

     

    I have a 5570g, and have been plagued with this issue since upgrading from W7 to Windows 10.  I never had any internet drop out issues, but any attempt to transfer data to / from a network share, would cause the adapter to fail within seconds.

     

    I can confirm that for me the problem is resolved by using the driver you suggest.

     

    https://www.broadcom.com/support/ethernet-nic-netlink-57xx#

     

    Again, many thanks.

     

     

  • ArseniyKDArseniyKD Posts: 4Member

    Hey, Thomas, I need your help. I have downloaded the 17.2.0.2 Broadcom x64 drivers but now I have hit a massive brick wall. I cannot delete the old drivers. As in, the driver stays at 15.6.1.3 even after I uninstall it or completely wipe the NIC adapter thing from the device manager. The issue is big as I am trying to sell my laptop ASAP. Mind helping me? To help me just tell me how to delete the old drivers and maybe walk me through the other steps to make sure that I do not **bleep** it up. Also, will the settings go back once I wipe my laptop with "Restore to Factory Settings" option? If, it will then helping me this one time will be enough.

  • Thomas1100101Thomas1100101 Posts: 4Member New User

    I don't know how your restore method works, but in most cases it'll also wipe your driver installations. So I recommend to do the restore first and isntall the drivers afterwards.

     

    Deleting the old driver:

    1. Disconnect the laptop from the internet.
    2. Go to the device manager, go to the settings of your network interface card and check which driver file is installed (ends with .sys)
    3. Deinstall the driver within the device manager.
    4. Go to C:\Windows\System32\drivers and delete the .sys file you detected in step 2.
    5. Run powershell.exe and put in this command:
      Get-WindowsDriver -Online -All | Where-Object {$_.Version -like '15.6.*'}
      This will display all locations of driver data that has a version kind of 15.6.... The search takes some time.
    6. Identify your driver (the windows standard driver) and take the path that is shown.
    7. Go to C:\Windows\System32\DriverStore\FileRepository and delete the files in the folder you found with powershell. (You won't be able to delete all files, but it will be sufficient)
    8. Now the driver is deleted and Windows is not able to reinstall it.

     

    Install the new driver like I did in my post above.

     

    After you have installed the new driver, connect to the internet, force windows update. Probably it will download its standard driver again and reinstall it. But now you can tell windows to revert to the previous one (per device manager), because luckily there was our version 17.2.0.2 before. Windows will then stay there and all will be fine.

     

    ~Thomas

     

    --

    This message was sent from a laptop with a fixed Broadcom Adapter under Windows 10 Smiley Happy

  • ArseniyKDArseniyKD Posts: 4Member

    The issue is still not resolved. At the moment I saved all the drivers that I will use on an external HDD and will Factory Reset the Laptop because I will have to soon anyways. So, I have attempted your method and it still did not work. What happened is that my laptop after "installing" the new file has two separate files in the update driver section. Both of them have no actual name but "Broadcom NetLink Gigabit Ethernet" as a thing. Also, the file in itself (the .inf file) after right clicking and installing does the process in under a second. Is that correct?

    P.S.: Someone decided to buy the laptop in spite of it having no wired internet available at the moment

     

    -Arseniy

     

    --

    This message was sent from a laptop with a broken Broadcom Adapter under Windows 10 Smiley Sad

     

    [edited to comply with guidelines]

  • ArseniyKDArseniyKD Posts: 4Member

    In addition to the issues that I just described, there is one more, and I think it is worse. When I try to "update" the driver, it tells me that it cannot find the file. All of this added up is super annoying. I really hope that someone can kinda walk me through the process.

  • GianniGianni Posts: 2Member

    Thanks to Thomas1100101 it seems that now with driver 17.2.0.2 my laptop is working fine when eth connected.

    But... Smiley Wink there is always a but... even if I reverted to driver 17.2.0.2 after the windows forced auto-update to 15.6.1.3 something is happened and the connection dropped Smiley Mad

    I found (again) the driver 15.6.1.3 Smiley Surprised

    I reverted (again) to 17.2.0.2 and I disabled the devices auto-update from system properties-advanced-hardware option.

    I'm waiting to know if this is the final solution...I hope...Smiley Indifferent

     

    I hope you will understand my bad english Smiley Tongue

  • Thomas1100101Thomas1100101 Posts: 4Member New User

    Gianni That's correct. I forgot to mention this option. To prevent Windows from installing drivers for your hardware on its own you have to turn this "feature" off:

    Rightclick the Start-Button and go to "System > Advanced system settings > Tab 'Hardware' > Device installation settings". Tell Windows not to install drivers for your hardware on its own.

     

    ArseniyKD It is correct, that the installation of the INF-File runs so fast, because it just copies the driver to the driver repository. After that you have to tell your NIC to use it. What you obviously tried, I guess, when you saw "Broadcom NetLink Gigabit Ethernet" two times. Just try it out which one of them is correct. You can check the version afterwards in the device manager.

  • ArseniyKDArseniyKD Posts: 4Member

    Yea... Didnt really work Smiley Sad .

    I do not have gyazo and cannot install it at the moment so I will write out the error message that appaears when I click "Update Driver". 

    "Windows found driver software for your device but encountered an error while attempting to install it.

     

    (driver icon) Broadcom NetLink (TM) Gigabit Ethernet

     

    The system cannot find the file specified" 

    This error appears on both of the drivers. Sigh... I really have no clue how to do it

  • GianniGianni Posts: 2Member
    Be sure you are network disconnected.
    Repeat step 1 to 8.
    Install inf driver
    Install NIC with option search driver in your pc. Don't use file search.
    You must find only one driver available.
Sign In or Register to comment.

Who's Online116

ArnaVin7
ArnaVin7
Dummytest97
Dummytest97
egydiocoelho
egydiocoelho
GolShah
GolShah
IronFly
IronFly
JackE
JackE
Kno63
Kno63
RLN
RLN
sepulturero
sepulturero
TexTor
TexTor
บุษยา
บุษยา
+105 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.