Examples: Monday, today, last week, Mar 26, 3/26/04

Linux on VN7-792G

bro85bro85 Posts: 6Member


has anyone successfully installed _any_ linux distribution (Ubuntu, Lubuntu, Fedora, Arch, Debian) on the Acer V7 Nitro VN7-792G Laptop?


The most important specs

- i6700HQ Skylake CPU

- Nvidia Geforce 950M

- Atheros Wireless card



I will document my progress here so everybody else can benefit from it.


I tried:

- Lubuntu 15.10

- Linux Mint

- Manjaro Linux (Arch based)

- Kubuntu 15.04


I don't want to mess with the Windows Installation (yet), so my instalation target was always the slower HDD.



Overall status is that it is currently quite painful during my tests I encountered various problems and solutions.


One of the biggest problems is that it seems that the nouveau driver actually hangs/freezes the system, or to be more correctly the framebuffer.

With Nouveau enabled I could not get any system to boot reliably, not even the installers!


So first of all boot your installer with


appended to the boot commandline (in grub press e, go to the linux line and insert this at the end, press ctrl-x to boot)


Depending on the version and confiiguration it sometimes helps also to set


as well. It definitely changes the behavior, sometimes for the better sometimes for the worse.


I'll create a post for each distro with my findings


FAQ & Answers

  • bro85bro85 Posts: 6Member

    Installer crashed/froze -- did not follow that route further.

  • bro85bro85 Posts: 6Member

    Installer did boot successfully to live cd

    - no touchpad

    - no wireless

    - wired networking works


    Installation did proceed smothly, however the UEFI/BIOS did not detect is as a suitable boot source.

    My guess is that it installed grub as a legacy bios installation, not a uefi based one.


    However switching bios to legacy mode did not change the situation.


    Did not investigate further

  • bro85bro85 Posts: 6Member

    Okay this one almost worked.

    Installer booted fine

    - no wifi

    - no touchpad

    - wired network


    The system installed fine, and grub appeared in the boot menu.

    Grub did even present me with the Windows option - so perfect dual boot.

    So manjaro did something right which the others didn't.


    From grub I could actually boot into my manjaro system -- at least to the console.

    The X server name came up.


    Going through the logs I figured out that it somehow wanted to make use of the "nvidia" driver,

    which failed completely.

    So I had a look at


    and did change nvidia to intel.

    Reboot -- I had a login gui.


    After login however the whole X/framebuffer got messed up when I moved the mouse in addition to being a super small resolution.


    So I removed


    completely, reboot.


    --> Working Desktop!



    However still

    - no touchpad

    - no wireless



    I experimented with the

    - driver backport project

    - the atheros firmware packages

    - the touchpad settings

    - newer/older kernelversions, as well as my own kernel compile.


    But nothing really made a difference.

    Booting was not always stable...



    Then I tried Lubuntu and killed this installation.



  • bro85bro85 Posts: 6Member

    This one was close to good.

    The installer booted fine to live cd.

    The trackpad was working

    still no wireless but okay


    The installation went good, until the point where it tried to install grub - which failed.


    Invoking it manually it seemed again that it wanted to install it as legacy.

    I tried to install grub manually for efi - it did show up in efibootmgr but it was gone after next reboot.


    sudo mount /dev/sdb3 /mnt
    sudo mount /dev/sdb1 /mnt/boot/efi
    sudo grub-install --root-directory=/mnt --efi-directory=/mnt/boot/efi --target x86_64-efi /dev/sdb


    So I'm left with windows at the moment.


    Next try is probably to install manjaro first (for the bootloader) and then install lubuntu in parallel


  • DrnoaDrnoa Posts: 3Member
    I got it to install with a older version of ubuntu 14.04.
    I was not able to get grub loading before the windows efi boot entry. So i copied the windows efi entry one folder upward an copied the grub loader to the windows efi entry.

    Still working on the trackpad an the wifi.
    The trackpad works with kernel 3.13. But not with the newer kernel versions.
  • DrnoaDrnoa Posts: 3Member

    Here some more informations.



    Actual my touchpad works. I had to do the following steps:

    * in the bios there is a touchpad setting witch i had to change from "advanced" to "normal"

    * install the synaptic packages with "sudo apt-get install synaptic"


    wireless module

    the wireless card is not working until now. Its a known problem.

    The related bug-report you find here:




    i installed nvidia driver (in my case nvidia-352).

    i followed the steps from the following post:



    everything else works out of the box.

  • DrnoaDrnoa Posts: 3Member


    Fix the wireless bug:

    Here is a solution for the wirless problems


    sudo mkdir -p /lib/firmware/ath10k/QCA6174/hw3.0/

    sudo rm /lib/firmware/ath10k/QCA6174/hw3.0/* 2> /dev/null

    sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board.bin https://github.com/FireWalkerX/ath10k-firmware/blob/7e56cbb94182a2fdab110cf5bfeded8fd1d44d30/QCA6174/hw3.0/board-2.bin?raw=true

    sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/firmware-4.bin https://github.com/FireWalkerX/ath10k-firmware/blob/7e56cbb94182a2fdab110cf5bfeded8fd1d44d30/QCA6174/hw3.0/firmware-4.bin_WLAN.RM.2.0-00180-QCARMSWPZ-1?raw=true

    sudo chmod +x /lib/firmware/ath10k/QCA6174/hw3.0/*



    but there is another problem with the acutal drivers/kernel.

    Internal microphone not working


  • SvatoSvato Posts: 2Member


    Fix the wireless bug:

    Hi Drnoa,

    thanks for help but this onli works for several types of cards, in my case i have to wait for next linux update i guess :/

  • SvatoSvato Posts: 2Member
    Linux on VN7-792G -- Mint 17.3 Mate


    Nvidia driver seems to work properlly, version-370. Tested OpenGL support, although i am not able to get on working detection of external displays. I have the same problem in win 10 while using dualboot. Separatelly i had no problem, just throught grub.

    Wifi in my case still not working, i have read bug report on this problem but no fix was working for me.

    Did you find the same display problem using another distributions?
  • gigi_Acergigi_Acer Posts: 2Member

    Hi, now I use since 4 mounth Ubuntu 16.04. The main problem is with wifi. I Have just ubutu no dual boot! .

    Also the usb vers.4 (the smaller between the two USB 3.0) doesn't running. I have not understad fine.. because sometime running and sometime no. I must look into.

    In the next week I'll Install the ubuntu 16.10 hoping that the problem  with wifi (Qualcomm Atheros QCA9377)will be resolved....Hi

  • LinuxgamerXLinuxgamerX Posts: 1Member



    i installed arch linux on my vn7-792g-79bl

    everything works fine except the mic

    nvidia geforce gtx 950m works great with bumblebee and no problems with wifi


    i got no other OS installed

Sign In or Register to comment.

Who's Online119

+109 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.