Aspire E11 won't power on

FreeJACFreeJAC Member Posts: 9

Hi,

 

I have an Aspire E11 11" fanless with an internal battery that won't turn on. I tried holding the power but for over a minute. It's plugged in and charging (battery LED is red) I tried it after 30min, 60min and 90 min with the same results. I have pulled the mouse dongle out and the SD card.  

 

Is there any tricks for this little guy to get it to turn on when things are messed up and you can't pull the battery?

 

I am hoping by morning it will have a full charge and to try again.

 

Thx.

FAQ & Answers

  • SharanjiSharanji ACE Posts: 4,321 Pathfinder

    Press and hold the power button for 10 seconds. The system should shut down.  Disconnect the AC adapter. Gently insert a paperclip in the battery reset hole on the bottom side of your ultrabook. Reconnect the AC adapter power the system back on to resume normal use.

     

    Click the Kudos kudos-thumbs-up.pngto say “Thanks” for helping! select "Accept Solution" if your issue is resovled.

     

  • GuruAid-CSGuruAid-CS Member Posts: 467

    As it is not possible to remove the battery, you can refer to the following link for troubleshooting options:
    http://acer.custhelp.com/app/answers/detail/a_id/4/~/what-can-i-do-if-my-computer-does-not-power-on%3F

     

    Hope this will help you.

  • FreeJACFreeJAC Member Posts: 9

    Hi,

     

    Thanks for the help, and the links. Unfortunately neither seem to be helping in this instance. The battery is showing fully charged but the laptop still won't power on. I followed the instructions exactly to reset the battery but no dice. I also tried a different power cable as I have 3 of these laptops and a different power outlet. No Dice! Smiley Sad  Looks like I may have to contact support unless someone else knows another trick?

     

    What can I expect from Support?

     

    Thanks.

  • vvpradvvprad Member Posts: 246 Die Hard

    Hi..

     

    As per the details you have provided, it seems to be an issue with the hardware (probably the motherboard). You may either contact Acer support team or place a repair order for the laptop

  • FreeJACFreeJAC Member Posts: 9

    Yep! Done and shipped yesterday. Hopefully it won't be too long.

  • vivbarkervivbarker Member Posts: 1

    Hey, thanks! I am a computer-dummy. That little video at acer community walks you thro starting at simplest connection problems, & mine turned out to be very simple: the 3-prong-to-2-prong connector to my extension cord had gone bad.

  • CliffordClydeCliffordClyde Member Posts: 1
    Hi I have Acer aspire E11 in first the laptop won't open but it connect to ac charger I put a paper clip in the bottom hole of the loptop the when I connect the charger the red light won't open then the laptop won't open hope you help me...
Sign In or Register to comment.

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers