Examples: Monday, today, last week, Mar 26, 3/26/04

Acer Aspire 5930g, Intel 5100 WiFi adapter DISAPPEARING

lexmirnovlexmirnov Posts: 1Member

Acer Aspire 5930g laptop with Intel 5100 WiFi adapter. Been testing Win 10 Tech Preview, switched off WiFi via built-in system switch and since than it completely disappeared from the laptop.

 

Which means when I press WiFi button on the laptop there's no light, the adapter itself is missing from the system — even in hidden devices. But all the other buttons (Bluetooth, browser) work well.

 

I've tried switching back to Win7, running WinXP from LiveCD, various Linux distribs — no result.

 

Tried other adapters (all of them Intel), it didn't help. Actually the system found Intel WiFi/WiMAX, but only WiMAX drivers were installed.

 

Tried flashing BIOS, also didn't help.

 

Been advised to install native ACPI utility with hardware buttons drivers. While trying to find it I stumbled upon a software called Acer Drivers Update Utility.

 

It's a third-party software which scans devices and proposes to download driver updates for them. For some money.

Yet while scanning it found the card (at least, listed it among devices). When I was scanning the laptop was connected via LAN, and after scanning Windows notificated about installing some bridge and PCI drivers. The button was working, and so was the WiFi card.

 

The next day, when I opened my laptop (as far as I remember, I didn't switch it off then), WiFi disappeared again. I've tried reinstalling the system and repeat the "magic" with Update Utilty, but failed. Of course, I've tried force-installing the drivers, installing Acer power management software — still no result.

 

Yesterday I've installed (on a fresh system) the latest Intel chipset drivers and Intel Rapid Storage software. Quite surprisingly it worked, but when I carefully turned off the system to make a full backup copy of it (via Acronis), and then turned it on again, the adapter disappeared again. Reinstalling the drivers didn't help. Restoring the system from the image too.

 

I've tried bypassing a laptop wireless switch by cutting its circuit (leading to pin #20). Honestly don't know if I really cut it (it's very small), but anyway no result.

 

I'm asking my dear colleagues for help :-) Suspecting glitches with ACPI and/or power saving functionality. And yes, I've tried disallowing power saving of WiFi adapter :-)

FAQ & Answers

Sign In or Register to comment.

Who's Online145

Acer-Jose
Acer-Jose
Acer-Manny
Acer-Manny
Balatekie
Balatekie
Biogeo
Biogeo
brummyfan2
brummyfan2
Cerilia
Cerilia
DAWNSTEPHENSON
DAWNSTEPHENSON
Fraupe
Fraupe
Grandcross
Grandcross
Ishy
Ishy
JackE
JackE
Jackyotto
Jackyotto
MMK360
MMK360
Mtrlns
Mtrlns
Prodigy_Burn
Prodigy_Burn
Sharanji
Sharanji
tobimaru
tobimaru
ven98
ven98
YaLags
YaLags
+126 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.