Touchpad is not working and receiving I2C-HID error. What should i do? My laptop is Aspire E15.

cjdemesacjdemesa Member Posts: 1

I just have my laptop for a month and my touchpad does not work after it wakes up from sleep. And now i have an error about I2C_HID that is not working. What should i do? Please help

FAQ & Answers

  • vvpradvvprad Member Posts: 247 Die Hard

    Please let us know the correct model number or you may reinstall the touchpad driver from the recovery manager.

     

    Here are the steps:

     

    Press and hold the Windows key and then press the C key to open Charms.

    Click on Search and type "Recovery".

    Click on 'Gateway Recovery Management'.

    Select Reinstall Drivers or Applications.

    Select Content and choose the touchpad driver and proceed to install it.

     

  • MynkMynk Member Posts: 2

    I'm having the same problem here.. I bought this laptop about 1 month ago and the model is an Aspire E 15 E5-571-36ZV

  • scahmadscahmad Member Posts: 1

    I had the same problem on my new Acer V15. After much searching and trial and error I found out it's a conflict based on the bios and how Windows 8.1 works. The chat help was no luck.

     

    Plug your laptop in and go to the Accer support website. Dowloand the latest bios updates from the downloads/drivers section.. You must be plugged in to run the bios update Also go to Windows updates on your computer and see if there are any Intel or other Microsoft updates that are optional. Downloand and install those as well. 

  • MynkMynk Member Posts: 2

    Do you think that this problem will be solved with the windows update to Windows10?

  • diymortdiymort Member Posts: 1 New User

    Mine is Aspire V11 Touch,12mths old Win8.1 and laptop lost the touchpad (no cursor at all) on resuming after hibernating. Connecting a mouse worked OK. Think it's a Windows 8.1 issue as in  Device Manager, Properties for the  12c-HID device (showing a ? query) the MSoft drivers were correct (2006) and 'working properly.' Turning touchpad on or off using function keys didn't work, decided to remove the device altogether in Device Manager (If I was wrong, then surely MSoft would install on reboot) however the touchpad returned and so fixed the problem.

  • mwmmwm Member Posts: 1

    "Gateway Recovery Management". What the What????

Sign In or Register to comment.

Who's Online1.2K

Acer-Blayn
Acer-Blayn
Acer-Carsten
Acer-Carsten
Acer-George
Acer-George
Acer-Ingrid
Acer-Ingrid
Acer-Jose
Acer-Jose
Acer-Manny
Acer-Manny
AdnachielRuiz
AdnachielRuiz
Alpaca_Friz
Alpaca_Friz
AngelPerez
AngelPerez
BINBIN
BINBIN
brummyfan2
brummyfan2
cleberdecarvalho
cleberdecarvalho
CLEMENT44600
CLEMENT44600
Coqui13
Coqui13
Cyriix
Cyriix
Daiky
Daiky
Daledantis
Daledantis
egydiocoelho
egydiocoelho
Eldiaploo
Eldiaploo
EmilioGC
EmilioGC
Everydaycomputer
Everydaycomputer
exxo_
exxo_
GarethS1994
GarethS1994
Hoseu
Hoseu
Humprey501
Humprey501
icedawg
icedawg
JackE
JackE
Joe78
Joe78
JulieAnn1215
JulieAnn1215
kanish
kanish
Kev0806
Kev0806
LauderNeto
LauderNeto
Leostat
Leostat
ljohns3
ljohns3
Lodetti
Lodetti
Mickael_14
Mickael_14
opaggiatto
opaggiatto
PaulK
PaulK
rafaelrasta
rafaelrasta
Ramesh123
Ramesh123
RaulPivetta
RaulPivetta
RenanVilela
RenanVilela
Sam_faadu
Sam_faadu
SergioV
SergioV
skitty
skitty
suesan48
suesan48
TECH_MAN
TECH_MAN
Zanthor
Zanthor
Zeiler
Zeiler
r00tz
r00tz
brummyfan2
brummyfan2
Acer-Manny
Acer-Manny
GarethS1994
GarethS1994
+1.1K Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We are honored to have Leostat in the Acer Community. With their dedication, support and effort, Leostat has become one of the main collaborators. On behalf of our Acer Community Team and all of our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1311

Total Points:4252

Total Accepted Answers: 164

Leostat Mainframe Wrangler