Examples: Monday, today, last week, Mar 26, 3/26/04

Help please with getting 802.11n wifi upto 104mbs

fabgavfabgav Posts: 9Member

Hi all, i have trawled the net for a few days and can not find specific answers for my problem.

 

I have Aspire 5749 with broardcom 802.11n wifi adapter.

I have virgin super hub cabable of 5ghz and 'n' speeds 2.5ghz

 

in device manager for broardcom under advanced i can find Rate, the max i can select is 54 but it should be capable of 104?

 

I have set IBSS mode to 802.11 b/g/n auto

 

my router is set to 104mbs and 'greenfield' mode which i think is N speeds.

 

has anyone got any ideas please?

 

thansk

FAQ & Answers

  • ababusaababusa Posts: 5Member

    hey there,I too would like to see a solution to this, after scrawling numerous forums I see this problem is more common than Acer probably care to admit. I have attempted the following:

    Contacting my ISP (redundant really as desktop is running at its max 30Mbps)
    Curries tech help (again like banging my head on a brick wall)
    Uninstalling and reinstalling drivers (fixes the problem for a whole 30 mins, whehey!)
    Installing drivers from Acer drivers section (why I even bothered is beyond me)
    System Restore AND Factory settings restore

    The best bit is, I exchanged my acer aspire e15 today for the same model and had exactly the same issue! Im new to this forum so not sure if any Acer tech geeks come on here or not, but if they do, for the love of god throw us a bone!

  • IronFlyIronFly Posts: 18,300ACE Trailblazer

    Do you have the latest drivers installed?

    I'm not an Acer employee.
  • fabgavfabgav Posts: 9Member

    The latest that I can find which are from intel, acer still spec the original ones that came with the machine.

  • ababusaababusa Posts: 5Member

    I find Acer's online support service extremely troubling as they so far have fobbed me off to both my ISP and the store which I bought it from.

     

    I have exhausted every possible avenue and still my connection remains a meagre 5 out of 30 Mbps.

    Up until now they have failed to acknowledge the device is with the problem, technical jargon aside these notebooks are supposed to be ready instantly, when you have to fiddle with numerous settings just to get a connection slightly better than that of the good old dial up days, something is obviously wrong.

     

    I wish someone would come forward with a straight forward fix for this as Id hate to have to return this

     

  • IronFlyIronFly Posts: 18,300ACE Trailblazer

    And the original one has the same issue?

    I'm not an Acer employee.
  • ababusaababusa Posts: 5Member
    Same issues for me yes...literally spend last few hrs going through numerous forums and I take great relief in knowing at least I am not the only one, wiping laptop as we speak to return tomorrow before its too late
  • IronFlyIronFly Posts: 18,300ACE Trailblazer

    can you post the exact model of broadcom wifi module?

    I'm not an Acer employee.
  • ababusaababusa Posts: 5Member

    Qualcomm Atheros AR956x Wireless network adapter current driver version: 10.0.0.285

    Edit:I want to also add I had the similar acer e5-551 model recently and exchanged it for an identicle model thinking it was a hardware issue, the previous one was a broadcomm adapter but this current one is an atheros

  • IronFlyIronFly Posts: 18,300ACE Trailblazer

    ababusa wrote:

    Qualcomm Atheros AR956x Wireless network adapter current driver version: 10.0.0.285

    Edit:I want to also add I had the similar acer e5-551 model recently and exchanged it for an identicle model thinking it was a hardware issue, the previous one was a broadcomm adapter but this current one is an atheros


    • On WiFi cards (b/g/n) which doesn't support the "a" standard there's a high risk that they will not be able to transmit data in 5GHz band.
      e.g. Atheros 802.11b/g/n WLAN card

    http://en.wikipedia.org/wiki/List_of_WLAN_channels

    As you can see the 802.11 n operates at 2.4Ghz (if module does not support additional 802.11 a) with 20Mhz (or double 40Mhz) bandwidth.

    In case the of 20Mhz bandwith and the datarate is limited to 72.2 (Mbit/s).
    In case the of 40 Mhz bandwidth the data rate up to 150Mbit/s would be possible..

     

    so only 54mps is available on your wifi adapter.

     

    to be able to connect to 5ghz the wireless adapter need to be 802.11 A/b/g/n, not only b/g/n.

    I'm not an Acer employee.
  • fabgavfabgav Posts: 9Member

    how do i find the exact module code?

     

    Also in reply to the other message, i thought 802.11n could do 104mbs?

  • ababusaababusa Posts: 5Member

    Even though that seems a little abover me, i think i get you and it seems acceptable, however I am only trying to get 30mbps, but currently only getting 5. Surely it should support more, id struggle to comprehend a £400 laptop not being able to handle more than that.

    Also in windows safe mode I am able to get up to 20 Mbps, this tells me initially maybe an application is hogging all the bandwidth so I uninstalled all unrequired apps and programms, yet still the problem remains
  • IronFlyIronFly Posts: 18,300ACE Trailblazer

    fabgav wrote:

    how do i find the exact module code?

     

    Also in reply to the other message, i thought 802.11n could do 104mbs?


    n could do it, but some wifi adapter without the a protocol can't be able to do it.

     

    about model name: go to your device manager, double click on network adapter and check name

    I'm not an Acer employee.
  • fabgavfabgav Posts: 9Member

    Untitled.jpg

     

    all i see is broardcom 802.11n network adapter

     

    I though that the fact it is 'n' meant it was capable of the higher speeds?

  • IronFlyIronFly Posts: 18,300ACE Trailblazer

    it should be, on the advanced tab there any settings about protocol or speed?

    I'm not an Acer employee.
  • IronFlyIronFly Posts: 18,300ACE Trailblazer

    i just found that some wifi adapter has some options "blocked" in their chip by the manufacter (broadcom for you) and it depends also on how many antennas are in your laptop.

    I'm not an Acer employee.
  • In Advance tab set it to Auto, in your router settings(second snip), Advanced Wireless Performance set the width to whatever you like, I have set it to upto270.

    Spoiler
    Capture 007.JPG

     

    Capture 008.JPG

     

  • fabgavfabgav Posts: 9Member

    iRONFLY

     - under advance the setting caled RATE has a max setting of 54,

     

    but like i siad i though n meant upto 104, unless like you say its been blocked in chipset.

     

Sign In or Register to comment.

Who's Online179

Acer-Harvey
Acer-Harvey
bobharris77
bobharris77
HaderMP
HaderMP
KishanMurthy
KishanMurthy
Maraxus79
Maraxus79
Migimara
Migimara
nicomunet
nicomunet
NiteOwl65
NiteOwl65
pabloeul
pabloeul
RafaelPhilippe
RafaelPhilippe
Soulr
Soulr
tux_peng
tux_peng
+167 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.