Examples: Monday, today, last week, Mar 26, 3/26/04

Touchpad problem with windows 8.1 Acer Aspire e3-111

Hi there, I saw similar threads, but, its little confusing... My problem is following: I have Acer Aspire e3-111 26UJ. I installed Windows 8.1, firstly in legacy mode, and all components worked. Touchpad worked without drivers, started from low level hardware when I pressed FN+F7. I changed my mind, and deleted everything, installed Windows 8.1, from UEFI mode. Even from installation starts, touchpad wont work. Now, its not working too. With or without drivers. If I press 2 3 times fn f7, keyboard not responding anymore, and windows restarts with message that my computer went to trouble... Does anyone solved this horor?

FAQ & Answers

  • zumtotalzumtotal Posts: 17Member

    You have to install the drivers in the correct order. I read it here somewhere in a thread about the V5 or E5 or V3 touchpad, I think.

    1. Chipset drivers

    2. I/O drivers

    3. Synaptics touchpad drivers

     

    I think that's correct, but have a search for the thread that mentions those drivers.

  • zumtotalzumtotal Posts: 17Member

    I got the first two the wrong way round. Should be

    1. I/O

    2. Chipset

    3. Touchpad

  • jescott418jescott418 Posts: 38Member Troubleshooter

    Not sure order of driver install matters?? I have this notebook but with Windows 7 OEM install and have done a factory restore from the partition twice which I would assume would install drivers in correct order. Still no joy, and my experiences are typically freezing on cursor when navigating with Touchpad, no mouse attatched. Also scrolling is choopy or pauses frequently.

    I even tried the manually uninstall and re install driver for Touchpad. Personally I don't think the Touchpad is to blame or its driver. I blame the weak CPU that probably get's bogged down by other proccesses and simply gets over loaded with instructions. Because at times my E3 is running Windows update or a security scan with Security Essentials the cursor freezes and scrolling issues get worse. This tells me the hardware in general is to blame. I am surprised given the quad core chip in my

    E3. But then again its really just a low powered Atom like Intel CPU. Not very responsive.

Sign In or Register to comment.

Who's Online179

Acer-Manny
Acer-Manny
Ajbrickyard
Ajbrickyard
bagualoide406
bagualoide406
JackE
JackE
Luigibarsocchi
Luigibarsocchi
manuelrv28
manuelrv28
Marlise
Marlise
MobJack
MobJack
OneIntangible
OneIntangible
Order_66
Order_66
Semajzero
Semajzero
TXHammer
TXHammer
+167 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.