Examples: Monday, today, last week, Mar 26, 3/26/04

My Iconia A1-810 suddenly wont start. What could the problem be?

MechanicsMechanics Member Posts: 4
edited October 2017 in Tablets

I have had it connected to the charger for some hours - and it would still not start up. Afterwards I connected it to my computer, but still nothing happened. It worked fine last night, but now it seems "dead".

FAQ & Answers

  • IronFlyIronFly ACE Posts: 18,415 Trailblazer

    Have you tried to use the "reset" hole?

     

    The hardware reset pin hole is located between the Micro HDMI port and Microphone.

     

    if this still not work, press the power button for about 20 seconds and still pressing the power button connect the charger and keep pressing for another 10 seconds.

    I'm not an Acer employee.
  • MechanicsMechanics Member Posts: 4

    Now I have... Still nothing..

  • IronFlyIronFly ACE Posts: 18,415 Trailblazer

    Try this:

    1. Power off the tablet.
    2. Press and hold the Volume up button, which is located closest to the touch screen lock switch.
    3. While holding the Volume up button, press and hold the Power button for 3 seconds then release it. Continue holding the Volume up button.
      1. Once the tablet screen turns on, stop holding the buttons.

     

     

    if A1 still not boot, it's time to contact Acer support for a repair.

    I'm not an Acer employee.
  • troymorehousetroymorehouse Member Posts: 3

    THis same thing just happened to me this monring.

     

    The tablet recently updated (about 3 days ago) to KitKat 4.4.2 from the original 4.2.2 that came on the tablet.

     

    Last night it was working fine.  It was at 40% battery and I plugged it in to the charger overnight.  But when I woke up the tablet screen was black and it will not power on. Tried the reset button, the powerkey/volume up button combo, and I even opoped open the case and siconnected the battery for 60 seconds.  Nothing worked.

     

    Earlier a month after I ot it the speaker failed.

     

    It appears that the A1-810 is a rather crappy tablet quality wise.

  • MechanicsMechanics Member Posts: 4
    I returned it to the service department and got it back within 10 days functioning again...
  • dawesydawesy Member Posts: 1

    Did they replace the battery?

     

  • MikeyBergoMikeyBergo Member Posts: 1

    I dont have a reset button I've looked. but I tried holding the on/off button for ten seconds and plugging it in and holding for another ten seconds and that seems to have worked. I hope it stays on now.

  • JDeeJDee Member Posts: 1

    I carried out your suggested solutions in turn: pressing the re-set button, pressing and holding the "On" button  & the "Volume" button , whilst plugging in the charger. None seemed to work. Then I removed the micro SD card, in preparation to send the Tablet off for repair,  and pressed the "On" button to see if anything would happen and the tablet started! There had been a gap of about 5 minutes between trying the various steps and removing the SD card. Thanks for your suggestions.

  • KrisOoKrisOo Member Posts: 1

    If your acer vibrates when you attach it to charger but the screen stays black then very gently take off the rear cover - you can do it with knife starting next to headphones jack. Unplug the battery for several seconds, plug it in again (you might have to take out the battery first to do so) and try to charge the tablet again. Should work.

  • Lornam1Lornam1 Member Posts: 1

    Pressing the power button for 20 seconds and still pressing the power button connect the charger and keep pressing for another 10 seconds worked. Tried everything else and nothing worked.

  • IronFlyIronFly ACE Posts: 18,415 Trailblazer
    Contact Acer support service if under warranty.
    I'm not an Acer employee.
  • njrefugionjrefugio Member Posts: 1 New User
    My Acer W1-810 had the same problem. It won't turn on. How will i make it work?
  • JourneymanJourneyman Member Posts: 1 New User
    Before you do all the reset steps, try this.
    Find a new USB cable and connect the table to it. It should vibrate, then you can do all the reset steps.
    I tried everything in the book with a "dead" A1, then I tried different cables I had laying around. 
    Some old cables I was using charged my other gear perfectly but it seems the usb connection of the A1 gains some slack with time thus you might need a new cable to boot the tablet. 
    I know this is a basic thing but it might save you some money. I just registered here to write this tip.  
  • BigSteelBigSteel Member Posts: 8

    Tinkerer

    Get a safety pin--Open it up then put in hole-push for 5 seconds--do this few times---Then do the hard start method--Volume up while holding power down at same time--Then put power charger in to give it a kick for few seconds--Do everything I just said a few times-----Sometimes if you just leave the tablet alone for an hour and go back and do it again--It will power up
Sign In or Register to comment.

Who's Online163

caroleBM
caroleBM
EuSystems
EuSystems
Faisal01
Faisal01
Fawaz2019
Fawaz2019
GAMING6698
GAMING6698
harshgupta718
harshgupta718
Shawafkhan
Shawafkhan
The_Bomsbas
The_Bomsbas
+155 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We want to recognize GAMING6698's dedicated efforts in the Acer Community. GAMING6698 has become one of the main collaborators since joining the Community in November of 2019.
On behalf of all our users and the Acer Team, we thank you for your dedication!

Total Posts and Comments: 3042

Total Points:5297

Total Accepted Answers: 265

GAMING6698 Mainframe Wrangler