Examples: Monday, today, last week, Mar 26, 3/26/04

This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

Visit our Product Forums for more current content.

ACer Aspire XC 105

pcselpcsel Posts: 2Member

Hi, My name is Paul and I have jkust purchased an Acer Aspire XC-105 which I have installed windows 7 64bit on. However the USB 3.0 Host Bus doesn't appear tio be recognised. with the AMD Chipset drivers that Acer supplies.

 

I have tried the Win 8 and Win 8.1 drivers to no avail (Chipset_AMD_12.102.1.1_W8x64_A and Chipset_AMD_13.152.1.3_W81x64_A) respectively.

 

I have also tried to look for the AMD driver for the device via the device Hardware ID (

PCI\VEN_1022&DEV_7814&SUBSYS_08001025&REV_01) again to no avail. I believe this to be an AMD A45 chipset but cannot lcate it on AMD's site.

 

 

Is any kind soul willing to give me a pointer as to where I might locate the driver for the units front USB devices..

 

Many Thanks in advance

 

Paul 

Answers

  • pcselpcsel Posts: 2Member

    It's okay I have fixed it... It DOES NOT install from the supplied Acer Software (Catalyst supplied by AMD) at all !!!  It doesn't even see the device in the device list in Catalyst... I found it in some HP drivers and installed it from there. Being an ex application packager helped me here... but other people may strugle with this one.. 

     

    Thanks

     

    Paul

  • fredneedlefredneedle Posts: 1Member

    Hi Paul,

     

    I have the exact same problem but I'm not able to find any HP driver that wil solve the problem like you did.  Could you link me to the HP download?

     

    Many thanks, John

  • 16vbatuk16vbatuk Posts: 3Member

    Hi all,

     

    Hopefully this will help people trying to get the USB3.0 driver working under windows 7 for these XC 105's.

     

    From the acer.co.uk support site search for the Windows 8 drivers for the XC-105 and download the chipset driver.

     

    ChipsetAMDChipset Driver12.102.1.1208.6 MB2013/06/10

     

    Right click the .zip file and "extract all" to a folder of your choice.

     

    Browse to the following directory for windows 7 32bit:

     

    Chipset_AMD_12.102.1.1_W8x64_A\Chipset_AMD_12.102.1.1_W8x64\Packages\Drivers\SBDrv\hseries\USB30\amdhub\W7

     

    OR browse to the following for Windows 7 64bit:

     

    Chipset_AMD_12.102.1.1_W8x64_A\Chipset_AMD_12.102.1.1_W8x64\Packages\Drivers\SBDrv\hseries\USB30\amdhub\W764A

     

    (If you are unsure of your windows version click START > Right click COMPUTER and check your version under the system information)

     

    Now you need to edit the amdhub30.inf (driver) file which is listed as type "setup information".

     

    Right click the file and choose "open with" and then select "notepad". You may have to expand "other programs" to find the option.

     

    You will need to edit the file and replace all instances of "5.1.1" with "5.1". The easiest way to do this is to click "edit" from the taskbar and choose the "replace" option.

     

    Complete the following:

     

    Find what:                5.1.1

    Replace with:           5.1

     

    Click "Replace All" , close the box and then save the file and exit it.

     

    Right click the amdhub30.inf file and choose the option to "install". Choose to install the driver if you are prompted with a red warning box.

     

    Now repeat the above process for the amdxhc.inf file found in :

     

    Chipset_AMD_12.102.1.1_W8x64_A\Chipset_AMD_12.102.1.1_W8x64\Packages\Drivers\SBDrv\hseries\USB30\amdxhc

     

    (selecting the file again based on your windows version)

     

    Once you have successfully installed both driver files go into the Device Manager (START > Right click COMPUTER > Select "Device Manager")

     

    The USB controller should currently be sitting under "other devices". Right click this and uninstall it.

     

    Then from the taskbar in the Device Manager click the button for "Scan for hardware changes".

     

    This should then go through the process of adding the USB 3.0 controller correctly.

     

    Works for me! Smiley Happy

  • 16vbatuk16vbatuk Posts: 3Member

    If this doesn't work for you please try running the .msi windows installer file from each folder and following the process through. ( amdhub30.msi and amdxhc.msi)

     

    Or another solution would be to replace "5.1.1" in the .inf files with "6.1"

     

    Thanks.

  • sigma36sigma36 Posts: 1Member

    This is the perfect solution.  Thanks for youe efforts.

  • 16vbatuk16vbatuk Posts: 3Member

    Thanks. You're very welcome. Smiley Happy

  • raddad555raddad555 Posts: 1Member

    I just purchased the XC-105 and it came with windows 8 installed , but I am finding that the 3.0 usb ports are not working. I do not see in the device listing a 3.0 root hub. Would all thos above steps also be for the problem I am experiencing?

     

    Please any help would be appreciated. Aslo nice work Paul 

This discussion has been closed.

Who's Online167

adsl3
adsl3
Dippy254
Dippy254
dsch
dsch
Hittie
Hittie
MEGARY
MEGARY
PhilipR
PhilipR
Pietro_fogaca
Pietro_fogaca
TechnoBeaver
TechnoBeaver
+159 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Announcements

Predator Gaming

Unleash the beast within. The Orion 9000 is built for legendary power with Ice Tunnel 2.0 cooling tech and room for up to five 120 mm fans on the front panel.

Member Highlight

Look at ven98 go! Raising up the ranks, helping other users in the Predator forums. Thank you for your dedication!

Total Posts and Comments: 1216

Total Points:863

Total Accepted Answers: 120

ven98 Seasoned Specialist