Examples: Monday, today, last week, Mar 26, 3/26/04

Acer Aspire E1-522 - Windows 7 Driver for Wireless

So I have this notebook and it came with Windows 8 (which I detest) so I decided to put Windows 7 on it. I managed to get everything working EXCEPT the wireless card. I just cannot find drivers for it. Is there anywhere I can get Windows 7 drivers for this device?

Answers

  • finluxfinlux Posts: 1,834ACE

    Hi Therks!

    I presume you've already checked Acer's support site?

    If you download Speccy or Belarc advisor, these programs will advise you on (amongst other things) the components in your PC. Once you know the make of your wireless card, go to the manufacturers website where you should be able to find the drivers there

  • therkstherks Posts: 5Member

    Yeah, I can only find Windows 8 and 8.1 drivers on the Acer site, and those drivers won't install, and it looks like neither Speccy nor Belarc Advisor are seeing the wireless device.

  • therkstherks Posts: 5Member

    Found em! I hadn't actually tried Acer's Win 8.1 drivers available til just now and when I tried those ones, for Atheros, it worked.

  • finluxfinlux Posts: 1,834ACE

    Hi therks

     

    Glad you're now sorted!

  • edaut80edaut80 Posts: 2Member

    Hey mate!

     

    I am exactly in the same condition. Worst, I resinstalled Windows 8, and damned Wi-Fi does not like to run. Will give a try to the Atheros driver following your advice though. Reading your post, I am even considering giving a second try to Win7. I couldn't find USB3 and SM bus drivers yet, though I have a possible lead. Could you point me to where you found yours? That would be much appreciated.

     

    Thank you in advance,

     

    Manny

  • edaut80edaut80 Posts: 2Member

    EDIT: I found out shortly after posting that these drivers (SM bus & USB3) were included in the AMD chipset and graphic APU driver packs.

     

    As far as the wireless is concerned, I confirm that the Atheros Win 8.1 driver worked for me as well, both in Windows 7 and Windos 8. I also noted that the Broadcom driver for Windows 8 failed in both Win 7 & 8. The device ID of my hardware didn't match the ones in the .inf file of the Broadcom one; since the Atheros worked right away in both Win 7 and 8, I didn't bother checking this one though.

     

    ISSUE SOLVED.

     

    I will note what I did to solve my other issues, for I looked for that information to no avail for two long, full and painful days.

     

    Since it is not the topic of the post, I assume any criticism that could be made upon the matter. The reason why I do it here is 1) because it is the place where I found the most usefull piece of advice regarding my issue, and 2) I am an assumed ignorant n008.

     

    I found the chipset drivers here: /en/home/leaving?target=http%3A%2F%2Fsupport.amd.com%2Fen-us%2Fdownload%2Fchipset%3Fos%3DWindows" class="Popup (further refered to as "site 1")

     

    ...and the graphic drivers, here: /en/home/leaving?target=http%3A%2F%2Fsupport.amd.com%2Fen-us%2Fdownload%2Fdesktop%3Fos%3DWindows%2B7%2B-%2B64" class="Popup (further refered to as "site 2")

     

    REPORT OF ACTIONS, to solve the SM bus, USB3 & graphics drivers issues (Acer Aspire E1-522 downgraded to Windows 7):

     

    Action: Downloaded & installed 13-4_vista_win7_win8_32-64_sb chipset driver from site 1 (package for motherboards with 700 series or newer AMD chipsets, revision number 13.4, 26.4 MB)

    Result: This solved the SM bus issue, but the USB3 was still not functionnal

    Observation: Nothing that stands out.

     

    Action: Downloaded & installed 13-12_win7_win8_32-64_sb chipset driver (older) from site 1 (likely labeled, revision number 13.12, 49.7 MB)

    Result: The USB3 got functionnal

    Observation: Though this version is older than the former, since the file size is much bigger, I suspect it contains some things that the other don't (yes I know I am a deductive genius). I installed it on top of the newer driver without prior uninstall (you're allowed to display a grin of disdain).

     

    Action: Downloaded & installed 13-12_win7_win8_64_dd_ccc_whql graphics driver from site 2 (to get this one, I used the autodetection tool from this page: /en/home/leaving?target=http%3A%2F%2Fsupport.amd.com%2Fen-us%2Fdownload%2Fauto-detect-tool" class="Popup, which pointed me to the right driver to download. I experienced some issue with the tool at this point, so I could not use it to download the driver, and I had to get it from somewhere else though I can't remember where, but the one which appear on site 2 bear the exact same number provided by the tool, and matches the one I installed).

    Result: The display adapter got fully functionnal

    Observation: I think I remember seeing that this last driver *might* also contain the SM bus and the USB3 drivers.

     

    CONCLUSION: This did the trick for me. I do NOT generally recommend to install an older version of a driver on top of a more recent version though. If I had to do it again, I would consider installing the display driver first, since it might solve everything at once. If not, then I would install the older chipset driver, and if this one still does not solve everything, I would install the newer one in last resort. If this does not work, I would then consider redoing it in the order provided here, maybe reformating & reinstalling Windows in the process to prevent bugs. So this is the very first thing I would try on my newly formated system, so I could reformat & reinstall right away if it went wrong & out of any control.

     

    BTW, since I had to reformat & install Windows 3 times to get this one to work, I can say "reformat if it goes wrong" without blinking (my system came preinstalled with w8, which I completely wiped out, including the recovery partition, to install w7, which I couldn't find the drivers for and removed for another version of w8, which I had to find and download on the spot because I didn't bother doing the recovery USB key prior to format, and which I could finally scrap for good & change back to w7 when I found my last ray of hope right here; the overall process took me about 24 hours and a sleepless night). Not that anybody cares though... besides those who might profit from my leads.

     

    All the other drivers provided by Acer on their support site for Windows 8 (Audio/Realtek, Card Reader/Atheros, LAN/Atheros, and TouchPad/Synaptics) all installed flawlessly on Windows 7. I didn't try any of the Windows 8.1 drivers beside the Wireless LAN/Atheros which is discussed on this page & saved me from utter deception... and a 80km drive to the store for a full refund.

     

  • H2KH2K Posts: 1Member

    Because it took me so long to find out how to get the wirless working after I downgraded from win8 to 7 I will tell you how to get WIFI working :

     

    1. Go here: /en/home/leaving?target=http%3A%2F%2Fwww.atheros.cz%2Fatheros-wireless-download.php%3Fchipset%3D83%26amp%3Bsystem%3D6" class="Popup

    2. Download it and make extract its contents to a folder on your desktop

    3. Go to device manager

    4. Right click on the missing network adapater and click update driver software then click browse my computer for driver software.

    5. Navigate to the folder you have created before then click next and your done.

     

    It should install and you will notice you have wifi networks online to connet to.

     

    Hope this helps someone in the same situation as I was

     

    My Laptop was a: Acer Aspire E1-522

  • twinbeetwinbee Posts: 1Member
    edaut80, do you have Paypal? I'm just a random visitor who would like to pay you for the time and effort you put into finding a solution as it's helped me with my Acer E1-522 laptop.
  • kamikarze75kamikarze75 Posts: 1Member

    Hi therks do you remember the version you installed as I am having the same problem and tried all Atheros drivers win 7, 8 & 8.1 I have no conflicts in device manager now but the wireless light stays orange and it will not turn on with fn+f3 any help would be grately received.

     

    many thanks Smiley Happy

  • irfan2irfan2 Posts: 1Member

    Hi.
    Is there a way to find atheros driver for this laptop for XP? I have win 7 installed, and working driver from this thread, but I can't seem to find any working driver for xp. I went on atheros site, and followed instructions on update driver from device manager, but it didn't work. Help, anyone?

    I need XP system for work. 

  • ThanoshldThanoshld Posts: 1Member

    Thanks mate, your post was the only one that helped me in my endless try to install all the drivers I needed in my Aspire E1-522! I don't know what I would do without you!

     

    I confirm that all the drivers you posted work, though I installed them with a different order. I first installed the graphics card drivers (which I found for 32bit and not 64bit Win7 though), then the older chipset driver descripted in step 2, which got the USB3 port to work and finally the first step aka the newest chipset drivers which got everything else to work. Also, the Atheros drivers for Win8.1 made my wi-fi adapter working.

     

    Also, I had some problem with booting the notebook from it's USB ports, which I resolved it this way:

    /en/home/leaving?target=http%3A%2F%2Fsuperuser.com%2Fquestions%2F863018%2Fboot-from-usb-not-working-acer-aspire-e1-522" class="Popup

     

    Thanks again for your help mate! Cheers!

  • orateh8400orateh8400 Posts: 1Member

    j'ai installer le pilote pour wifi iva le site acer  mais il ne prend pas 

Sign In or Register to comment.

Who's Online218

Acer-Victor
Acer-Victor
Alez_Curquejo
Alez_Curquejo
Coqui13
Coqui13
CortesX24
CortesX24
Hagz33
Hagz33
IVAN_PC
IVAN_PC
Kanmuri
Kanmuri
lewisc
lewisc
vivimar
vivimar
+209 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Announcements

Maintenance Notice:

The Acer Community Maintenance has ended! We apologize for the delay and would like to thank everyone for their patience. We're still ironing out some details but you're more than welcome to explore! Stay tuned to the Announcements section as we'll be updating it regularly to keep you informed about the changes.

New Here?

New to Acer Community?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Member Highlight

Look at ven98 go! Raising up the ranks, helping other users in the Predator forums. Thank you for your dedication!

Total Posts and Comments: 760

Total Points:147

Total Accepted Answers: 0

ven98

Practitioner