Examples: Monday, today, last week, Mar 26, 3/26/04

This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

Visit our Product Forums for more current content.

Acer Aspire M5-481PT BIOS update failed, won't boot

JB2579JB2579 Posts: 9Member

Tried to update using download from Acer and it shut down 80% of the way through the update for no apparent reason. Now it won't boot. Have keyboard lights and fan noise, but screen remains black, and nothing happens from there. I've seen some old posts especially regarding the Aspire One where you could put an .fd file (a BIOS file) on a flash drive and hold Fn + Esc and it would replace the BIOS that way so you could boot again. Tried that with my M5-481PT but no success. And I haven't found any instructions for the M5-481PT (or any other M5) anywhere. Anyone have any ideas? I'm totally stuck at this point.

Answers

  • JB2579JB2579 Posts: 9Member

    Can anyone help? There must be someone somewhere who knows how to replace the BIOS from the flash drive for the M5. When I hold down Fn + Esc on power-up the flash drive lights up for a split second (the DVD drive does too) so I know it is being accessed. All I need to know is what files should be on there for it to succeed. I called Acer and they won't support it because it's a refurbished computer. They told me to go to "a local store such as Best Buy." I've had the computer a week and a half and it's a very expensive paperwieght at this point. Please help!

  • JB2579JB2579 Posts: 9Member

    Still stuck here. Does anyone happen to know if the eRecovery DVD you can purchase from Acer includes a BIOS crisis recovery capability? As in, insert DVD, hold Fn + Esc, power on, and it will allow it to boot?

  • mazenmazen Posts: 57Member

    try to shutdown laptop, then turn on and keep tapping F2 until u get Bios setting screen, set bios to Default and then f10 to save then reboot and see if it works.

    Good luck

  • dhroopydhroopy Posts: 4Member

    Hi JB2579

     

    I am also facing the same problem; I updated Acer BIOS - UEFI for Windows 8 (Not for Upgrades); Version - 2.22; Dated - 2013/06/20 on my Aspire M5-481PT-6488 laptop. Now it wont boot up, the battery & the keyboard lights are on, but there is no screen display.

     

    Were you able to get it resolved? Is there any way I can revert this change?

     

    Thanks

    Dhroopy

  • JB2579JB2579 Posts: 9Member

    No, I was not able to resolve my problem. Mine was still under warranty and I dropped it off at UPS two days ago. Frustrating because as I understand it, all I need is the correct DOS BIOS file (in .fd format) on a flash drive, hold Fn + Esc and I am up and running, but Acer doesn't provide any DOS BIOS files, only the Windows-based .exe files. So much less efficient to mail it etc at Acer's expense and time -- they could just provide the files and save themselves time and money. Oh well. I'll update this post when I get mine back. Good luck.

  • dhroopydhroopy Posts: 4Member
    Yeah if they could at least provide the correct file name we can download on a flash drive and give it a try ourselves.
    I am in yet another problem, I bought it from USA and currently I am in India, and there are no service center close by Smiley Sad, can't even ship it to the Acer center..
  • padgettpadgett Posts: 3,263ACE Pathfinder

    I take it that you cannot even get into the BIOS setup.

     

    If the BIOS is confused, you have what is known as a "brick". You need some code just to get started and there is no way I know to toggle in a bootstrap. The whole idea of updating a BIOS should be done under very controlled conditions with a UPS and the computer left completely alone until finished.

     

    Once screwed up the only way to restore that I know is to replace the BIOS chip.

     

    True, some computers maintain enough of a bootstrap to be able to reload the BIOS but only ACER knows if yours has that capability.

     

    Bottom line: I only update a BIOS if there is no other choice.

  • dhroopydhroopy Posts: 4Member

    Hi JB2579

     

    Any luck with the issue? I am stuck with mine in India with no success.. Smiley Sad ...

  • kingking Posts: 9Member

    im stuck with the same problem with my acer aspire 4752G. i tried wincris but it wasn't working.
    in my service manual, .FD file should be place in a bootable flash drive, but in bios file from Acer it's .WPH and .ROM.

    any successfull process sir?

  • JB2579JB2579 Posts: 9Member

    To all reading this forum,

     

    I am the original poster of this thread. And I was never able to find a do-it-yourself solution to this problem. I sent mine in for warranty repair service and it came back to me working again. Then I immediately sold it.

     

    For what it's worth I did the BIOS upgrade under fully controlled circumstances -- plugged in, no power interruption, using the BIOS update released by Acer on their official website -- and it failed. I have updated the BIOS on Dell and Asus laptops with no problem. I don't know why Acer's product/upgrade failed. But that's why I ended up selling that laptop and going a different direction. Based on my experience, my recommendation would be to avoid Acer computer products. I wish I could tell you I figured out a solution but I did not. Good luck.

     

    John

  • kingking Posts: 9Member

    is ur motherboard sir replaced?

    Thanks for the recommendation.

  • JB2579JB2579 Posts: 9Member

    I don't know what they did for the repair. All I know is it came back working again.

  • kingking Posts: 9Member

    thankyousir

  • Acer-CoryAcer-Cory Posts: 1,442Member, VIP

    It's unfortunate that this experience drove JB2579 away. BIOS updates have come a long way from the late 90's and early 2000's, but there is always a small chance that an error can occur. When a BIOS update does fail, it is not always a simple fix. I'm glad that JB2579 was able to get help, and we were able to correct the issue. I have updated an M5-481G (which uses the same BIOS) with our most up to day bios (2.22) without issue. I've also worked with our engineers who verified 2.22 does not have an issue.

     

    Also, we have a couple FAQs related to the BIOS here: http://community.acer.com/t5/Knowledge-Base/BIOS-Update-frequently-asked-questions/ta-p/58859

  • danzmandanzman Posts: 3Member

    (Aspire M5-481PT) After updating to Windows 8.1 and the drivers I still can not make the audio work. I tried drivers from acer and from realtek. I have upgraded the bios to version 2.22. Was this a mistake? How do I revert back to previous versions? I am running out of resources (considering I am a super IT/Hardware Techie) and this is embarrassing me Smiley Embarassed I am not sure if my warranty still holds. Do I bring this back to ACER or just brick it and never buy anymore ACER products?

This discussion has been closed.

Who's Online217

birchers
birchers
Bloopiey
Bloopiey
brummyfan2
brummyfan2
Jadehibbs
Jadehibbs
Pcgamer12345
Pcgamer12345
+212 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Announcements

Five Year Anniversary

Acer Community turned 5 years old this week! I would say that's a reason to celebrate!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Member Highlight

Look at ven98 go! Raising up the ranks, helping other users in the Predator forums. Thank you for your dedication!

Total Posts and Comments: 1032

Total Points:569

Total Accepted Answers: 88

ven98 Seasoned Specialist