Examples: Monday, today, last week, Mar 26, 3/26/04

This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

Visit our Product Forums for more current content.

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Dual boot Aspire V5-122P with Window 8 and Ubuntu

wealthraiderwealthraider Posts: 2Member



I have just bought an Acer Aspire V5-122P with Window 8 loaded as a default. I personally not a big fan of Window but it comes with the laptop. So i thought i can install Ubuntu on top of Window 8 so that i can dual boot my laptop and that's what i have done for my previous laptop, which has been running more than 6 years until recently broken down. I have questions as follow:


i. Is there an issue with Window 8 and Unifi? it seems that when my laptop is connected to the Unifi via the wireless router, the connection will not be stable and tend to get disconnected on and off. My wife's Sony laptop with Window 8 encountered the same issue until Sony send a guide to fix the bug. Is there a bug to be fixed on Window 8? I am currently using teetering on my mobile and it seems to work fine but not at the speed i would expect from Unifi.


ii. How to dual boot this laptop? I have read some guides posted by some people on some othe forum. They mentioned about the the new laptop with new bios that i have to change it to "legacy". Since there's no DVD Rom comes with my laptop, i can only boot it from USB. However, once i have changed it to "legacy" the start up can never seem to boot it on the USB besides i have made a bootable Ubuntu USB. Can someone please guide me how to install Ubuntu on this laptop?




  • CoinbirdCoinbird Posts: 4Member


      Yes, it's possible!

      Bought an Aspire V5-122P yesterday from Costco and thought I'd share, since I couldn't find info on making it dual-boot linux anywhere either (found a lot of wrong information though Smiley Happy )


    More of a writeup here:

    /en/home/leaving?target=http%3A%2F%2Fubuntuforums.org%2Fshowthread.php%3Ft%3D2142786" class="Popup


    Steps I took (from memory, I think this was pretty much it.) I needed 2 USB sticks, one for recovery disk, one for Ubuntu installer.


    - Boot into Win8, make a recovery disk, and remove the recovery partition (Windows does this for you after creating the recovery disk. I used a 16 GB usb stick.)


    - Disable Windows 8 fast boot. I read there's an issue with lost data if you are dual booting and do a Windows shutdown? This step might not be necessary.


    - Shrink your partition by ~100 GB using the built-in Windows disk tool. (You can do a larger or smaller partition) This will be your linux partition.


    - Download ubuntu 64-bit 13.04 ISO. (Older versions will have issues.)


    - Download Universal USB Installer from pendrivelinux (google it, I think it's linked off Ubuntu page.) This will make a bootable USB stick. The tool will require you to tick a checkbox to see the USB drive, which mounts as D in windows 8. Leave the USB stick in the drive once it's done.


    - Windows Key + W (Search Settings), type "boot" and choose Advanced Boot Options. Then click the Advanced Reboot at the bottom, and choose EFI USB boot option. You will use this option to boot into Ubuntu later.



    - Boot, select Install Ubuntu from the boot menu. (Don't hit ESC during boot or you'll get no Desktop after the services load.) You can connect to Wifi now!


    - In the partition step at the beginning of the Install process, choose "something else" then from the space you freed by shrinking the partition, make a 16 gig swap partition and the rest (~88 gigs) an ext4 partition, mounted as "/"  I think I left the rest of the options default.


    Boot options:

    At boot, F2 to choose the ubuntu EFI in BIOS (or F12 after you enabled it)

    or, boot into win8 and Windows+W Advanced Boot, then choose EFI ubuntu


    -Next you'll see that lightdm fails to load. Fix this by installing the AMD Catalyst drivers from their website. /en/home/leaving?target=http%3A%2F%2Fsupport.amd.com%2Fus%2Fgpudownload%2Flinux%2FPages%2Fradeon_linux.aspx" class="Popup You can wget via wifi from the command line, which is a pain to type in. I installed the Beta driver, and all is good. Not sure if the older driver would work.


  • dlanghdlangh Posts: 1Member

    Good answer!  It worked for me.  I had a few hiccups that I thought I would share in the hopes of helping someone else:


    1. When running the 'Universal USB Installer' App, It worked the first time through, but after I had what I think was a bad usb stick and I re-ran it with a new stick, it would not let me choose the ISO image to save my life.  It was like it wasn't in the folder I said it was.  The solution I finally discovered was to enter '*' in the filename field in the File-Open popup dialog.  Then it listed everything in the folder and I was able to select my ISO image.  Very strange.


    2. I'm not completely sure if this is needed, but I ended up doing it both the bad stick I used and the good one.  I installed a master boot record into the stick.  I haven't really messed with bootable USB sticks in a while, but I vaguely remember this being an issue with many USB sticks.  Luckily the solution is simple, I found the answer here: /en/home/leaving?target=https%3A%2F%2Fhelp.ubuntu.com%2F12.04%2Finstallation-guide%2Famd64%2Fboot-usb-files.html.%26nbsp%3B" class="Popup Look in the section titled 'Booting the USB stick'.  Follow those instructions then use the Universal USB Installer App.  Doing this will require access to an existing Linux system FYI.



  • CoinbirdCoinbird Posts: 4Member

    Glad you got it running!

    In Universal USB Installer, you have to choose the specific ubuntu distribution; it will choose a wildcard filename that only matches that specific version (e.g. Ubuntu desktop 13.04 amd64 will only match filenames with the pattern "ubuntu-13.04*desktop-amd64.iso") The annoying thing is, when a new version of Ubuntu comes out, you need a new version of the installer (that has the new "wildcard.")


    With the distribution selected, the Universal USB installer will take care of everything, including marking the partition as bootable, so you shouldn't need to install an MBR on the stick. But, that was just my experience, it's possible your host system has some issue with USB that needed it. 

  • CoinbirdCoinbird Posts: 4Member

    Just wanted to follow up on this with a warning.


    About a month later, I was typing along in Ubuntu and the system hard-froze. Rebooting revealed that for some reason Ubuntu had been removed from the UEFI boot menu. I had backups so it was mostly just an annoyance. I wasn't able to recover my data from this; I would have tried Boot-Repair but ubuntu 13.04 doesn't boot into "Try Ubuntu" on this hardware yet; I suspect that would be the best solution.


    Also, I wasn't able to just reinstall Ubuntu by just following the same steps for some reason. WIth the same partitioning scheme, I eventually tried "Erase Ubuntu and Reinstall", assuming it would reinstall to the same partition. But, "Erase Ubuntu and Reinstall" ignores your partitioning scheme and it erased the entire drive, including windows 8.


    So, make sure you have backups of your stuff (I recommend CrashPlan.) And be sure to do the USB recovery stick creation step!


    I'm now using the system recovery USB stick made in the steps described above to reset the laptop to factory new. Very happy that Win8 has this capability! It's able to restore even though the entire hard drive was repartitioned. If I didn't need native Ubuntu for a project I'm working on, I'd probably stick to Windows 8 and run Ubuntu in a VM.


  • rempatrempat Posts: 1Member

    I am attempting to install a dual boot using Ubuntu 13.10.  When I try to boot from the stick, I first get the menu with the options of running Ubuntu without installing and the option to install. However, whichever option I choose I get a blank screen that does not respond to the touchpad, the screen touch, the keyboard.


    Should I try instead to install 13.04, or does anyone have a clue for me.

  • CoinbirdCoinbird Posts: 4Member

    I haven't had much luck with 13.10, that blank screen issue I also saw in 12.04, and I had the best luck with 13.04. You could try following my instructions above (they may be a bit obsolete) or getting an alternate (no UI, it's all text) installer. The key here is that you'll need to install the AMD driver as described above.

    You could install 13.04, then upgrade to 13.10 (keep the AMD driver so you can reinstall it.) 

    You can switch out of the "blank screen" you're seeing to a text mode command line using the ALT-F-keys.


This discussion has been closed.

Who's Online117

+115 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!


Maintenance Notice:

The Acer Community Maintenance has ended! We apologize for the delay and would like to thank everyone for their patience. We're still ironing out some details but you're more than welcome to explore! Stay tuned to the Announcements section as we'll be updating it regularly to keep you informed about the changes.

New Here?

New to Acer Community?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Member Highlight

Look at ven98 go! Raising up the ranks, helping other users in the Predator forums. Thank you for your dedication!

Total Posts and Comments: 760

Total Points:147

Total Accepted Answers: 0