image

Linux auf ACER One 10 S1003 installieren

subnoxsubnox Member Beiträge: 3 New User
bearbeitet März 2018 in Linux
Guten Tag,
Ich versuche seit ein paar Tagen Ubuntu oder ein anderes Linux OS auf mein Acer One S1003 zu installieren. Dies hat es bis jetzt nicht geklappt.
Im UEFI habe ich den Secure Boot deaktiviert und mit Easyuefi den Boot start geändert und zuerst USB gewählt. Sagt mir aber jedes Mal: "System doesn't have any USB boot otpion. Please select other boot option in Boot Manager Menu".
Ich war ebenfalls im Boot Manager Menu, dort ist nur den aktuelles Windows zu treffen.
Mein USB-Stick ist bootable und gut sauber gemacht, ich kann damit auf ein anderes Computer booten.
Habe ebenfalls probiert dies auf ein bootable Memorycard zu erstellen, macht genau das gleiche...
Ich wollte danach Windows 10 downgrade auf windows 7, habe aber kein Lizenz-nummer, da auf Windows 10 eine Elektronische-Lizenz angehängt ist...
Meine letzte Lösung:
Den UEFI flashen und eine anderen Version mit mehr Möglichkeiten auswählen, finde aber keine auf der Netz!?
Oder habt ihr anderen Ideen ?
Besten Dank im Voraus
«1

Häufig Gestellte Fragen und Antworten

  • subnoxsubnox Member Beiträge: 3 New User
    Besten Dank für deine Antwort!!
    Das hat teilweise funktioniert!
    Ich musste danach noch dies machen: https doc ubuntu-fr org/unetbootin
    Bzw. den Datei BOOT/grub/grub.cfg ändern und eben diesen Linien einfügen:
    menuentry "Install Ubuntu" {:
    	set gfxpayload=keep
    	linux	/casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash ---
    	initrd	/casper/initrd.lz
    } 

    Dann bekomme ich aber bei der Installation das nächstes Problem.
    Es meldet mir:
    Das Paket >>grub-efi-ia32<< konnte nicht in /target/ installiert werden. Ohne den GRUB-Bootloader wird das installierte System nicht booten.

    Das Paket ist auf dem USB-Stick vorhanden.
    Habe ich, hier https //wiki ubuntuusers de/EFI_Installieren/ , gefunden dass wenn die Partition nicht richtig gemacht wurde dann kann das System nicht den Bootloader kopieren.
    Bei der Installation wähle ich aber "Festplatte löschen und Ubuntu installieren".
    Besten Dank im Voraus für die Hilfe.



  • MegaParsecMegaParsec Member Beiträge: 100 Skilled Fixer
    Hi,

    ich habe leider nur ein älteres Tablet mit Intel Bay Trail. Da läuft die Installation ohne Problem durch.
    Mal zum Abgleich, die Schritte die ich unternommen habe.

    Ich habe die letzte verfügbare Ubuntu Cinnamon - Respin Version von dem nachfolgenden Link geladen.

    https://goo.gl/DfhG72

    Dann mit dem Tool Rufus das Image bootfähig gemacht.

    https://rufus.akeo.ie

    Bei Rufus unter "Partitionsschema und Typ des Zielsystems" muss man GPT Partitionierungsschema für UEFI" auswählen.

    Die Installation durchlaufen lassen und anschließend mit F2 ins UEFI.
    Dort unter Security auf "Select an UEFI file as trusted for executing" -> HDD1 -> "<ubuntu>" -> grubia32.efi auswählen.
    Dem Eintrag einen Namen geben z. B. Ubuntu und mit F10 speichern.

    UEFI erneut aufrufen und unter Boot den Booteintrag "Ubuntu" an erste Stelle setzen und (wichtig) Secure Boot aus disabled stellen.
    Der grub 32Bit Bootloader ist nicht signiert und würde sonst nicht ausgeführt werden.

    Nochmalmit F12 speichern und Ubuntu bootet durch. 

    Hoffe das hilft Dir.

    Gruß,
    MP





  • subnoxsubnox Member Beiträge: 3 New User
    Hi MegaParsec,

    Besten Dank für deine Antwort!
    Ich habe es geschaft Cinnamon zu installieren.
    Es funktionniert ziemlich gut.

    Habe aber ein weiteres Problem,
    Ich probiere seit einer Woche die Wifi Card zu installieren. Nach viel Tests und Probe, habe ich gedacht vielleicht hast du ein Typ?

    Zur Info, iwconfig zeigt kein Wirelesscard
    lspci zeigt kein WIFI
    lshw zeigt ebenfals kein wifi

    Ich habe b43-fwcutter und der b43-Firmware installiert, bin aber nicht erfolgreich gewesen.

    Gemäss den Hersteller sollte diesen Driver für die Karte gebraucht werden:
    Broadcom Wlan Driver 1.596.10.0
    Ich finde aber kein gleiches für Ubuntu.

    Besten Dank im Voraus für die Hilfe!!

    V.


  • MegaParsecMegaParsec Member Beiträge: 100 Skilled Fixer
    Hi,

    das ist wirklich ein Problem bei diesen SDIO W-LAN Karten von Broadcom.
    Damit diese von Linux angesprochen werden können, benötigst du die passende Firmware und ggf. eine Textdatei mit entsprechenden NVRAM-Parametern in dem nachfolgenden Verzeichnis.
    /lib/firmware/brcm/
    
    So wirklich sicher wie man das hin bekommt bin ich mir nicht. Wir können aber etwas rumprobieren.
    Testweise könntest du einmal den Windowstreiber von der Acer Webseite laden und die nachfolgenden Dateien des Treibers in das oben genannte Verzeichnis kopieren.

    43438a0rtecdc.bin
    43438a1rtecdc.bin
    43455c0rtecdc.bin
    4356a2rtecdc.bin
    bcm943430a1wlselgs.txt
    bcm943430wlselgs.txt
    bcm94356z_p122.txt

    Probier nach einem Neustart, ob du mit lspci oder lshw die W-Lan Kart finden kannst.

    Schau bitte auch mal auf dem nachfolgenden Link. Weiter unten der Abschnitt zur "Firmware installation / NVRAM from EFI."
    Probier das bitte auch mal aus.

    Gruß


  • PitPit Member Beiträge: 18

    Tinkerer

    Hallo.. Ich hoffe das mir hier bitte jmd weiterhelfen kann !? Nun ich habe einen Acer SW5-012 mit Windows 8.1 upgrade auf Windows 10. Es ist ein 32 Bit System und mit UEFI Boot..Festplatte bzw. Speicherkarte mit 32GB... Da ich kein Windows Fan sondern lieber wieder mit Linux arbeiten will ist es (fast) aussichtslos ;(
    Ich habe Security boost ausgeschalten u wollte Linux per USB oder DVD/ROM booten. Nur leider immer nur no boot ;-(
    Ich habe auch die Festplatte komplett gelöscht und mit gparted wieder partitioniert.. Nur das bringt nichts kein BOOTEN!!!
    Mit Linux Kali kam ich in die Version zum System zwar rein..aber leider geht es nicht zum installieren ;-(
    Bitte ich wäre sehr dankbar wenns jmd hinbekommt, da ich schon seit Wochen nach Feierabend es versuche u nicht aufgebe es hin zuu bekommen ;OD oder es gibt eine Möglichkeit für Windows 7 mit 32 Bit System zu installieren dann könnte es klappen !?
    Achso die USB Sticks mit 8GB habe ich mit Rufus/Linux Live USB Installer/ Unetbootin/ und Universall USB Installer...u mfg

    Vielen Dank für eure schnelle Hilfe und mfg. Pit ;)
  • MegaParsecMegaParsec Member Beiträge: 100 Skilled Fixer
    Hi Pit,

    also die Lösung steht hier ja schon weiter oben.
    Du brauchst ein 32Bit EFI Bootloader um einen USB-Stick an dem Tab zu booten.

    Out of the Box untertüten das momentan Fedora ab Version 27 und Arch Linux.

    https://fedoraproject.org/wiki/Changes/32BitUefiSupport

    Probier mal die Distri Antergos. Basiert auf Arch und ist einfach zu installieren.

    https://antergos.com/try-it/

    Wenn du eine andere Distribution möchtest, kannst du mit dem nachfolgenden Script versuchen den 32Bit Bootloader hinzuzufügen.

    http://linuxiumcomau.blogspot.com/2017/03/running-ubuntu-with-upstream-kernel-on.html





  • PitPit Member Beiträge: 18

    Tinkerer

    OK Danke erstmal MegaParsec für Deien rasche Antwort und Deine Tipps ;))
    Mit Fedora hab ich es schon geschafft.. Nur installiert/bootet der nur vom Usb Stick..
    Installiert ist fertig auch wlan funktioniert mit ein bißch en probieren alles gut soweit ;-)
    Nur wenn ich updates machen möchte d.h. die System updates (1,2GB) die wichtig sind, will der die immer auf die Festplatte intern speichern u nach 1 Update egal welche friet der vom system ein ;(
    Das heißt dann neustarten..Usb stick dran lassen u wieder versuchen.. Nur ich kann nicht die System updates bzw. alle updates auf meine Micro speicherkarte speichern ;( Weiß leider nicht wie und wo ??? Sonst kann ich keine updates machen u muß immer nur mit Usb stick laden..
    Ich wäre Dir sehr dankbar für einen Tipp oder ein anderes Linux was besser geht !?

    Achso ich habe schon Ubuntu netbook..Linux Suse..KU-XU-LU-Ubuntu...selbst Linux kali versucht alles geht nicht ;-(
    Obwohl beim Linux kali funktioniert die Installation fast..nur zum ende bricht der ab..alles ***** sorry ;(
    Danke Dir für Deine Hilfe mfg. Pit
  • MegaParsecMegaParsec Member Beiträge: 100 Skilled Fixer
    Hi Pit,

    klingt für mich so, als würdest du nur im Live-System des USB-Sticks arbeiten.

    Probiere mal folgendes. Starte neu und öffne das UEFI/BIOS. Wechseln auf den Menüreiter Security und wähle den Punkt Set Supervisor Password aus.
    Jetzt ein Passwort festlegen. Dann in den Menüreiter Boot wechseln und Secure Boot von Enabled auf Disabled setzen. Mit F10 speichern.

    Nochmal Fedora von dem USB-Stick booten und installieren.
    Nach Abschluss der Installation neustarten und wieder in das UEFI gehen.

    Nun unter Boot den Eintrag Secure Boot wieder von Disabled auf Enabled setzen.
    Dann unter Security den Punkt Select an UEFI file as trusted for executing auswählen.

    Wiederholt die Enter-Taste drücken, bis man die Auswahl des Boolaoders von Fedora hat.
    Müsste hier der Bootloader "grubx64.efi" sein 

    Diesen Auswählen und einen Namen festlegen. Einstellung wieder mit F10 speichern.

    Jetzt müsste das Tab auch ohne USB-Stick Fedora booten.
    Probier dann noch mal die Updates aus.

    mfg

  • PitPit Member Beiträge: 18

    Tinkerer

    OK Megaparsec.., ich habe es so gemacht wie Du geschrieben hast.. Nur im Bios kann ich nicht von HDD auswählen bzw. dort kein grub is d.h. dort steht nix drinnen ;( Hab es stick den grubx64.efi eingespeichert wie Du geschrieben hast..dann gespeichert u wollte es ohne USB Stick laden..da kam diese Fehlermeldung ;-/
    Default boot Device missing or boot failed, Insert Select Boot Manager to choose a new Boot device or to boot recovery media...bedeutet glaub ich auf deutsch...
    Standardstart Gerät fehlt oder Start fehlgeschlagen, Einfügen Wählen Sie Start-Manager, um ein neues Startgerät auszuwählen oder um Wiederherstellungsdatenträger zu starten....und wenn ich dann security failed ;( obwohl security boot aus ist...
    Was kann ich noch machen !? Ich wäre Dir sehr dankbar für Deine Hilfe ;OD mfg. Pit
  • PitPit Member Beiträge: 18

    Tinkerer

    Hey Megaparsec.. Also ich hab vom Acer die Festplatte nochmal gelöscht mit gparted uneingeschränkt installiert.. Dann im BIOS es so umgestellt wie Du geschrgesch hattest u neu gestartet mit Security Boot desabled😁👍 
    Dann startete mein Acer Tablet so siehe Bild 😁👍 Bei Security Boot enabke kommt noch boot 😣😕 Danke Dir für Deine schnelle Hilfe ich verzweifle schon 😣😣😣 
    Liebe grüsse Pit ✌️
  • MegaParsecMegaParsec Member Beiträge: 100 Skilled Fixer
    bearbeitet Februar 2018
    Hi,

    ich habe Fedora jetzt einmal testweise auf einem SW5-11 installiert. Das müsste eigentlich ziemlich ähnlich wie das 12er sein, hoffe ich.
     Die Installation und auch das System läuft, nach meiner Beschreibung. Ich habe mal Fotos gemacht.

    1. Fedora installieren, dann neustarten
    2. UEFI aufrufen 
    3. Secure Boot muss enabled sein dann auf Security gehen.
    4. HDD1 auswählen



    5. fedora auswählen



    6. grubia32.efi auswählen



    7. Dem Bootlaoder einen Namen geben



    8. Mit F10 speichern und anschließend kann Fedora gebootet werden.




    Es bootet und Updates laufen auch.




  • MegaParsecMegaParsec Member Beiträge: 100 Skilled Fixer
    Nachtrag:

    Wenn man den Bootoader von Fedora hinzugefügt hat und mit F10 gespeichert, dann muss erneut ins UEFI und der Secure Boot wieder deaktiviert werden.
    Die 32 Bit Bootloader sind nicht signiert und können daher nicht mit Secure Boot starten. 


  • PitPit Member Beiträge: 18

    Tinkerer

    Hey Megaparsec.. erstmal danke für Deine schnelle Meldung und das testen mit Deinen Tablet Pc ;-)
    Nur bis Punkt 8 komm ich, d.h. Fedora anklicken u dann kommt 2x eine Fehlermeldung von Couldn´t get sides (konnte keine Seiten bekommen) ;( Ich kotz ab es geht nicht wieso was denn noch ???
    Danke Dir wie immer für Deine Hilfe mfg. Pit
  • MegaParsecMegaParsec Member Beiträge: 100 Skilled Fixer
    Hi,

    magst mal ein Bild von der Fehlermeldung machen und posten?

  • PitPit Member Beiträge: 18

    Tinkerer

    Ok ich hoffe das Du was erkennst, denn ich hatte nur 2sek Zeit... 
    Das 2 kam vorher...und jetz is nur ein schloß zu sehn : - (
  • MegaParsecMegaParsec Member Beiträge: 100 Skilled Fixer

    hm, hast du den Secure Boot wieder auf disabled gesetzt?

  • PitPit Member Beiträge: 18

    Tinkerer

    Ja das hatte ich..
  • MegaParsecMegaParsec Member Beiträge: 100 Skilled Fixer
    ok...

    Leider erkenne ich nicht wirklich was. Sieht für mich aber wie der normale Grub von Fedora aus.
    Eine Idee, warum es bei dir nicht bootet habe ich leider nicht wirklich...

    Ist auf deinem Tab das aktuellste UEFI drauf? 
    Ist zurzeit die Version 1.20.


  • PitPit Member Beiträge: 18

    Tinkerer

    OK.. ich mache Dir mal Bilder von dem Bios.. Hoffe das Du dann den Fehler finden könntest...
Anmelden oder Registrieren, um zu kommentieren.

Wer ist online639

Acer-Samuel
Acer-Samuel
AspireV5user678
AspireV5user678
batmalin
batmalin
busolof
busolof
David_S
David_S
geraldbostock
geraldbostock
jv_jaov
jv_jaov
KanagawaTomasu
KanagawaTomasu
LinkSlotGacor
LinkSlotGacor
MarcB
MarcB
Steve423
Steve423
Tonao
Tonao
Vitall
Vitall
xapim
xapim
+625 Gäste

Mach mit! Teile deine Erfahrungen mit uns!

Anscheinend sind Sie neu hier. Um zu beginnen, melden Sie sich an oder registrieren sich.

Neu hier?

So, welche Regeln gibt es hier? Alle Regeln finden sich in der Acer Community Endbenutzer Vereinbarung. Besuche unsere Willkommensseite für eine kleine Einleitung mit den am häufigsten gestellten Fragen und vieles mehr. Informieren Dich sich über das Acer ACE-Programm und bleibe auf dem Laufenden, was es Neues in unserem Blog gibt.

Hilfe von Acer