next@acer 2020

How to disable Function Keys Travelmate P2410

RafavertRafavert Member Posts: 10 New User
Hello!

I need to disable the fn functions in my recently bought Travelmate P2410 because they're clashing with the use of an external USB numpad, which I need to work. So I want to have the numeric pad on, but also be able to use the normal keys where numpad numbers are (U - P,, J - L, etc).

I've been searching online and have yet to find a solution for this.

There's nothing in the BIOS to disable the function keys. I can't find any option for this anywhere.

PS: Running Windows 10 Pro

Anyone can help?

FAQ & Answers

  • MaClaneMaClane ACE Posts: 29,959 Trailblazer
    Good Morning Rafavert !

    Acer Quick Access controls the Fn keys.
    Take a test by removing and disabling it.


    Se minha resposta foi útil, deixe um Curtir, marque como Solucionado e clique em Promover!
    Caso contrario, fico a disposição para tentarmos sanar suas duvidas e resolver seus problemas!
    Atenciosamente:  J. MaClane™

    If my answer was helpful, leave a Like, flag as Fixed and click Promote!
    Otherwise, I am willing to try to heal your doubts and solve your problems!
    Sincerely, J. MaClane ™

    For users of the English, Spanish, French and German Community, I will be using Google Translate!
              
  • RafavertRafavert Member Posts: 10 New User
    Nope, doesn't work =(

    I uninstalled it, found no way to disable it, though.

    FN keys still working normally.


  • JackEJackE ACE Posts: 21,761 Trailblazer
    Your KB should work normally with NumLock turned off independent of the external USB NumPad. What is the NumPad model and number? Jack E/NJ
    Jack E/NJ
  • RafavertRafavert Member Posts: 10 New User
    It does work normally with NumLock off. The problem is that when I connect the USB numpad (A Mitsai Q20, btw, nothing too fancy) and turn NumLock on, the numpad in the keyboard is also activated, so I have two numpads and lose the use of some keys.
  • JackEJackE ACE Posts: 21,761 Trailblazer
    If the KB FN+F11 key combo also toggles the numpad on & off, then press the WINkey + Rkey and enter 'regedit'. Search 'InitialKeyboardIndicators'. Try setting the value to '0' if it's set to 1 or 2 to turn off the KB numlock. Jack E/NJ


    Jack E/NJ
  • RafavertRafavert Member Posts: 10 New User
    I'm afraid this didn't do anything either. The two numpads are still working. What was that regedit supposed to do, exactly?

    Again, I want to be able to connect and use a USB NumPad and have the one underneath the UIOJKLM keys disabled, but when Numlock is turned on, both the USB one and the one in the keyboard get activated. I want the one in the keyboard deactivated or removed altogether.
  • JackEJackE ACE Posts: 21,761 Trailblazer
    The regedit setting is supposed to disable the KB numlock only. But both numlocks are apparently interdependent , not independent, on your Q20. Thus the only option is to try a NumPad without a numlock (like the Targus below) or a full external KB. Both types are available wireless or wired. Jack E/NJ


    Jack E/NJ
  • RafavertRafavert Member Posts: 10 New User
    JackE said:
    The regedit setting is supposed to disable the KB numlock only. But both numlocks are apparently interdependent , not independent, on your Q20. Thus the only option is to try a NumPad without a numlock (like the Targus below) or a full external KB. Both types are available wireless or wired. Jack E/NJ


    After some search I've found one of these (this exact model, even), and yet another new problem crops up...

    When I connect that it works all right, until I try to use the Enter key on the num pad. Turns out the laptop cannot distinguish between the two! He treats both as if they were regular Enter keys, and I need both the regular and the num pad's.

    Any ideas? I'm at my wits end with this laptop and about to return it.
  • JackEJackE ACE Posts: 21,761 Trailblazer
    Do you mean the targus' enter key doesn't work? Jack E/NJ
    Jack E/NJ
  • RafavertRafavert Member Posts: 10 New User
    It works, but it's mimicking the regular Enter key. Regular Enter and numpad Enter are supposed to be recognized as separate keys.
  • JackEJackE ACE Posts: 21,761 Trailblazer
    edited April 2019
    In what way are they supposed to be recognized separately? Both my regular and numpad ENTER keys seem to behave the same in all my apps? When/where are they supposed to behave differently? It's not immediately obvious to me. Jack E/NJ
    Jack E/NJ
  • RafavertRafavert Member Posts: 10 New User
    I'm trying to use a subtitling software that uses the two keys independently:
    https://www.spotsoftware.nl

    Regular Enter is used to manipulate text, while num pad Enter is used to mark the incue of a subtitle.

    I've used SharpKeys and can confirm both are being read as "Special: Enter (00_1C)" (the default), but num pad one should be "Num: Enter (E0_1C)".

    If I change one using SharpKeys, it changes both.
  • JackEJackE ACE Posts: 21,761 Trailblazer
    I see. So I would think you should be able to remap the ENTER keys separately by using a full size USB or BT keyboard/numpad combo instead. Correct? Jack E/NJ 
    Jack E/NJ
  • RafavertRafavert Member Posts: 10 New User
    Indeed. I used a USB keyboard to get those key codes. The USB numpad with num lock  also reads it as Num: Enter (and would work perfectly, if not for the numpad overlapping with the keyboard)
  • JackEJackE ACE Posts: 21,761 Trailblazer
    So you're saying the ACER NUMLOCK key must be toggled on or the Targus won't work. But then both ENTER keys are NUM ENTER?  Jack E/NJ
    Jack E/NJ
  • RafavertRafavert Member Posts: 10 New User
    No, no, the Targus numpad doesn't require the numlock at all, as intended, but both Enter keys are "Special: Enter".

    The USB numpad I mentioned is a different one with its own numlock key, a Mitsai, which posed a problem earlier, hence why I had to look for the Targus one. The Mitsai one has the "Num: Enter" key, but activating it's numlock also actives the numpad underneath the regular keys, like I said in the first post.
  • JackEJackE ACE Posts: 21,761 Trailblazer
    OK. So does toggling the ACER's numlock off also turns the Mitsai's numlock off? And vice-versa? Jack E/NJ
    Jack E/NJ
  • RafavertRafavert Member Posts: 10 New User
    Yes, it does. With the Targus one, the numlock only activates the numpad in the keyboard.
  • JackEJackE ACE Posts: 21,761 Trailblazer
    It might be worth contacting Mitsai to see if firmware might be available to isolate the Mitsai's numlock from the ACER's numlock. And also contacting Targus to see if its EnterSpecial key can be configured as EnterNum key. Jack E/NJ


    Jack E/NJ
Sign In or Register to comment.

Who's Online776

738
738
antonioflores20
antonioflores20
Arif94
Arif94
Beingastan
Beingastan
CamiloGomez
CamiloGomez
CJSoCool420
CJSoCool420
Ebanescence
Ebanescence
HartHart05
HartHart05
HeinzDBV
HeinzDBV
kirvz123
kirvz123
MAXIMO9702
MAXIMO9702
rennschwein
rennschwein
RJ008
RJ008
Zimex_LH
Zimex_LH
+762 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We want to recognize GAMING6698's dedicated efforts in the Acer Community. GAMING6698 has become one of the main collaborators since joining the Community in November of 2019.
On behalf of all our users and the Acer Team, we thank you for your dedication!

Total Posts and Comments: 3315

Total Points:5722

Total Accepted Answers: 288

GAMING6698 Mainframe Wrangler