Acer Aspire E15 How can I boot from a USB in UEFI mode?

SixtyforceSixtyforce Member Posts: 6

So I have bought an Acer Aspire E15 for school at the beginning of the year but the thing is I want to boot to a Linux USB. This is no problem with Booting in Legacy mode but I want to boot into UEFI mode to see if it would make a difference since the Linux Distro I'm using doesn't display correctly. Nothing major Just composting doesn't work. And my BIOS doesn't want to read it when it's on UEFI mode. I go into the menu to select the USB but it simply isn't there at all. Like.... At all. It only shows Windows Boot manager. Help, anyone?

FAQ & Answers

  • IronFlyIronFly ACE Posts: 18,413 Trailblazer

    Ubuntu x64 will boot under UEFI settings for sure, just burn the .iso file to a Flash Drive using Rufus and partition scheme as UEFI only.


    at boot press F12 and choose your Flash drive as bootable device, if F12 doesn't work, enter BIOS pressing F2 and enable boot list (F12), then save and exit.


    to narrow booting problem, you can try to disable secure boot too:

    I'm not an Acer employee.
  • JordanBJordanB ACE Posts: 3,729 Pathfinder


    If your current hard drive is using legacy MBR partition'll need to wipe the HDD with diskpart clean and then load BIOS defaults.


    Some people use the convert GPT command to ensure drive is initialized GPT


    So from an admin command prompt outside of windows...



    diskpart>list disk

    diskpart>select disk ?


    diskpart>convert GPT



    ? is the drive you want to wipe clean


    I use a vanilla Windows 10 media to get an admin command prompt


    When you see the screen below on the bootable windows 10 media, press Shift-F10 to get to admin command prompt






    untick the box that says "use this computers default settings" when creating your win10 you can use media repair tools on any computer.


    Edit: If you need help disabling "Secure Boot" in your UEFI/BIOS, please ask.


    I'm not an Acer employee.
  • SixtyforceSixtyforce Member Posts: 6

    I know how to access the F12 boot menu and it doesn't show up Plus Rufus keeps crashing whenever I press the button to look for an ISO. Anymore help?

  • SixtyforceSixtyforce Member Posts: 6

    The USB option isn't showing i mean. Smiley Tongue

  • IronFlyIronFly ACE Posts: 18,413 Trailblazer

    i never heard about Rufus crashes, try to run it as administrator, by the way...
    you can try to create it manually:

    I'm not an Acer employee.
  • SixtyforceSixtyforce Member Posts: 6

    So I tried the Manual method since rufus still isn't working. And it... Still didn't work. Nothing. Is there something wrong with my PC. I got the Windows 10 Upgrade. Is that a part of it or something?

  • IronFlyIronFly ACE Posts: 18,413 Trailblazer

    nope, not a windows 10 update problem.


    have you disabled secure boot?


    can you post the exact model?



    I'm not an Acer employee.
  • SixtyforceSixtyforce Member Posts: 6

    I'll check my BIOS for Secure boot. Is it suppose to be disabled? Also My model is E5-521-45BU.

  • SixtyforceSixtyforce Member Posts: 6

    And secure boot is already on.

  • IronFlyIronFly ACE Posts: 18,413 Trailblazer

    disable just to test if the USB flash drive became visibile on the boot list.


    if you have another PC, please try to create the USB bootable media with Rufus and/or use another USB another flash drive.

    I'm not an Acer employee.
  • VsarvaiyaVsarvaiya Member Posts: 2 New User
    Hi frnd anyone can help me plz
    I have a acer aspire es1 533 laptop
    Plz someone tell me how can I boot this this laptop cannot show USB or CD in boot or no legacy mode only uefi mode so
    Anyone can help me how to install in Windows 10 
    My no is 9904873590
    Or emails is [email protected] 
    Plz any one can help me
  • asasingh864asasingh864 Member Posts: 1 New User
    window 7 is not installing Acer Es1533 because of UEFI mode and there is no LEGACY mode pls help me how to install window 7 I tried many time but window 7 didn't install... I created UEFI bootable window 7 after that it didn't install.....pls help me
  • MNHACKERMNHACKER Member Posts: 2 New User
    Hello, I have a problem I'm grateful to help.
    My laptop is an Aspire E15 model of the E5-553G-T1F7.
    Windows Me is 10 and I want to install a Windows Linux-based system along with my windows, but it will be restarted when installing the laptop and the installation process starts from the beginning. If you can, please help me.
    I'm sorry if I was wrong in the post because I am an Iranian and I do not know English very much.
  • nightclownnightclown Member Posts: 2 New User

    To disable the secure boot option it is necessary that you establish a supervisor password, after doing so the option will be available
Sign In or Register to comment.

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer

Drivers &