Aspire E1-510 Windwos 7

cyberpepe Member Posts: 1 New User
edited August 2023 in 2018 Archives



Ich habe 4 Stk. Aspire E1-510 erworben, und unglücklicherweise lässt sich momentan kein Windwos 7 auf diesen Geräten installieren.


Ich habe mich schon über die Thematik schlau gemacht, UEFI ist aktiviert (was sich ja bekanntlich bei diesem Gerät nicht auf "legacy" umstellen lässt), "Secure Boot" ist jedoch nicht aktiviert.


Grundsätzlich steht einer Windwos 7 Professional x64 installation also nichts im Wege (technisch gessehen)


Leider startet das Setup, bricht dann aber ab, bzw. friert mit rotem Balken ein. (-> ähnliches Thema bereits im Forum, jedoch ohne Antwort)

Also habe ich versucht, einen UEFI fähigen USB Stic zu erstellen, der jedoch nicht laden kann -> Fehlercode 00000xd bla bla bla...


Hat irgendwer das Problem in den Griff bekommen, und auf diesem Gerät Windows 7 installieren können?



For english users:



I have purchased 4 pcs Aspire E1-510, and unfortunately can not currently install Windwos 7 on these devices.

I have made smart already on the topic, UEFI is enabled (which is well known in this unit does not switch to "legacy"), "Secure Boot" is not enabled.

Basically a Windwos 7 Professional x64 installation, nothing stands in the way of (technical gessehen)

Unfortunately, the setup starts, but then breaks down, or freezes with a red bar. (-> Similar topic already in the forum, but no answer)

So I tried to create a UEFI-enabled USB Stic, but which can not invite -> error code 00000xd bla bla bla ...

Has anyone get the problem under control, and can install Windows 7 on this device?



  • brummyfan2
    brummyfan2 ACE Posts: 28,199 Trailblazer

    How did you create the bootable USB stick? give this free program a try:

    let us know the outcome.

  • enes
    enes Member Posts: 5 New User

    Did anyone successful install Windows 7 on this notebook? I make Win7 UEFI instalation USB, but I still cannot install Win7. Any idea? It seems that Acer blocked Win7?!


    P.S. In BIOS I cannot make any changes about Security. Is this normal?!

  • Blayn-Acer
    Blayn-Acer Administrator Posts: 2,355 Community Administrator

    In looking into what you have reported, I see this system uses the Bay Trail chipset, which was not qualified to run the Windows 7 operating system. This system is not able to boot from “traditional” bootable CD/DVDs and flash drives, therefore, there is no legacy option in the system BIOS. You can boot the system from bootable media, however, it must contain UEFI boot files or WinPE 4.0 or 5.0.

  • baidrk
    baidrk Member Posts: 5



    It works with update/change in BIOS


    1. Download the file E1-510BIOS.Zip from the below FTP site

       URL –[edited to comply with guidelines]

       User name – [edited to comply with guidelines]

       Password -[edited to comply with guidelines]

       Folder name – E1-510BIOS

    2. Make the pen drive ready by formatting with Fat-32 file system

    3. Extract the file to the USB pen drive, which will create a bootable pendrive.

    4. Connect the pen drive to E1-510 notebook where the BIOS have to be updated.

    5. Ensure that the notebook is plugged with the AC adapter and the battery is also having the charge of 40%.

    6. Press F12 and power on the notebook to select the Boot option.

    7. Select USB Boot and press enter, Notebook will boot from the USB Pen drive with the command prompt window.

    8. Type C:\ which will be the root of the Thumb drive.

    9. Type Z5WE3207W.exe which will start updating the BIOS.

    10. Follow the steps displayed in the screen.

    11. After completing the BIOS update the Notebook will take 1 minute to power on.

    12. Press F2 and get into the BIOS setup.

    13. In the BOOT Menu there will be the option for UEFI / Legacy mode

    14. To load Windows 7 change to legacy mode.

  • jink
    jink Member Posts: 3 New User

    Help me need bios e1-510 for install windows 7. UEFI / legacy


  • enes
    enes Member Posts: 5 New User
    Sorry, but you must find a way to get it... Here we cannot post it.

    Anyway, I have question - is this BIOS really works? Are we get Legacy mode with it on E1-510 notebook? Maybe this BIOS will show soon on acer support page?
  • jink
    jink Member Posts: 3 New User

    New bios really works, it activates the legacy. (Z5WE3207W)

  • osalas
    osalas Member Posts: 1 New User

    Please send me the bios. I have the same problem and can not solve.


    I can not find the file anywhere (Z5WE3207W.exe).



  • pretorianbr
    pretorianbr Member Posts: 4 New User

    Dear Friend,


    I spend a lot of time to find the font of this information.


    Aparently the blog with the correct information is off and the solution for this was to search again e run with google cache, after that i found the correctly archive.

    So, check this steps


    1. Search in the google for "E1-510BIOS.Zip"

    2. Probably the first item is a site

    3. the blog is disable, so you need to open with googlecache.

    4. After this, you can see the information what you need, and download ao files to fix this problem.

    5. I make a new post in my personal blog, but it is probably not google first option, so make a new search.

    6. Dont give up, I work an entire day in this.


    Give a big THANKS TO "baidrk" for sharing the information !!!


    In the future I will be think in a buy a new acer notebook.

  • CoupDeVille
    CoupDeVille Member Posts: 1 New User

    Can someone please email me this file.   I will PM you with email.  Thanks !

  • rolf24
    rolf24 Member Posts: 2 New User

    go to driver download in the official page of acer, after you find your model, and you will find it there.

  • rolf24
    rolf24 Member Posts: 2 New User

    yes this solution realy work, i'm installing right now windows 7,  thanks a lot man

  • niemand
    niemand Member Posts: 6 New User

    So has any one managed to install Win 7 (x64) on the existing GPT drive on this laptop??

  • tecky
    tecky Member Posts: 1 New User


      update ur bios by downloading the patch file from acer site under drivers and manuals section or take it to a acer service center to update it.but if u want to update it urself u will have to install win8 first and then follow instructions given in the patch file to update the bios.but after installing the bios u will have to hustle a lot to find the required drivers.

  • ziizou_23
    ziizou_23 Member Posts: 3 New User

    the flash is working but if someone have troubles to select the path C: . you can try other letters like B: or E: for me E: worked instead of C:

  • toma_man
    toma_man Member Posts: 1 New User

    J have trouble with path C: and J change to>   D:  but is not recognized. After  write E;  and F:. When write F: and click enter

    and write Z5WE3207W.exe  is started  Smiley Happy

  • ElizabethS
    ElizabethS Member Posts: 845 Practitioner WiFi Icon

    While our members are generally eager to provide useful information, be advised that Acer does not validate third party external links for downloads or content and is not responsible for them. Acquiring files through such links or using directions found there is at the user’s own risk.

  • ziizou_23
    ziizou_23 Member Posts: 3 New User

    my friend . on the step 8. Type C:\ which will be the root of the Thumb drive.  ...... if the C: doesn't work for you just try to type D: . E: . or F: & when one o the letters work type Z5WE3207W.exe & it shall start right away Smiley Wink

  • clarencefm
    clarencefm Member Posts: 2 New User

    I have a similar problem where my Acer E1-510 just cant boot from USB nor DVD, so i dont know how to proceed and update the bios! My initial problem is a forgotten WIN8 password and all i need is to boot a win8 dvd and get to a command prompt. From there I can find my way. So far I have no joy searching all over the net. Any solution yet?