image

OJO 500 left controller batteries always low.

ThanatewaThanatewa Member Posts: 3 New User
 OJO 500 left controller batteries are always low even I try to used new batteries but it did not work. I can use it for a few minutes and it over again.
May be, battery level has some error.
What can I do?
Reset the controller? or
Update firmware?
Please, help.

Best Answer

  • billseybillsey ACE Posts: 25,397 Trailblazer
    Answer ✓
    Do you see any corrosion on the battery contacts? Sometimes when a battery has leaked the contacts get corroded and that can act like a low battery.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.

FAQ & Answers

  • billseybillsey ACE Posts: 25,397 Trailblazer
    Answer ✓
    Do you see any corrosion on the battery contacts? Sometimes when a battery has leaked the contacts get corroded and that can act like a low battery.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • ThanatewaThanatewa Member Posts: 3 New User
    billsey said:
    Do you see any corrosion on the battery contacts? Sometimes when a battery has leaked the contacts get corroded and that can act like a low battery.
    thanks, I cannot see any corrosion but I will try cleaning it first.
  • ThanatewaThanatewa Member Posts: 3 New User
    Thanatewa said:
    billsey said:
    Do you see any corrosion on the battery contacts? Sometimes when a battery has leaked the contacts get corroded and that can act like a low battery.
    thanks, I cannot see any corrosion but I will try cleaning it first.
    It's WORK!! I cleaned it follow this link  and it's solved.
    Thank you so much.
  • sammorrissammorris Member Posts: 2 New User
    Thanatewa said:
    Thanatewa said:
    billsey said:
    Do you see any corrosion on the battery contacts? Sometimes when a battery has leaked the contacts get corroded and that can act like a low battery.
    thanks, I cannot see any corrosion but I will try cleaning it first.
    It's WORK!! I cleaned it follow this link  and it's solved.
    Thank you so much.
    Thanks for the detailed video, it really help me out!
Sign In or Register to comment.

Who's Online1.1K

Acer-Samuel
Acer-Samuel
Acer-Wick
Acer-Wick
agustinquipildor
agustinquipildor
Andrew_Sn
Andrew_Sn
Camiloleon
Camiloleon
COMPUDUDE
COMPUDUDE
Facchini
Facchini
GleydsonV
GleydsonV
IVAN_PC
IVAN_PC
Jack22
Jack22
Jaroq
Jaroq
johnbeaumaris
johnbeaumaris
Josselin
Josselin
Kno63
Kno63
Marciowo
Marciowo
MaxGarridan
MaxGarridan
PaulinXp
PaulinXp
Rafael09
Rafael09
rafaelsoaresbr
rafaelsoaresbr
RenanVilela
RenanVilela
ruletheskies007
ruletheskies007
TSAFADI98
TSAFADI98
Vikingo29
Vikingo29
+1K Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers