image

predator 15 G9-593 won't turn on

I0I0 Member Posts: 4 New User
edited July 23 in Predator Laptops
Hi all,
I've got a predator 15 G9-593 that just blinked off the other day and when I tried to start it again, the fans didn't come on and the screen stayed dark - only the power button lit up. I tried doing a pinhole battery reset but that didn't help and since then, the power button only lights up when I press it when the laptop is plugged in. The light then goes out immediately when I unplug it and if I try anything without the laptop plugged in, it's completely unreponsive.

I talked with support and the only thing they could tell me was to send it in to a service center since it's still under warranty. The problem is, I bought the laptop in the US but now live in Spain, and they'll only honor the warranty in the country where I bought it. Obviously it could be pretty time consuming and expensive to send it overseas for repairs.

From what little I've gathered from google and the forums here, this sounds like a battery problem, and I've had similar problems in the past (laptop not waking up from sleep so I have to force shut down and start again, or laptop unresponsive with fans and screen off but processor was still working, overheating laptop until I disconnected the battery).

My question is, how confident can I be that changing the battery would fix this?

I plan to first open up my laptop and try disconnecting and reconnecting the battery again, and making sure the pinhole reset button didn't get stuck down or something, but if that doesn't work, does anyone have some insight or recommendation?

Thanks,
J

​//Edited the content to add model name.

Best Answer

FAQ & Answers

  • EaswarEaswar Ally Posts: 4,890
    Hi I0,

    Are you getting any light indication when charger is connected.
  • I0I0 Member Posts: 4 New User
    Easwar said:
    Hi I0,

    Are you getting any light indication when charger is connected.
    Yes, when I plug it in, the battery indicator comes on and when I press the power button, the power indicator comes on. With no charger, nothing.
  • I0I0 Member Posts: 4 New User
    edited July 21
    Update: I've opened the computer up and the battery reset button does look a bit broken compared to other pictures I found. The smaller square looks a bit crushed and dimpled. Maybe this isn't what caused the issue in the first place but is something that happened when I did the pinhole reset.
    I didn't see anything else strange so I disconnected and reconnected the battery and put it back together. Still doesn't work, behaves the same as before.
  • EaswarEaswar Ally Posts: 4,890
    Hi I0,

    Is your unit battery charged enough to run the system. How long you charge the unit.
  • I0I0 Member Posts: 4 New User
    Easwar said:
    Hi I0,

    Is your unit battery charged enough to run the system. How long you charge the unit.
    It is, battery has full charge.
  • EaswarEaswar Ally Posts: 4,890
    Accepted Answer
    Hi I0,

    It looks like hardware issue. Contact acer tech support,


    https://www.acer.com/ac/es/ES/content/service-contact


    OR book the unit for repair service,

    https://customercare.acer-euro.com/customerselfservice/CaseBooking.aspx?CID=ES&LID=SPA&OP=1

Sign In or Register to comment.

Who's Online674

billsey
billsey
Black_WindowsBA
Black_WindowsBA
dh666
dh666
DocD
DocD
drale
drale
Furthy
Furthy
GabrielVieira
GabrielVieira
JackE
JackE
JusALee
JusALee
JúliaF
JúliaF
Kevinhalby
Kevinhalby
Kobredabre
Kobredabre
MajinOne
MajinOne
PGrahamS
PGrahamS
RussianEscort
RussianEscort
StevenGen
StevenGen
William_mk2
William_mk2
xapim
xapim
+656 Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos