AXC-603-ER12 BIOS update error ROMID is not compatible with existing BIOS ROMID

compis
compis Member Posts: 14

Tinkerer

edited December 2023 in Legacy Desktops

I have an AXC-603-ER12 running with current rom version P11-B4 i am trying to update to the latest version P11.B4L. I have downloaded the update folder BIOS_Acer_p11.B4L_A_A and when I try to install I see that the FSF checksum is OK, but it gives the error

4-ErrorL ROM file ROMID is not compatible with existing BIOS ROMID.

Why can I not upgrade ?

[Edited the thread to add model name to the title]

Answers

  • billsey
    billsey ACE Posts: 31,153 Trailblazer

    P11-B4L is only used for incompatibilities with some Linux systems. If you aren't running Linux the current version is P11-B4.

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • compis
    compis Member Posts: 14

    Tinkerer

    I am using linux and I also experience the incompatibility with the screen display.

    Why is it not upgrading ? Can I confirm the ROM ID ?