TravelMate P216-51-TCO Docking type-C USB Docking station 3 disconnecting internet

gerektipcars
gerektipcars Member Posts: 2 New User
edited December 2023 in TravelMate and Extensa

Hello,

I have an Acer USB type C docking station 3 connected to a TravelMate P216-51-TCO laptop via USB C. I have an Ethernet cable and an external monitor connected to the docking station. I find that from time to time at various times the internet connection gets disconnected and I have to physically disconnect and reconnect the cable. I tried to upgrade the dock firmware using tool from the official acer site, but I get an error see screenshot.

How can I solve this error or how can I solve the internet disconnection problem. Thanks

[Edited the thread to add model name to the title]

Best Answer

  • billsey
    billsey ACE Posts: 31,167 Trailblazer
    Answer ✓

    Fire up Device Manager to see if the USB ports or Ethernet port are set to turn off to save power. That error doesn't seem to be directed at the Ethernet, it looks like the display.

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.

Answers

  • billsey
    billsey ACE Posts: 31,167 Trailblazer
    Answer ✓

    Fire up Device Manager to see if the USB ports or Ethernet port are set to turn off to save power. That error doesn't seem to be directed at the Ethernet, it looks like the display.

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • Kaya84
    Kaya84 Member Posts: 2 New User

    Hey! I have the same error.

    First of all (I don't know why) to upgrade the firmware, you need to connect a display to HDMI port.

    I already upgraded to last version, but no luck. (only with DP port)

    Any advice?

  • gerektipcars
    gerektipcars Member Posts: 2 New User

    Seems like turning off power saving on USB ports and ethernet ports did it. Thanks! Haven't got disconnected since.

    But the firmware upgrade doesn't work for me even with monitor plugged in via HDMI, still get the same error.