Acer Swift Go 16 (SFG16-71-72A) WIFI Speed dropped tremendously.

gankianteck
gankianteck Member Posts: 6

Tinkerer

Hi hi, I just bought a new Acer Swift Go 16 Inch (SFG16-71)

Not sure if anyone encounter this issue.

When I just got the laptop setup, before Windows Update, I did a speed test, I was able to reach more than 200 Mbps. Using home WIFI.

After I perform Windows Update, I noticed the internet speed was slow. Then I did another speed test. I was only able to obtain 10 to 20 Mbps.

Is there anything wrong with the driver or something.

I have 2 other laptops (Lenovo and Dell), the speed test results were quite consistent, around 200 Mbps. Using home WIFI.

Answers

  • gankianteck
    gankianteck Member Posts: 6

    Tinkerer

    I just did some trial and error.

    I noticed after I remove the Windows Update KB5032007, and rebooted the laptop, my WIFI speed test can go beyond 200Mbps, which is about the same as my Dell and Lenovo laptop.

    What's going on?

  • gankianteck
    gankianteck Member Posts: 6

    Tinkerer

    Strangely, after sometime, the WIFI speed dropped back to 10 to 20MBps, whereas my Dell and Lenovo still getting 200++ Mbps.

  • billsey
    billsey ACE Posts: 31,167 Trailblazer

    Likely not the update then. Do you still have the trial antivirus installed and running? That can really affect performance…

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • gankianteck
    gankianteck Member Posts: 6

    Tinkerer

    I just removed the trial McAfee LiveSafe and rebooted the system, the problem still persist.

  • gankianteck
    gankianteck Member Posts: 6

    Tinkerer

    I just learnt from someone who posted in MS forum, tried to restart the WIFI Network Adaptor, then it the speed is back to normal, e.g more than 200 Mbps, using home WIFI.

    I'm still observing how long does the effect last. Someone also recommended to disable the Killer Network Service, which I have not try it yet.

  • gankianteck
    gankianteck Member Posts: 6

    Tinkerer

    I disabled the Killer Network Service, and up till now, then WIFI speed is normal (more than 200 Mbps).