Predator Z301C not working anymore / Blackscreeen - no Backlight - Just blue powerlight (DE/EN)

DarkAltairx
DarkAltairx Member Posts: 2 New User
edited May 2023 in Predator Monitors

Hello together,

yesterday everything worked fine and today when i came home I turned on the pc as always but quickly realized that only my second (old and bad) monitor worked and showed me my windows screen. i checked if my predator curved monitor was on and did a quick, plug out - plug in check. nothing. i disconnected all cables, reconnected them and pressed the power button for at least a minute. Nothing. the strange thing is that not a single button on the back works anymore, I cant get to any settings within the monitor. i connected my mac with the monitor (via hdmi) and strangely enough my mac recognizes the monitor and i can get to it with the mouse but it stays black and there is no backlight, just the blue light that indicates that the monitor is activated. strangely my computer didnt realize the monitor was plugged in (via dvi) and just shifted all the icons to the second monitor.

Anyone ever had similar issues or knows what to do? i really need that monitor and am not in the position atm to buy a new one :/

Greetings and thanks in advance

(Antworten auch in deutsch möglich)

Answers

  • billsey
    billsey ACE Posts: 31,153 Trailblazer

    Disconnect all cables and press the power button for 60 seconds. Only after that do you reconnect the cables. That forces an internal reset and should get it back if it's only confused.

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • DarkAltairx
    DarkAltairx Member Posts: 2 New User

    i did that. i think the screen just randomly broke =( really sad about that…

  • billsey
    billsey ACE Posts: 31,153 Trailblazer

    Yup, if the reset didn't fix it and you don't see a splash screen when you first turn it on for a few seconds, then it's an internal problem. :(

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • Lleweilyn
    Lleweilyn Member Posts: 1 New User

    Hello, I literally got the same problem of black screen, no splash screen with blue light. I tried holding down the power button for a minute, but to no avail.
    Does anybody found a fix ? Or even repair is possible ?

  • billsey
    billsey ACE Posts: 31,153 Trailblazer

    Did you have the power cord disconnected while holding the power button?

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.