Aspire Z5801 BIOS version P01.A2 possible bug

FamilyTech
FamilyTech Member Posts: 7 New User
A family member has a Aspire Z5801 All-in-One, that was being used as a TV. It is also a PC, but had a problem with Windows 7, so it was only being used a a TV. Let me upgrade it and you'll have both devices working again, I said. I upgraded the memory to 16GB. Took out hard drive and replaced with a SSD and installed Windows 10 Pro. Windows 10 installed very nicely and is working very good. Problem is the HDMI 1 and 2 in ports will not allow any sound through. Video is okay. Audio is okay on the PC side. I did upgrade the BIOS to P01.A2. The ACER Menu Display is version 1.58. I can't see how anything I did, would interfere with the input sources audio, other then the BIOS upgrade. I don't see anything in the BIOS settings that would disable the audio on those ports. Acer menu "input setting" is set to the port which has the HDMI cable connected (not sure if that setting is referring to audio). Any one run into this problem? Solution? I'm sure the video-in feature is not a highly used feature that someone would notice this problem. I broke their TV but they now have their Desktop working again :)

Answers

  • JackE
    JackE ACE Posts: 44,098 Trailblazer
    Heh-heh. I feel your pain. Despite the hype, Win10 still is --- and never was --- quite fully compatible with many legacy BIOS machines. So to try to save the Win10 install, I suggest that you first run a few driver search freeware tools like iobit's Driver Booster and others listed here  to see if they can pick up anything better on line that might fix the HDMI audio output. If they don't work, we can try a few other tricks to salvage the Win10 install.


    Jack E/NJ

  • FamilyTech
    FamilyTech Member Posts: 7 New User
    Hi JackE: Thanks for the response. I don’t think it is a Windows problem. My reasoning: They were using the Aspire as a TV, Windows 7 had a problem loading, so Windows wasn’t even being used and the TV worked. They turned on the desktop and selected video source from the right-side buttons on the outside frame of the Aspire. Nothing to do with Windows. It’s HDMI inputs that are the problem, not HDMI outputs. A unique problem, because most desktops don’t have HDMI inputs.
    Ray
  • JackE
    JackE ACE Posts: 44,098 Trailblazer
    OK. Gotcha. Open Control Panel. Search 'button'. Click 'change what the power buttons do' in left pane. Click 'change settings that are currently unavailable' near top of next screen. Scroll down and uncheck the box for fast startup. Shut down Windows normally. Then do what they did before.


    Jack E/NJ

  • FamilyTech
    FamilyTech Member Posts: 7 New User
    Tried what you suggested. No luck.
    I also tried removing the CMOS battery to reset the BIOS settings. No luck with that either. I thought of going back on the Firmware version but Acer doesn't list a previous version for this model.
  • JackE
    JackE ACE Posts: 44,098 Trailblazer
    edited August 2022
    >>>I did upgrade the BIOS to P01.A2>>>

    Do you recall what the previous version was? Often can found on firmware archive sites. But generally riskier to backdate than update.

    PS: Also make sure fast startup is still unchecked. Windows update service will often turn it back on when you're not looking.

    Jack E/NJ

  • FamilyTech
    FamilyTech Member Posts: 7 New User
    I’m assuming it updated the Firmware. The updater didn’t complain that it was already updated. No message at end of process that it was completed either. First time working on an Acer. Very risky I’m sure. They could end up without a TV and a computer. I’d advise them to leave as is. I see you are very busy on this site.
  • JackE
    JackE ACE Posts: 44,098 Trailblazer
    Out of curiosity, open Device Manager to see if there are any red or yellow warnings? There are some Win8x TV tuner drivers for this model that may leave an imprint on the BIOS even after Windows is shutdown. They might affect the HDMI input section.  They also might have to be installed in Win8x compatibility mode. Maybe worth a try without a significant risk of bricking machine?

    Jack E/NJ

  • FamilyTech
    FamilyTech Member Posts: 7 New User

    Sorry for the slow response. There wasn't any warnings in Device Manager. I had tried those four tuner drivers before with no result. I tried them again with a focus on compatibility mode but the downloads don't give you the option for Compatibility Mode. The installers do run and after each I looked to see if there was any additions in the BIOS and Device Manager after a restart. Thanks for all your time in trying to solve this problem. The BIOS does have an onboard audio device listing, no name description and only has option for enable/disable. It was enabled. I tried disable and the PC then has no audio. Nothing in the BIOS for video or inputs.

  • JackE
    JackE ACE Posts: 44,098 Trailblazer

    >>>I tried them again with a focus on compatibility mode but the downloads don't give you the option for Compatibility Mode.>>>

    Did you right click properties of the EXE file instead of the BAT file for the Win8x compatibility mode tab? Win8x EXE compatibility mode should be a property of Win10 OS, not the Win8x EXE file

    Jack E/NJ

  • FamilyTech
    FamilyTech Member Posts: 7 New User

    I looked at the properties of the different files that downloaded and didn’t see an exe, which I was looking for. The installers do run though.

  • JackE
    JackE ACE Posts: 44,098 Trailblazer

    You must have the view system file extension disabled or hidden. The EXE setup file is in the unzipped tuner subdirectory like shown below.



    Jack E/NJ