Windows 11? Predator Helios 500 PH517-51

Options
brwster455
brwster455 Member Posts: 42 Enthusiast WiFi Icon
edited December 2021 in Windows 11
Anybody have any problems with updating or clean installing   Windows 11 on Helios 500? 
Like drivers, undervolting or Predator sense not working.


Acer Predator Helios 500 (PH517-51)
Processor i7-8750H
Memory 16GB DDR4
Samsung 970 EVO Plus 500GB NVMe boot drive
Intel Optane 32 gigs Memory to boost secondary mechanical HDD
HDD 1TB Harddrive
GPU Nvidia GTX 1070
Killer Wirless AX Wifi 6 1650 Network Adapter E2500 GB Ethernet Controller
Chipset Intel HM370 with Thunderbolt 3

Answers

  • xapim
    xapim ACE Posts: 7,257 Pathfinder
    edited December 2021
    Options
    brwster455 my advice wait a few more years before upgrading to win11 loads of issues and bugs to get sorted  but if you really want to do it at your own risk also check the acer win11 supported compatibility list good luck :)


    https://www.userbenchmark.com/UserRun/11532543

    UserBenchmarks: Game 43%, Desk 61%, Work 40%
    CPU: Intel Core i5-7300HQ - 63.5%
    GPU: Nvidia GTX 1050-Ti (Mobile) - 41.9%
    SSD: WDC WDS200T2B0B-00YS70 2TB - 71.4%
    HDD: WD WD10SPZX-00HKTT0 1TB - 93.7%
    RAM: Kingston HyperX DDR4 2666 C15 2x16GB - 76.8%
    MBD: Acer Predator G3-572

    I'm not an Acer employee. (just here to help in the best way i can)
    If my answer fixed you issue please accept it for any other users who search for it would find it quickly thanks :)
    If you want to learn more about undervolting/optimizing windows join the Predator fb group and youtube channel:

    Owner/Admin (HOTEL HERO/Red-Sand/Opoka Opoka)
    https://www.facebook.com/groups/PredatorHelios300
    https://www.youtube.com/channel/UCNJwGUHxSJ8FKqAhnOqQuAw
    Acer support:
    https://www.acer.com/ac/en/US/content/service-contact
    http://www.acer.com/worldwide/support/  


  • billsey
    billsey ACE Posts: 32,277 Trailblazer
    Options
    There shouldn't be any problems on the Windows 11 side, though I believe you will want to wait for Acer to release a newer version of PredatorSense, there have been reports of the W10 version not working in W11.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • Gunraajsingh
    Gunraajsingh Member Posts: 14

    Tinkerer

    Options
    Anybody have any problems with updating or clean installing   Windows 11 on Helios 500? 
    Like drivers, undervolting or Predator sense not working.


    Acer Predator Helios 500 (PH517-51)
    Processor i7-8750H
    Memory 16GB DDR4
    Samsung 970 EVO Plus 500GB NVMe boot drive
    Intel Optane 32 gigs Memory to boost secondary mechanical HDD
    HDD 1TB Harddrive
    GPU Nvidia GTX 1070
    Killer Wirless AX Wifi 6 1650 Network Adapter E2500 GB Ethernet Controller
    Chipset Intel HM370 with Thunderbolt 3

    i have ph517-51 but after installing audio drivers are not working so i say dont do it
  • LI78
    LI78 Member Posts: 8

    Tinkerer

    Options
    Acer Team sleeping???
  • billsey
    billsey ACE Posts: 32,277 Trailblazer
    Options
    This is a community forum and everyone here (other than the moderators) are other Acer customers, not Acer support, engineers or marketing.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • setzco
    setzco Member Posts: 1 New User
    Options

    Brother has Helios 500 and it upgrade to Windows 11 on its own?? Since then having strange problems.Got

    Sometime it will not power on at all, sometimes it comes up the builtin wifi not working, or sometimes device isn't even showing??

    Bluetooth is also doing same, sometimes it shows and sometimes it is missing from Device manager.

    Going to drives, it only shows Windows 10 as OS?

  • billsey
    billsey ACE Posts: 32,277 Trailblazer
    Options

    Yes, Acer hasn't released drivers for W11 yet, since there are issues with some devices. Those don't sound like they should be having problems though. Go into Device Manager, expend the USB section and delete the host controllers and root hubs, then reboot and see if things come back after the OS reinstalls those drivers. If that doesn't work start a new thread witn your issue. Include the full model number (it's on the same sticker as the serial number and looks something like PH5xx-xxx-xxxx), what specifically is happening and what you ahve tried so far to fix it.

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.