Randomly black screen for few seconds, ACER Predator XB323UGP

Options
Ronnback92
Ronnback92 Member Posts: 4 New User
Hello, just bought my ACER predator XB323UGP-monitor and i'm having a problem. When i start a game the screen will say "No signal". When i'm playing in a game, the screen will turn black, as if it was off and then come back to life and it will be like this till i turn off the game. If i press windows-icon on my keyboard it will stop. This only happends with DisplayPort, HMDI works fine. 

Reinstalled Nvidia drivers, tested another DisplayPort-cable and i'm facing the same issue. Do any of you have any idéas?

Answers

  • Ronnback92
    Ronnback92 Member Posts: 4 New User
    Options
    The screen wont say "no signal" everytime, only like 90% of the time. If it says "no signal" I unplug/plug-in the cable and it's fine. Then it wont black-screen either. If it dosn't say "no signal" it will turn black on and off.
  • Ronnback92
    Ronnback92 Member Posts: 4 New User
    Options
    I have a RTX3080 and Rayzen R7 5800X. 
  • Easwar
    Easwar Member Posts: 6,727 Guru
    Options
    Hi @Ronnback92,

    Monitor self test,

    1. Power OFF the unit.
    2. Unplug all the cables.
    3. Press and hold the power button for 30 seconds.
    4. Turn ON the unit and check.
  • Ronnback92
    Ronnback92 Member Posts: 4 New User
    Options
    Easwar said:
    Hi @Ronnback92,

    Monitor self test,

    1. Power OFF the unit.
    2. Unplug all the cables.
    3. Press and hold the power button for 30 seconds.
    4. Turn ON the unit and check.
    Tried this woth no luck. Tried all kind off stuff but i get other symptoms with other games. 

    I will return this monitor and get somethingels. As your reply was a time ago i still have issues and have been speaking with nvidia themself, swedish support of Acer aint too good.

    NVIDIA blames Acer because it's overclocked. And what i can find is all monitors overclocked, this gets me confused.
  • Defzone
    Defzone Member Posts: 2 New User
    Options
    Try other DP 1.4 cable that is vesa certified.