Random blank screen on new acer predator xb323qk nv

Thms7722
Thms7722 Member Posts: 7

Tinkerer

Hello, hope someone can help me with my problem here. I just got this monitor 2 weeks ago and continue to have this issue no matter what I try. My PC specs are I9-10900K, EVGA 3090 ftw 4000 GSkill ram, 4 terabyte SSD and 1200 watt power supply (custom loop to cool it all). So every so often while gaming or even surfing the net, my monitor will go blank for a few seconds than the picture will come back. It’s not turning off and it doesn’t say “no signal”. I’m using the supplied DPI cable (and have tried others including HDMI. I’ve tried DDU’ing my Nvidia drivers and did a “fresh” install of the latest driver. I tried disabling G-sync in Nvidia control panel and disabling free-sync on the monitor itself. I don’t use HDR. It happens while having a duel display setup and also with just the single monitor. If anyone has any info I’d really appreciate it. I love the picture and ability to play games at 4K @144 FPS. 

Answers

  • Easwar
    Easwar Member Posts: 6,727 Guru
    Hi @Thms7722,

    Monitor self test,

    1. Power OFF the unit.
    2. Unplug all the cables.
    3. Press and hold the power button for 30 seconds.
    4. Turn ON the unit and check.
  • Thms7722
    Thms7722 Member Posts: 7

    Tinkerer

    Nah, didn’t work. Thanks for trying
  • Easwar
    Easwar Member Posts: 6,727 Guru
    Hi @Thms7722,

    It looks like hardware issue. Contact acer tech support,

    https://www.acer.com/ac/en/US/content/service-contact


    OR book the unit for repair service,

    https://customerselfcare.acer.com/CS2/#/

  • Thms7722
    Thms7722 Member Posts: 7

    Tinkerer

    I think I may have found the cause of my random blank screens. It’s been fine for the few days but turning off super sharpness seems to have fixed the issue. I’ll keep you posted if the issue returns 
  • Easwar
    Easwar Member Posts: 6,727 Guru
    Hi @Thms7722,

    Good to know thanks for your information. ​
  • Cricketboy4K
    Cricketboy4K Member Posts: 8

    Tinkerer

    Thms7722 said:
    I think I may have found the cause of my random blank screens. It’s been fine for the few days but turning off super sharpness seems to have fixed the issue. I’ll keep you posted if the issue returns 
    Are you using multiple monitors with your XB323QK monitor? I've been having this same black screen issues for weeks after returning several XB323QK monitors. I turned off super sharpness on my monitor and it didn't fix the issue but using only one monitor did. Seems like a graphics card/driver issues but it ONLY happens with THIS monitor.

  • Thms7722
    Thms7722 Member Posts: 7

    Tinkerer

    Thms7722 said:
    I think I may have found the cause of my random blank screens. It’s been fine for the few days but turning off super sharpness seems to have fixed the issue. I’ll keep you posted if the issue returns 
    Are you using multiple monitors with your XB323QK monitor? I've been having this same black screen issues for weeks after returning several XB323QK monitors. I turned off super sharpness on my monitor and it didn't fix the issue but using only one monitor did. Seems like a graphics card/driver issues but it ONLY happens with THIS monitor.

    Actually it wasn’t super clear as the issue. Only way I was able to fix the issue is with a fresh install of windows unfortunately. It kept getting worse and worse. First it would just go blank for a few seconds and come right back on. Than it progressed to my GPU crashing and me having to hard boot my pc. It got to a point that I thought it was my gpu or power supply. Finally said f it and did a clean wipe of my hard drives and reinstalled windows and all other drivers and it’s been perfect for 3 days now. I checked the crash log and kept seeing power failure gpu or something to that affect. As of now everything seems to run great but again if it acts up I’ll keep y’all posted. 
  • Cricketboy4K
    Cricketboy4K Member Posts: 8

    Tinkerer

    edited November 2021
    Thms7722 said:
    Thms7722 said:
    I think I may have found the cause of my random blank screens. It’s been fine for the few days but turning off super sharpness seems to have fixed the issue. I’ll keep you posted if the issue returns 
    Are you using multiple monitors with your XB323QK monitor? I've been having this same black screen issues for weeks after returning several XB323QK monitors. I turned off super sharpness on my monitor and it didn't fix the issue but using only one monitor did. Seems like a graphics card/driver issues but it ONLY happens with THIS monitor.

    Actually it wasn’t super clear as the issue. Only way I was able to fix the issue is with a fresh install of windows unfortunately. It kept getting worse and worse. First it would just go blank for a few seconds and come right back on. Than it progressed to my GPU crashing and me having to hard boot my pc. It got to a point that I thought it was my gpu or power supply. Finally said f it and did a clean wipe of my hard drives and reinstalled windows and all other drivers and it’s been perfect for 3 days now. I checked the crash log and kept seeing power failure gpu or something to that affect. As of now everything seems to run great but again if it acts up I’ll keep y’all posted. 

    Seems odd that a monitor would do this. Strange. I guess I could try reinstalling windows again. At least it's easy to do. I haven't had any GPU crashes, BSODs, or any other crashes at all, just the black screen every few second or minutes that makes this unusable. Let me know if you have any problems in the future. If this persists I'm taking this back and going with something else other than Acer.
  • Thms7722
    Thms7722 Member Posts: 7

    Tinkerer

    So today after the fresh install of windows and all drivers it’s happening again. I really think there is a problem with this monitor. I’ve ran past my return window so I really hope a fix is available for this. It only happens with this monitor connected. 
  • JackShih
    JackShih Member Posts: 1 New User

    I am using Aorus 15P XC laptops(RTX 3070,one monitor mode).When encountered blank screen problem,I found that select information from the OSD,then reset,this often solve the problem for the day.Sometimes require 2-3 times reset daily,occasionally no problem for a day.The problem usually occurs shortly after boot, and sometimes two consecutive black screen.I think this needs a hardware repair.









  • agg
    agg Member Posts: 1 New User
    edited January 2022
    Got my Acer XB323QK NV monitor two days ago. Had black screen blinking on the first boot on just normal desktop use. That's when I first found these forum posts and got really worried.

    After first boot the problem seemed to go away. Only thing bothering was 2s black screen when losing focus of screened game when alt tabbing to do something else on other screen (and the horrible, unusable overdrive and crappy OSD, oh and don't even mention those aim-points).

    Now tried RDR2 to see how it looks on 4k and after couple of hours playing black screens started to appear in few second interval. I hard earlier enabled HDR. Trying to see if disabling HDR will help. (One would expect the HDR to work though, so having to use workarounds to get a functional products really don't cut it). 

    3080ti + multi monitor setup here.

    It seems like this monitor does have an applicable firmware upgrade. So far my options looks like:

    1. Get a better HDMI cable (I'm using some old one I had laying around, but it does seem to allow 144Mhz)
    2. Try the firmware upgrade (and hope it won't brick it. Will contact vendor first, if doing this would void any warranty / refund policy) 
    3. Return and refund

    So, far, looks like I've made a dire mistake by purchasing this Acer Predator XB323QK NV monitor. (Do you feel like I'm repeating the model number? Yes I am. Hopefully someone has more wits than I did and does a Google search before buying a monitor ;P)


  • Defzone
    Defzone Member Posts: 2 New User
    edited February 2022
    This one happens to me with mg sbmiiprzx. Try to change the DP cable with a DP 1.4 vesa certified. Use a appropriate cable that matches your monitor needs. 
  • Thms7722
    Thms7722 Member Posts: 7

    Tinkerer

    Well it has started to happen again today. So 3 months with no issues but the funny thing is, The only recent updates I’ve done is windows update. I’m pretty much done with this monitor, going to send it in and hopefully they return it fixed so I can sell it and cut my losses 
  • Tentacle_Blue
    Tentacle_Blue Member Posts: 9

    Tinkerer

    edited April 2022
    Thms7722 said:
    Well it has started to happen again today. So 3 months with no issues but the funny thing is, The only recent updates I’ve done is windows update. I’m pretty much done with this monitor, going to send it in and hopefully they return it fixed so I can sell it and cut my losses 
    I get same issue even worst.


    I try to see if it was my GPU by pluging both on my 3080 and i get this :


    Both screen are plug on HDMI on this picture. (Aslo get the issue on 2 different cable 1.4 DP)
    But if I plug the screen just on my macbook pro I don't get issue. So I think it's a issue with Nvidia card but for the price of this screen it's not acceptable to get this kind of issue. So I will try to see to have a other one or other brand screen...