Random black screen while gaming on Predator PO3-630

Wrathchild68Wrathchild68 Member Posts: 9

Tinkerer

Just recently I have been getting a random black screen while gaming which lasts for about a second, doesn't happen all the time though. I have searched all over the internet to find a solution and have tried all different kinds of fixes for it, 2 new HDMI cables, different drivers for graphics card, under volting the card using MSI Afterburner, different power options in windows. I am currently running  the resolution at the recommended settings for my display (55" Samsung TV) which are 3840/2160. This is starting to drive me mad because it did it a few weeks ago then stopped but over the last couple of days it's come back again.

Does anyone have any idea what could be causing this because I have now run out of ideas.

Thanks.

FAQ & Answers

  • EaswarEaswar Ally Posts: 3,250
    Hi @Wrathchild68,

    Did you check this monitor with different system.
  • Wrathchild68Wrathchild68 Member Posts: 9

    Tinkerer

    edited September 15
    I think I may have found the problem. I had turned on 120HZ in windows settings and in games that supported it but I only have an HDMI 2.0 cable which according to the manufacturer will not run 4K at 120HZ, will only run at 60HZ. I need a 2.1 cable. I am guessing that's why it was doing this in certain games.
  • Wrathchild68Wrathchild68 Member Posts: 9

    Tinkerer

    Edit: Changed some of my games to run at 60hz and it did it again although it's not as bad as before. I have run this monitor on my old desktop with no problems.

    Would dropping the resolution down slightly help?
  • EaswarEaswar Ally Posts: 3,250
    Wrathchild68,

    Edit: Changed some of my games to run at 60hz and it did it again although it's not as bad as before. I have run this monitor on my old desktop with no problems.

    Would dropping the resolution down slightly help?

    It may hepl you. "dropping the resolution down" there will be some change in FPS.
  • Wrathchild68Wrathchild68 Member Posts: 9

    Tinkerer

    All sorted now. I bought a decent 2.1 HDMI cable and have been running it for couple of days at 120hz in 4K and no signal loss.
Sign In or Register to comment.

Who's Online839

AZOOZ_I8084
AZOOZ_I8084
BlindSaiyan00
BlindSaiyan00
bluemoon2
bluemoon2
Doyle_Welch
Doyle_Welch
egydiocoelho
egydiocoelho
Montes
Montes
NiklaSge208
NiklaSge208
Sanketh0012
Sanketh0012
Speculoos
Speculoos
YanSay
YanSay
Yibo_de
Yibo_de
+828 Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We are honored to have Leostat in the Acer Community. With their dedication, support and effort, Leostat has become one of the main collaborators. On behalf of our Acer Community Team and all of our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1961

Total Points:6307

Total Accepted Answers: 245

Leostat Community Aficionado