image

Predator Helios 300 charging issue. - Predator PH315-53

SpeedjpopSpeedjpop Member Posts: 4 New User
edited May 12 in Predator Laptops
Dear Acer community and gurus,
I'm having problem with a 4-months old Helios 300. It does not charge when powered up. It can only be charged when shutdown or in sleep mode.
Tried searching the FAQ and forum for solutions.
Tried the recommended steps like CALIBRATION & BATTERY RESET, BATTERY CONTROLLER RESET and PROCESS FOR CALIBRATING BATTERY but none worked. The only step I didnt follow was the 'locate a hole at the bottom of the laptop, insert a pin and hold reset button for 5-secs' because there is no such for my laptop.
Laptop data are as follow:
Model: Predator PH315-53
Bios Version: V1.01
OS: Wins 10 Home 64-bit
Looking forward to any assistance!

//Edited the content to add model name on title.​​

FAQ & Answers

  • SpeedjpopSpeedjpop Member Posts: 4 New User
    B.U.M.P.

    No one able to help me???....so sad...
  • EaswarEaswar Ally Posts: 828
    Hi Speedjpop,

    # Try to update the battery driver

    1. Hold windows key and hit letter X.
    2. Choose the device manager option.
    3. Go with the option battery.
    4. Under the title battery.
    Update Battery Drivers in Windows EASILY - Driver Easy
    5. Right click on that option ----> Update all driver under the title battery.
    6. Choose "search automatically". 

    Check this T/S and post the result. ​
  • SpeedjpopSpeedjpop Member Posts: 4 New User
    Hi Easwar,

    Tried this step before. Just retried it again. Both actions prompted that the latest drivers are installed.


  • SpeedjpopSpeedjpop Member Posts: 4 New User
    Read egydiocoelhos advice to ruts0418: Turn off laptop, disconnect power adapter, press power button for 12secs then leave laptop off for 30mins.
    Tried it as well. It seems to help laptop be able to charge when in use. However once I start game 'World of Tank', the charging disconnects. I got to manually switch off the power adapter and switch it on again, this action sometimes charge for 10secs then charging disconnects again. Sometime this actions does not enables charging at all.

    Any other help/suggestions are welcome!
  • EaswarEaswar Ally Posts: 828
    Hi Speedjpop,

    Are you getting any blue or orange light indication when charger is connected. 
Sign In or Register to comment.

Who's Online1.2K

Acer-Blayn
Acer-Blayn
Acer-Erick
Acer-Erick
Acer-George
Acer-George
Acer-Ingrid
Acer-Ingrid
Acer-Jose
Acer-Jose
alfieb2204
alfieb2204
Andy4046
Andy4046
Ansh2236
Ansh2236
Anuknownuser22
Anuknownuser22
Badsun117
Badsun117
Balatekie
Balatekie
brummyfan2
brummyfan2
dunre
dunre
Edummsp
Edummsp
Edward1212
Edward1212
egydiocoelho
egydiocoelho
FabriciodSilva
FabriciodSilva
FakerVLC12
FakerVLC12
GeeKnight
GeeKnight
HertZ
HertZ
jaroldrasich
jaroldrasich
PaulK
PaulK
pegasis
pegasis
RenanVilela
RenanVilela
Romain17
Romain17
Starkkyy
Starkkyy
surfscuba808
surfscuba808
TransparentPixel
TransparentPixel
VanillaNut
VanillaNut
vg11
vg11
Yinet
Yinet
Zeiler
Zeiler
Andy4046
Andy4046
Badsun117
Badsun117
brummyfan2
brummyfan2
pegasis
pegasis
egydiocoelho
egydiocoelho
Acer-George
Acer-George
+1.1K Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We are honored to have Leostat in the Acer Community. With their dedication, support and effort, Leostat has become one of the main collaborators. On behalf of our Acer Community Team and all of our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1338

Total Points:4292

Total Accepted Answers: 164

Leostat Mainframe Wrangler