After changing sata mode to ahci the bios isn't recognising my storage drive in aspire 7 a715-75g

Options
neopanther
neopanther Member Posts: 13

Tinkerer

edited February 2021 in Aspire Laptops
I have an Acer aspire 7 a715-75g. I wanted to install Linux on it, So I changed my SATA mode from 'optane without raid' to AHCI by going to safe boot and changed it in the bios. But then if I go to my bios, it isn't showing the HDD model number and serial number which it showed when it was in the 'optane without raid' option. I have a 512GB SSD on my laptop. I will include screenshots of bios in both SATA modes below. Does anyone else with an acer aspire 7 have this issue. Please let me know if anybody knows a solution to this.

Answers

  • brummyfan2
    Options
    Hi,
    Your Windows OS is installed in UEFI, so you have to install Linux OS also in UEFI mode, have you tried installing Linux in UEFI mode? if not give it a try.
    UEFI - Community Help Wiki (ubuntu.com)
  • neopanther
    neopanther Member Posts: 13

    Tinkerer

    Options
    the problem is not about Linux installation. The thing is after I change sata mode to ahci, windows 10 also crashes after I wake the laptop from sleep.
    I think I installed Linux in UEFI. I used etcher to create the installation media. I was trying to install Pop os. And the grub wasn't configured properly(I think) and I was just able to get rid of the Linux installation just by deleting the partition in windows(which I don't think is the right way).

    Thanks for replying