SF314-42 doesn't wake up from sleep mode, with Hyper-V turned on!

SF314-42 doesn't wake up from sleep mode, with Hyper-V turned on. Need to interrupt the power to get it back working!? Can we get any updates?

FAQ & Answers

  • kirmgrauzakirmgrauza Member Posts: 39 Devotee
    Same problem. It restarts instead. All work lost.
  • UserLand001UserLand001 Member Posts: 6

    Tinkerer

    I'll second this complaint. Same model (SF314-42 RSYN), same issue, no solutions. Acer support, where are you?

    https://community.acer.com/en/discussion/628801/swift-3-will-not-wake-from-windows-10-sleep-mode/p1?new=1
  • Tarik02Tarik02 Member Posts: 27 Enthusiast
    The same problem. Waiting for updates.
  • UserLand001UserLand001 Member Posts: 6

    Tinkerer

    edited January 14
    After many hours of research, I solved this problem for my Acer laptop (SF314-42 RSYN). I had installed WLS2 (Windows Linux Subsystem, version 2), and this can cause problems with waking from sleep. I followed these instructions to remove WLS2: 

    https://superuser.com/questions/1317883/completely-uninstall-the-subsystem-for-linux-on-win10

    This completely resolved the issue. Of course I no longer have WLS installed, which is annoying. I intend to try installing WLS version 1, but I have not yet done so. So I cannot vouch for the earlier version of WLS, I can only confirm that removing WLS completely was a solution for me. 

  • Tarik02Tarik02 Member Posts: 27 Enthusiast
    After many hours of research, I solved this problem for my Acer laptop (SF314-42 RSYN). I had installed WLS2 (Windows Linux Subsystem, version 2), and this can cause problems with waking from sleep. I followed these instructions to remove WLS2: 

    https://superuser.com/questions/1317883/completely-uninstall-the-subsystem-for-linux-on-win10

    This completely resolved the issue. Of course I no longer have WLS installed, which is annoying. I intend to try installing WLS version 1, but I have not yet done so. So I cannot vouch for the earlier version of WLS, I can only confirm that removing WLS completely was a solution for me. 

    Actually it's enough to disable virtualization in BIOS. Of course, WSL2 won't work then.
  • AnimeshSahuAnimeshSahu Member Posts: 14

    Tinkerer

    After many hours of research, I solved this problem for my Acer laptop (SF314-42 RSYN). I had installed WLS2 (Windows Linux Subsystem, version 2), and this can cause problems with waking from sleep. I followed these instructions to remove WLS2: 

    https://superuser.com/questions/1317883/completely-uninstall-the-subsystem-for-linux-on-win10

    This completely resolved the issue. Of course I no longer have WLS installed, which is annoying. I intend to try installing WLS version 1, but I have not yet done so. So I cannot vouch for the earlier version of WLS, I can only confirm that removing WLS completely was a solution for me. 

    That's not a solution, that's the reason I mentioned "with Hyper-V turned on" on the front title. I basically cannot run Docker (and a lot of Linux commands like `time`) unless WSL2 is enabled.
  • UserLand001UserLand001 Member Posts: 6

    Tinkerer

    Ah. Well, yes, that is a problem then. Sorry for the misunderstanding. 
  • UserLand001UserLand001 Member Posts: 6

    Tinkerer

    edited January 16
    Tarik02 said:
    After many hours of research, I solved this problem for my Acer laptop (SF314-42 RSYN). I had installed WLS2 (Windows Linux Subsystem, version 2), and this can cause problems with waking from sleep. I followed these instructions to remove WLS2: 

    https://superuser.com/questions/1317883/completely-uninstall-the-subsystem-for-linux-on-win10

    This completely resolved the issue. Of course I no longer have WLS installed, which is annoying. I intend to try installing WLS version 1, but I have not yet done so. So I cannot vouch for the earlier version of WLS, I can only confirm that removing WLS completely was a solution for me. 

    Actually it's enough to disable virtualization in BIOS. Of course, WSL2 won't work then.
    FWIW, I tried disabling virtualization in the BIOS (v1.08), it didn't solve the sleep problem. I had to uninstall WLS2. I am now running with virtualization _enabled_ in the BIOS, and no WLS2, and my laptop has no problems with sleep mode.
  • mit_smit_s Member Posts: 4 New User
    Hello Acer
    Please fix this asap, I have a need to use WSL2 with Docker.
Sign In or Register to comment.

Who's Online1.2K

Adrigr
Adrigr
Akagami029
Akagami029
BillStott
BillStott
CatchyMonica
CatchyMonica
Glenjamin
Glenjamin
Gwinbleid
Gwinbleid
hannesm813
hannesm813
Heliotrope
Heliotrope
JDAR
JDAR
Jrrc98
Jrrc98
Kno63
Kno63
malmeida28
malmeida28
OLLIBIGGI
OLLIBIGGI
phoenX
phoenX
Plodmore1
Plodmore1
roro19
roro19
saooliveira
saooliveira
+1.2K Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos