no Bluetooth on my Aspire TimelineX 4830TG ?

Options
nze123
nze123 Member Posts: 11

Tinkerer

edited November 2023 in 2020 Archives
Hello

I had to reinstall my PC completely from scratch after a hard disk crash.
Model 4830TG-2434G75Mnbb
Unfortunately my recovery CD were corrupt and failed to execute the system recovery ; I had to install a standard windows10 on my blank machine.

Ever since, it seems I cannot enable my Bluetooth on this PC ; no bluetooth entry in the device manager, no bluetooth enable option in the Parameters, Windows troubleshooter does not find any bluetooth device.
When running Acer vendor detector, no Bluetooth is displayed in the list.
Fn-F3 is enabled, WIFI works like a charm.

Any idea what's going on ? Am I missing some kind of low level driver ? (installing BT drivers does not help)

Thanks in advance for your help.

Answers

  • billsey
    billsey ACE Posts: 32,329 Trailblazer
    Options
    The Bluetooth module is separate from the WiFi adapter on your model, unlike most newer computers. Which OS did you install, Windows 7, 8.1, 10? The description in specs says: AR3011, BCM2070/BU12. I believe those are all Foxconn modules. Perhaps by looking in Device Manager you can find out their IDs and get drivers from a search on them.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • nze123
    nze123 Member Posts: 11

    Tinkerer

    edited December 2020
    Options
    Hi
    thanks for your answer.
    i installed Windows10 - the initial setup was Win7 home, but I managed to obtain a W10 licence 
    there seems to be 2 flavors of BT on this model - Broadcom and Atheros. The label on the back says it is Atheros AR5Bbu22. I installed the drivers from Acer site but so far no luck - system keeps saying no Bluetooth device... No Bluetooth icon in device manager.
    I thought maybe some chipset issue ? As it seems the chipset is managing those devices... and because my OS is standard (not the acer version) maybe that’s where the problem lies ?
  • billsey
    billsey ACE Posts: 32,329 Trailblazer
    Options
    It's possible. Is there anything in Device Manager showing an issue? If the underlying USB hub is not initialized the device 'connected' to that port wouldn't show as being installed, so wouldn't show up in DM.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • nze123
    nze123 Member Posts: 11

    Tinkerer

    Options
    Hi.
    actually no, there is no error or unknown device appearing in Device manager even in USB. Like the device does not exist at all... and is not detected by the system...