Predator Helios 3000 Gpu Fan not spinning after repasting and cleaning the Fans :/

AxoneQAxoneQ Member Posts: 3 New User
So, i recently repasted and Cleaned the Laptop by myself using some Youtube tutorial, as I thought it would be easier and faster than waiting for my Laptop to come back from Repair, and it was only Repasting that needed to be done so I did It.

At first I didnt notice any mistakes I couldve made, after the cleaning I stuck the Cables where they shouldve been and eveything seemed alright, but after some time I looked over my Predator Sense an saw that the GPU Fan isn't spinning at all, I Thought maybe it was some kind of a bug on Predator senses Side, but after inspecting the fan It Indeed wasnt spinning. 
Today I opened the Laptop again in hopes that i maybe didnt put the Cable deep enough into the Slot, but it still isnt Spinning.
Im pretty new to "repairing" any kind of Electronic device by myself, I dont even know what to Ask right now as of I dont know what couldve happened that the Fan isnt Working anymore, pls Halp.

FAQ & Answers

  • busu3busu3 Member Posts: 552 Seasoned Specialist
    How did u remove the fan plugs from the motherboard? If u had loosened them by pulling the cable then most likely u would have cut the cables. Otherwise check if the fan spins by moving it with your hand since something could be obstructing it. Even then if it doesnt work then interchange the fans and see if the fan which wasnt running runs in the other plug.
  • AxoneQAxoneQ Member Posts: 3 New User
    busu3 said:
    How did u remove the fan plugs from the motherboard? If u had loosened them by pulling the cable then most likely u would have cut the cables. Otherwise check if the fan spins by moving it with your hand since something could be obstructing it. Even then if it doesnt work then interchange the fans and see if the fan which wasnt running runs in the other plug.
    So I checked the cables and everything was fine, I loosened them with two toothpicks, I didint pull the cables.
    But i've found the problem, one of the Golden coils in the plug for the Fan broke off and where the are usually 4 of them in now only 3.
    Is there a way to fix it or Should I just Send my Laptop to repaircenter and hope that they Can repair it ?
  • busu3busu3 Member Posts: 552 Seasoned Specialist
    Is the broken piece from the fans plug or the motherboard connector to the fan? Either way u should give it to them.
  • AxoneQAxoneQ Member Posts: 3 New User
    The motherboard connector coil is broken. ;/
  • busu3busu3 Member Posts: 552 Seasoned Specialist
    The one in which u insert the plug?
Sign In or Register to comment.

Who's Online983

Acer-Erick
Acer-Erick
AldoSchmidt
AldoSchmidt
JackE
JackE
JuanPabolo
JuanPabolo
jwvin
jwvin
KL_Duq
KL_Duq
KrimsonD
KrimsonD
mvinip
mvinip
nandolimoes
nandolimoes
Oilstar
Oilstar
pcd_abreu
pcd_abreu
Snarkingjay
Snarkingjay
+971 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

  • By Acer-Ingrid -
    The brightest talents from across the Asia Pacific unite to celebrate Acer Day 2021 with its official anthem, Live Your World.Unlock limitless possibilities and join us for our #LiveYourWorldWithAcer (Read more…)
    1 52

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We are honored to have Leostat in the Acer Community. With their dedication, support and effort, Leostat has become one of the main collaborators. On behalf of our Acer Community Team and all of our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1752

Total Points:5437

Total Accepted Answers: 207

Leostat Community Aficionado