Low FPS on new Predator PH317-53

DesiwahDesiwah Member Posts: 10 New User
Hi all,

I have pretty low FPS in games and at least by my knowing I shouldn't. I did literally everything I could find on YT, this forum and all the other things that Google suggested me.
   New Windows 10 installed as I bought the laptop
   Nvidia GeForce Experience removed since a lot of people said it can be a problem and this guy helped me to install the newest drivers without it (used DDU)
   All chipset and bunch of other drivers downloaded from the manufacturer site
   Underclocked CPU with ThrottleStop following one video on YT for the same CPU
   Windows set to Best performance
   Power option for max CPU set to 99
   Nvidia Control panel set to Max performance in the main option and down among the other options. Checked and the game is using that card NOT iGPU
Can't even remember what all I have tried and I really need your help because I know that this laptop can do much much better since even some lower systems do better. I'm missing something important I can't find what exactly...

These are the benchmark results which are now lower because of ThrottleStop and Nvidia showing something red which it didn't before when I made a test before I installed the new drivers without NGE
Literally right now I'm checking the graphic on the site while I was copying it and it shows the wrong card for some reason. My GPU is GeForce RTX 2070 with Max-Q design.
Trying to fix this low FPS for too long now and I'm writing because I can see there's something I'm missing, but can't figure out on my own.

Thanks in advance! :)


FAQ & Answers

  • DesiwahDesiwah Member Posts: 10 New User
    [EDIT] Sorry forgot to mention that the game I'm trying it all on is Grounded on Steam. It goes around 50 FPS then sometimes when I turn to some areas drops to around 40, 30 and it is really noticeable. I didn't test it on other games, but from the gameplay I can say it is the same because in GTA 5 I also get the same drop because I notice it just like in Grounded.

  • GAMING6698GAMING6698 Member Posts: 3,504 Supercomputer Wrangler
    @desiwah
    I didn't think under clock cpu, set maximum processor stage to 99%, beast performance mode will work.
    These changes will decrease laptop performance.
    There are other reasons for this low fps and drop.

    First revert or reset these all changes and do completely reset your window using ALT+F10.
    1. Press and hold the Power key for 5 seconds to power the system off completely.
    2. Press the Power key to turn on the computer.
    3. Press the Alt and F10 keys at the same time when the Acer logo appears on the screen. Your system should boot to a blue screen that says Choose an option.
    4. Select Troubleshoot.
    5. Click Reset your PC. This process will erase all data on the your system. 
    6. Click Next, then select fully clean drive
    7. Click Reset to begin the recovery.

    After reset download latest nvidia software for your gpu and report back after installation 
    click on "Yes" if it answers your question.
    God has established his kingdom on earth in such a way that we must ask for help.
    my Acer nitro 5 (AN515-43) userbenchmark

  • DesiwahDesiwah Member Posts: 10 New User
    Done everything you've said and FPS is still the same without changing any options... Only thing that changed is that I get higher CPU temperatures by 15 - 20°C more even on idle. I have no idea why and what happened. Maybe now after clean install that BIOS kicked in because some people said they noticed a bit higher temps after BIOS update even on idle, but this is maybe a bit much. No idea what to do next...
  • DesiwahDesiwah Member Posts: 10 New User
    edited August 1
    Actually whole system started to act very weird after the full clean install. There is one Unknown USB device (Device descriptor request failed) in my device manager and there is no USBs attached to laptop and it won't go away whatever I do. Some apps just doesn't work anymore etc.
  • DesiwahDesiwah Member Posts: 10 New User
    Ok so, I reverted BIOS back to 1.10 and now I do not have those weird Windows glitches anymore and fans are not turning up for nothing even when in idle BUT the FPS are the same and temperature is still high for idle. I think I'm gonna see my options for repasting, but that's for sure not all. What can I do to fix these stupid low FPS?!
  • GAMING6698GAMING6698 Member Posts: 3,504 Supercomputer Wrangler
    @Desiwah
    cpu working in full potential thats why heating.
    May be this is reason why you are getting low fps.

    Did you install nvidia control panel software?
    If yes,then add your game .exe file in nvidia control panel (3d settings) and set high performance nvidia processor

    Now do these changes 
    -Make sure you are using latest nvidia control panel 
    -In (nvidia control)GeForce Experience, find the settings for battery and whisper mode(s).
    Turn these off to return fps to normal (normal of battery powermizer that is)


    (If your GPU/CPU temperature reaches 89°C then thermal throttling will start and you will experience shuttering and fps drop, low fps)
    click on "Yes" if it answers your question.
    God has established his kingdom on earth in such a way that we must ask for help.
    my Acer nitro 5 (AN515-43) userbenchmark

  • DesiwahDesiwah Member Posts: 10 New User
    I installed every option except GeForce Experience so I don't have those options and I already checked all that in Nvidia control panel. Temperature doesn't reach that much and I didn't see thermal throttle but still have those same FPS. I do have latest drivers
  • GAMING6698GAMING6698 Member Posts: 3,504 Supercomputer Wrangler
    @Desiwah
    Run userbenchmark again and post result link
    click on "Yes" if it answers your question.
    God has established his kingdom on earth in such a way that we must ask for help.
    my Acer nitro 5 (AN515-43) userbenchmark

  • DesiwahDesiwah Member Posts: 10 New User
  • GAMING6698GAMING6698 Member Posts: 3,504 Supercomputer Wrangler
    @Desiwah
    Now everything is working great!!!

    Did you check if v-sync is on in game or fps limit?
    Is this happening in online game only ?
    Are you sure you temperature is less then 89°C?
    click on "Yes" if it answers your question.
    God has established his kingdom on earth in such a way that we must ask for help.
    my Acer nitro 5 (AN515-43) userbenchmark

  • DesiwahDesiwah Member Posts: 10 New User
    edited August 2

    Based on info looks like nothing works as it has to or those "errors" doesn't matter? It is less yes. I'm playing Grounded in single player mode on Epic settings which should work flawlessly on this configuration. v-sync is off in Nvidia control panel and I didn't play with FPS limit


  • DesiwahDesiwah Member Posts: 10 New User
    GTA 5 is most of the time around 60 FPS and sometimes drops below depending on surroundings. Grounded is just a few FPS better, but still goes below sometimes. Temperatures are A LOT higher, sometimes CPU reaches 82°C and system (I think that's RAM) 80°C while GPU keeps a pretty good temp all the time, not sure if it went above 60°C at all... I was watching it while playing on my phone through Predator Sense application. I don't know if that all is normal, but I don't like it and when I bought this laptop I thought that for the first time I won't have to watch what I am playing and if I am able to play it. If I wanted to be careful all the time and trying to make every game playable I would just stick with my old laptop... Very disappointing and I'm starting to regret buying this laptop
  • DesiwahDesiwah Member Posts: 10 New User
    edited August 3
    I have to use Turbo (overclock) if I wanna play any game and here is an example. Sorry for recording this way by the way.
    When I turn to other side GPU usage drops which leads to FPS drop and sometimes depending on place or situation it drops near roughly 44 FPS. Why it doesn't use GPU all the time when it clearly needs it? The game is Grounded, but it happens with GTA 5 too and probably other games just didn't test them all since these two are more resource hungry that I have installed. Not sure what's the point of 144Hz screen either.

Sign In or Register to comment.

Who's Online880

AaranB
AaranB
alucke
alucke
aphanic
aphanic
Dusty13B
Dusty13B
IVAN_PC
IVAN_PC
Iván78
Iván78
Jhon1980
Jhon1980
Kno63
Kno63
MrHolo
MrHolo
OWangutan
OWangutan
Robin038
Robin038
Shanthan_Spidey
Shanthan_Spidey
Sheenkv
Sheenkv
SofiaKim
SofiaKim
TF21045
TF21045
Tred3007
Tred3007
ttttt
ttttt
vinAb
vinAb
xapim
xapim
YgrecPeKa
YgrecPeKa
+860 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos