next@acer 2020

XB273 max refresh rate option drops after sleep mode

Jay13579Jay13579 Member Posts: 4 New User
Hi, I've got a brand new Predator XB273. I've set it to 4k 120Hz refresh in the nvidia Control Panel (RTX 2080 GPU)  as well as the Windows Display Settings. It works fine, but after it wakes up from sleep mode, the refresh rate drops by itself, and very noticeably so. The maximum refresh rate that you can select dropped to only 30Hz. Another time it dropped to 82Hz. Higher refresh rate options are no longer available. I restart the PC and then 120Hz comes back as the maximum available refresh rate. Please advise, because it's not right that the refresh rate and the maximum refresh rate option changes itself after the monitor wakes up from sleep mode. Thank you.

FAQ & Answers

  • Jay13579Jay13579 Member Posts: 4 New User
    sorry forgot to say i am using the DisplayPort cable that came with it
  • billseybillsey ACE Posts: 11,033 Trailblazer
    Is it just the monitor that was sleeping, or did the computer sleep?
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • Jay13579Jay13579 Member Posts: 4 New User
    Hi Billsey, just the monitor. I found a workaround (as in my later post) where turning off Deep Sleep in the OSD prevents this from happening. However, this creates another issue where the monitor fan will not stop (even overnight), and even when both the PC and monitor are switched off. The only way to stop the fan is to pull the power plug.
  • billseybillsey ACE Posts: 11,033 Trailblazer
    Ok, so that narrows it down a bit to either the monitor acting up or the video card not recognizing the monitor has been asleep. Can you check for new drivers for the GPU?
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • tonyncatonynca Member Posts: 9 New User
    I have this same issue with X27-P! When the monitor returns from deep sleep the refresh rate drops to 87hz. I need to toggle overclock mode on and off to fix the issue. This is very very annoying. Acer please fix it.
  • tonyncatonynca Member Posts: 9 New User
    Hey,

    If you're using Nvidia card, try this:

    Nvidia CP > Adjust desktop size and position > Scaling > Perform scaling on: GPU

    Do this for all your monitors that is connected and see if that works. I just tried this and it seems to hold my settings now.
Sign In or Register to comment.

Who's Online1.6K

AlanPaes
AlanPaes
Comrade_Brad
Comrade_Brad
Gallucci
Gallucci
glk29
glk29
HeronCarlos
HeronCarlos
HighSierra
HighSierra
Iqra
Iqra
Mamuang_kun
Mamuang_kun
MOHAMMADREZAFATAN
MOHAMMADREZAFATAN
PK2000
PK2000
rich1974
rich1974
rmpinho
rmpinho
sdzshn3
sdzshn3
TADIEMAGX
TADIEMAGX
techiekhan
techiekhan
Vanderson3112
Vanderson3112
WillDoNitro5
WillDoNitro5
xapim
xapim
xmen1404
xmen1404
+1.6K Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We want to recognize GAMING6698's dedicated efforts in the Acer Community. GAMING6698 has become one of the main collaborators since joining the Community in November of 2019.
On behalf of all our users and the Acer Team, we thank you for your dedication!

Total Posts and Comments: 3320

Total Points:5757

Total Accepted Answers: 290

GAMING6698 Mainframe Wrangler