image

[Help requested] Can't set Acer Predator XB3 (XB273K GPbmiipprzx) to 4k 144hz

BaHSiCBaHSiC Member Posts: 4 New User
Hi everyone!

I'm hoping you could help me with a problem I'm having with my Acer Predator XB3 model XB273K GPbmiipprzx. I can't get the monitor to run at 4k 144hz. I've tried setting it to 144hz via the Windows display settings and the Nvidia Control Panel. I've noticed two odd things:
  1. In the Nvidia Control Panel, 144hz is an option for any resolution under 2048 x1546; however, once click on 2048 x1546 or higher resolutions, the highest refresh rate available is 120hz (I am selecting resolutions from the "PC" resolutions)
  2. In the Windows display settings, it says the monitor is running at 119hz, and when I try to change it, the only option is 120hz -- but even when I change it to 120hz, it immediately reverts to 119hz
 This is a brand new build running an MSI RTX 2080 Ti VENTUS GP. The monitor is hooked up using the display port cable provided by Acer. Here's what I've tried so far:
  • Set the "4k-144hz mode" in the monitor settings to "on"
  • Tried different display port cables
  • Tried different display ports on both the GPU and monitor
  • Installed the monitor drivers from Acer site
Any thoughts would be appreciated. Thank you in advance for your help!  =)

FAQ & Answers

  • BaHSiCBaHSiC Member Posts: 4 New User
    One more thing to add to what I've tried so far: performed a clean install of the Nvidia drivers.
  • BaHSiCBaHSiC Member Posts: 4 New User
    SOLVED! Updating this thread in case anyone else has/had this problem. You have to plug both display port cables in.
  • RON60559RON60559 Member Posts: 2 New User
    What procedure did you follow after plugging in second cable?  Windows seems to want to identify 2 monitors with both cables in.  Thanks.
  • BaHSiCBaHSiC Member Posts: 4 New User
    RON60559 said:
    What procedure did you follow after plugging in second cable?  Windows seems to want to identify 2 monitors with both cables in.  Thanks.
    Try swapping the inputs on either the GPU or monitor. For example, input 1 on the monitor should be plugged into input 1 on the GPU (and the same for input 2).
  • TrickyRichardTrickyRichard Member Posts: 2 New User
    I have same situation. couple of questions please.

    before I begin, was the improvement worthwhile for FPS gaming do you know?
    I cannot seem to find where to "install" the monitor files, are these really drivers at all?  How do I do that step?
    Any special Displayport cable needed?
    Thank you!
  • TrickyRichardTrickyRichard Member Posts: 2 New User
    Also is this monitor even capable of running 4K @ 144hz?  My monitor only has a single DP input and a s ingle HDMI input.
  • MorbowMorbow Member Posts: 3 New User
    I have same situation. couple of questions please.

    before I begin, was the improvement worthwhile for FPS gaming do you know?
    I cannot seem to find where to "install" the monitor files, are these really drivers at all?  How do I do that step?
    Any special Displayport cable needed?
    Thank you!
    Same issue.  Any help is appreciated!
  • MorbowMorbow Member Posts: 3 New User
    Also is this monitor even capable of running 4K @ 144hz?  My monitor only has a single DP input and a s ingle HDMI input.
    Same issue also, any help would be great!  I tried plugging in both HDMI and DP.  If the input on the monitor is set to DP then I can choose 120hz, but then the monitor has the "no input" issue and I have to use 82hz or below to get display to work.  If I set the input to HDMI, I have 2k, 4K options but only up to 60hz.
  • billseybillsey ACE Posts: 17,014 Trailblazer
    Here is what the XB273K spec says:
    So you have to overclock to get the 144Hz rate at 4K and it has to be on DP.

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • MorbowMorbow Member Posts: 3 New User
    billsey said:
    Here is what the XB273K spec says:
    So you have to overclock to get the 144Hz rate at 4K and it has to be on DP.

    This works to get 144hz to show up thank you!  Still wont display when set to anything over 82hz.  Tried a few custom ones in the Nvidia Control Panel but no luck.
Sign In or Register to comment.

Who's Online1.2K

Acer-Erick
Acer-Erick
Acer-George
Acer-George
Acer-Ingrid
Acer-Ingrid
alfieb2204
alfieb2204
Andy4046
Andy4046
AntonFrolov1133
AntonFrolov1133
Balatekie
Balatekie
B_Dos
B_Dos
Cnolan44
Cnolan44
Daledantis
Daledantis
damiao
damiao
Darko1963
Darko1963
dunre
dunre
EmilioGC
EmilioGC
Giovane
Giovane
HertZ
HertZ
hugodiniz
hugodiniz
JackE
JackE
kovit
kovit
NekoFaye
NekoFaye
NGriggs88
NGriggs88
PaulK
PaulK
RenanVilela
RenanVilela
Rosanelimamedeiros
Rosanelimamedeiros
surfscuba808
surfscuba808
System
System
thor4766
thor4766
TonnyBalla
TonnyBalla
vg11
vg11
Yagarin
Yagarin
Yinet
Yinet
Zeiler
Zeiler
+1.2K Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We are honored to have Leostat in the Acer Community. With their dedication, support and effort, Leostat has become one of the main collaborators. On behalf of our Acer Community Team and all of our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1338

Total Points:4292

Total Accepted Answers: 164

Leostat Mainframe Wrangler