image

X35 flickering(Acer X35 monitor)

1171820222328

FAQ & Answers

  • spoonermcgeespoonermcgee Member Posts: 6 New User
    edited November 2019
    Wanted follow up here guys after returning my x35 to microcenter about 3-4 weeks:

    - switched back to x34P and thought I would be missing the x35, but honestly was a huge relief and instantly fell back in love with the IPS panel and the reliable motion it supports. No flash/flicker/scanlines, to me the x34P is better and I'm glad to have that monitor and not something incomplete and overpriced!

    -bought an LG C9 oled tv instead and it's been amazing, not a single flaw so far with the display and it makes current high-end monitors look insignificant. With Nvidia adding GSYNC support to the current LG OLED lineup I don't see how anyone could recommend not getting one for gaming both console and PC. My experience has been amazing and again makes me very relieved to have taken the x35 back. The C9 can be found so much cheaper as well, I got mine from Rakuten.com for 1179 from vendor "ielectrica", they run great discounts regularly on new OLED's.

    If you have an x35 and are happy with it then I am very glad for that too. I know a lot of us are disappointed and expected more, to those people I would recommend looking into the current LG OLED tv lineup with hdmi 2.1 support + GSYNC :)
  • SpazAuSpazAu Member Posts: 5 New User
    edited November 2019
    I had to make an account as I think I might have found the issue with the flickering and a possible solution.

    I had the same issue with flickering with the Predator X35 in multiple games and this seem to have fixed it.

    In windows goto Start|Settings|System|Display then scroll down to "Graphics Settings". There you will find a setting called "Variable refresh rate" go to "Optimize games for variable refresh rate" and turn it off.

    Mine was on, possibly by default as I'm sure I didn't turn it on, but as soon as I turned it off I'm no longer getting flickering.
  • antychantych Member Posts: 12

    Tinkerer

    SpazAu said:
    In windows goto Start|Settings|System|Display then scroll down to "Graphics Settings". There you will find a setting called "Variable refresh rate" go to "Optimize games for variable refresh rate" and turn it off.

    Mine was on, possibly by default as I'm sure I didn't turn it on, but as soon as I turned it off I'm no longer getting flickering.
    I've tried it, doesn't change anything. Vertical lines and flickering are still present.
  • SpazAuSpazAu Member Posts: 5 New User
    edited November 2019
    antych said:
    I've tried it, doesn't change anything. Vertical lines and flickering are still present.
    That's a shame. It's has definitely worked on mine. I'm assumed it was due to a conflict with Windows attempting to override g-sync or interfering with it somehow. 

    Edit: I should note that I wasn't getting the vertical lines when pulling up the OSD or anywhere for that matter.
  • antychantych Member Posts: 12

    Tinkerer

    edited November 2019
    I've tested it with the image https://pcmonitors.info/wp-content/uploads/2019/09/snowy-village.jpg
    Open it either in full screen (lines visible), or open it on half of the screen and drag the browser size between 50% and 100% = lines + flickering. Mine doesn't show lines when OSD opens, but it often depends on what's on the screen behind it, so your wallpaper or color theme can affect it.
  • SpazAuSpazAu Member Posts: 5 New User
    antych said:
    I've tested it with the image https://pcmonitors.info/wp-content/uploads/2019/09/snowy-village.jpg
    Open it either in full screen (lines visible), or open it on half of the screen and drag the browser size between 50% and 100% = lines + flickering. Mine doesn't show lines when OSD opens, but it often depends on what's on the screen behind it, so your wallpaper or color theme can affect it.
    I spent all day trying to replicate what you're getting with snowy-village.jpg and the only time I was able to get very slight lines visible is when I switched off HDR in windows but that was on an Icon on the task bar and there was still no flickering even when I moved the image around. 


    HDR On


    HDR Off

    The lines were noticeable but only really on that icon.
  • antychantych Member Posts: 12

    Tinkerer

    Maybe not all of them are exactly the same, and you got a better one. Those lines are very faint and barely noticeable on some backgrounds. This is what it looks like on mine.


  • SpazAuSpazAu Member Posts: 5 New User
    antych said:
    Maybe not all of them are exactly the same, and you got a better one. Those lines are very faint and barely noticeable on some backgrounds. This is what it looks like on mine.


    Ok. I managed to get the same result as you when I turned down "Digital Vibrance" in the Nvidia control panel. (I have it set to 60%)

    I then turned it up to 75% and it was gone completely, even when I had HDR off.


    HDR On @ 75% Digital Vibrance

    HDR Off @ 75% Digital Vibrance

    Try that and see if it helps you.
  • antychantych Member Posts: 12

    Tinkerer

    It doesn't make a difference. It's wouldn't be much of a fix anyway. Those lines appear depending on overall brightness/contrast/color etc. You can make them go away in one scene, they will appear in another. Even playing a youtube clip in a small window with the right content can trigger them. There doesn't seem to be any evidence of a proper fix or even a workaround for it. We'll have to wait for a revised model or a new batch.
  • SpazAuSpazAu Member Posts: 5 New User
    antych said:
    I've tested it with the image https://pcmonitors.info/wp-content/uploads/2019/09/snowy-village.jpg
    Open it either in full screen (lines visible), or open it on half of the screen and drag the browser size between 50% and 100% = lines + flickering. Mine doesn't show lines when OSD opens, but it often depends on what's on the screen behind it, so your wallpaper or color theme can affect it.
    I spent all day trying to replicate what you're getting with snowy-village.jpg and the only time I was able to get very slight lines visible is when I switched off HDR in windows but that was on an Icon on the task bar and there was still no flickering even when I moved the image around. 


    HDR On


    HDR Off

    The lines were noticeable but only really on that icon. Weird.
  • antychantych Member Posts: 12

    Tinkerer

    I've tested it with the image https://pcmonitors.info/wp-content/uploads/2019/09/snowy-village.jpg
    Open it either in full screen (lines visible), or open it on half of the screen and drag the browser size between 50% and 100% = lines + flickering. Mine doesn't show lines when OSD opens, but it often depends on what's on the screen behind it, so your wallpaper or colour theme can affect it.
  • scottbascottba Member Posts: 8 New User
    Try see if below can fix your flickering

    In NVIDIA Control Panel Display setting
    Resolution: 3440x1440 (native)
    refresh rate: 144hz
    Use NVIDIA color settings:
      Desktop color depth: highest (32 bit)
      Output color depth:10 bpc
      Output color format: RGB
      Output dynamic range: Full

    If you think monitor too bright, in Window Display setting, 
    Turn off "play HDR games and apps"

  • kot0005kot0005 Member Posts: 56 Devotee
    edited November 2019
    SpazAu said:
    antych said:
    I've tested it with the image https://pcmonitors.info/wp-content/uploads/2019/09/snowy-village.jpg
    Open it either in full screen (lines visible), or open it on half of the screen and drag the browser size between 50% and 100% = lines + flickering. Mine doesn't show lines when OSD opens, but it often depends on what's on the screen behind it, so your wallpaper or color theme can affect it.
    I spent all day trying to replicate what you're getting with snowy-village.jpg and the only time I was able to get very slight lines visible is when I switched off HDR in windows but that was on an Icon on the task bar and there was still no flickering even when I moved the image around. 


    HDR On


    HDR Off

    The lines were noticeable but only really on that icon.
    yes those are scanline, they are on the whole screen, not just the icon. Badluck you paid $4000 for a faulty monitor.


    its funny seeing people attempting fixes when they actually dont fix the issue because its firmware level. 
  • KingFisherKingFisher Member Posts: 13

    Tinkerer

    kot0005 said:
    SpazAu said:
    antych said:
    I've tested it with the image https://pcmonitors.info/wp-content/uploads/2019/09/snowy-village.jpg
    Open it either in full screen (lines visible), or open it on half of the screen and drag the browser size between 50% and 100% = lines + flickering. Mine doesn't show lines when OSD opens, but it often depends on what's on the screen behind it, so your wallpaper or color theme can affect it.
    I spent all day trying to replicate what you're getting with snowy-village.jpg and the only time I was able to get very slight lines visible is when I switched off HDR in windows but that was on an Icon on the task bar and there was still no flickering even when I moved the image around. 


    HDR On


    HDR Off

    The lines were noticeable but only really on that icon.
    yes those are scanline, they are on the whole screen, not just the icon. Badluck you paid $4000 for a faulty monitor.


    its funny seeing people attempting fixes when they actually dont fix the issue because its firmware level. 
    Its funny people know nothing about VA monitor, spam the false information and still hopes his $4000 can be returned.
  • antychantych Member Posts: 12

    Tinkerer


    That's great news. I've sent mine back. I'll buy it again once Acer fixes it too.
  • DrZDrZ Member Posts: 8

    Tinkerer

    Thanks @Dirkscooby I'm happy you caught this. Perhaps I should of gotten the ASUS model instead of the X35 Predator. Hopefully Acer will be on top of this as well. If they do I'll stay with Acer for my next monitor purchase if not I'll definitely start looking elsewhere.
  • kot0005kot0005 Member Posts: 56 Devotee
    edited November 2019
  • Aldur67Aldur67 Member Posts: 30 Enthusiast
    @Acer-Manny

    Can you let us know of any information with regards to this issue? The radio silence is crazy here. And to think that ASUS has identified the issue on their PG35VQ monitor and we've not heard a peep out of Acer about this problem...
  • FeklarFeklar Member Posts: 20 Troubleshooter
    +1. I can't believe Asus found the issue and will remedy it while Acer says nothing. Times like this make me wish I had dismissed my Acer monitor loyalty and went with Asus for this model. How frustrating.
This discussion has been closed.

Who's Online628

Acer-Ingrid
Acer-Ingrid
Acer-Monica
Acer-Monica
Adameh1
Adameh1
alyssadphillips
alyssadphillips
edgarpy
edgarpy
Nirvana1991
Nirvana1991
NRCSD
NRCSD
PriKaD
PriKaD
RenanVilela
RenanVilela
whatch
whatch
+618 Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers