H6510BD no power, 3 red blinking LEDs

ChrisNo
ChrisNo Member Posts: 5 New User
edited February 27 in 2020 Archives
Hello,
my Acer H6510BD projector does not power up anymore. I have opened the upper lid of the case and when I press this hidden black "reset power button" I get the 3 blinking red lights. They blink 5 times and then it stops. Other than that nothing happens. No sound, no lights.
If I just plug in the power cord nothing happens. I need to press the black button to get the blinking lights.
I have tried to unplug everything and let it rest for a day. Did not help.
Any suggestions would be very much appreciated. Thank you.
Regards,
Chris

Answers

  • laurent_14
    laurent_14 ACE Posts: 9,982 Trailblazer
    Hello,
    Did you check the lamp door switch?
    France
  • ChrisNo
    ChrisNo Member Posts: 5 New User
    Hi Laurent,
    thank you for your response. I did not check the lamp door switch. What am I looking for? Do you mean the power plug that comes from the lamp?
    Regards, Chris
  • laurent_14
    laurent_14 ACE Posts: 9,982 Trailblazer
    Hello,
    You should find a switch by removing the door lamp (plastic cover with Acer logo):

    France
  • ChrisNo
    ChrisNo Member Posts: 5 New User
    Hi Laurent,
    thank you for the picture. That door switch is what I think is causing the problem. Or at least the problem should be related to that switch. That is the button that I press to get the 3 blinking red lights.
    The switch looks ok. Wires are in there. Everything is connected. Is that a part that might need to be changed? Could that thing be broken in any way? Unfortunately I don't understand what it does to the system.
    Thank you for your time and help. It is very much appreciated.
    Chris
  • Tom_O
    Tom_O Member Posts: 1 New User
    Hi guys, I have almost exactly the same problem, however symptoms are the opposite, so 3 blinking lights are flashing immediately when I'm plugging in the power cord. When I'm removing top cover, leds stop blinking but obviously projector does not turn on (actually nothing happens, no fan, no sound etc). As soon as I press that button under the cover, 3 leds start to blink again. I haven't opened projector yet to check other things like suggested switch by @laurent_14 , but thought I'll ask you, especially @ChrisNo have you ever got to the bottom of the issue.

    Thanks in advance
    Tom