Examples: Monday, today, last week, Mar 26, 3/26/04

Why games are lagging too much on Acer swift 3?

Abhishek19Abhishek19 Posts: 20Member Troubleshooter
My Acer swift 3 with mx150 used to run euro truck simulator 2 on ultra settings with no lagals whatsoever until two windows commutative updates arrived. The games work good and then lag for a second and then again work good, and then again lag for a second. What should I do?

FAQ & Answers

  • MaClaneMaClane Posts: 18,251ACE Trailblazer
    Good Morning Abhishek19 !

    Is your device set to High Performance in power options?
    Does it only play plugged into the power outlet?
    Are your drivers properly updated?


    Se minha resposta foi útil, deixe um Curtir, marque como Solucionado e clique em Promover!
    Caso contrario, fico a disposição para tentarmos sanar suas duvidas e resolver seus problemas!
    Atenciosamente:  J. MaClane™

    If my answer was helpful, leave a Like, flag as Fixed and click Promote!
    Otherwise, I am willing to try to heal your doubts and solve your problems!
    Sincerely, J. MaClane ™

    For users of the English, Spanish, French and German Community, I will be using Google Translate!


  • Abhishek19Abhishek19 Posts: 20Member Troubleshooter
    The performance is almost same in plugged in or battery power. Updating the drivers doesn't work for sure. The only one that's working somewhat good is the one from Acer website 381.99, I've also tried latest nvidia drivers but they make it worse. I haven't tested in high performance mode though! Does it really makes difference? I've always used in balanced mode.
  • basil327basil327 Posts: 2Member New User
    My Acer swift 3 with mx150 used to run euro truck simulator 2 on ultra settings with no lagals whatsoever until two windows commutative updates arrived. The games work good and then lag for a second and then again work good, and then again lag for a second. What should I do?
    The same problem is present in my pc too. Whether a game is low graphics or high graphics, that periodic lag persists. This problem started 2-3 months back only.
  • Good afternoon basil327 !

    To keep the forum organized and your questions more visible, please avoid posting to already resolved or inactive topics.
    Always open a new post, as it has been guided by moderators.
    Put an @ in front of my name that will guide you there for any questions.


    Se minha resposta foi útil, deixe um Curtir, marque como Solucionado e clique em Promover!
    Caso contrario, fico a disposição para tentarmos sanar suas duvidas e resolver seus problemas!
    Atenciosamente:  J. MaClane™

    If my answer was helpful, leave a Like, flag as Fixed and click Promote!
    Otherwise, I am willing to try to heal your doubts and solve your problems!
    Sincerely, J. MaClane ™

    For users of the English, Spanish, French and German Community, I will be using Google Translate!


  • basil327basil327 Posts: 2Member New User
    @MaClane I don't see query being solved that's why I posted here and not as a new thread.
Sign In or Register to comment.

Who's Online in this Category1

JohnathanWick
JohnathanWick

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos