Examples: Monday, today, last week, Mar 26, 3/26/04

No Data Connection After Latest Update

CliffEndicottCliffEndicott Posts: 2Member New User
I installed the latest update (300-350Mb) a couple of days ago, and after it was completed I cannot access my mobile data network.  Wifi is fine, calling and texting is fine, but no mobile data.  No issues with network or hardware.  Settings > Data Usage > Cellular, the Cellular data is switched on.  Settings > More > Cellular Networks, Mobile Data is on.  Preferred Network Type hasn't changed - it is still 2G/3G/LTE.  All settings appear correct, but the phone won't access the mobile data network.  Is there something I am missing?

Thanks for any help.

FAQ & Answers

  • thamahes2018thamahes2018 Posts: 170Member Skilled Fixer
    HI CliffEndicott
    Please turn on the hotspot tethering in your phone .
  • Rudy21Rudy21 Posts: 795Ally
    I installed the latest update (300-350Mb) a couple of days ago, and after it was completed I cannot access my mobile data network.  Wifi is fine, calling and texting is fine, but no mobile data.  No issues with network or hardware.  Settings > Data Usage > Cellular, the Cellular data is switched on.  Settings > More > Cellular Networks, Mobile Data is on.  Preferred Network Type hasn't changed - it is still 2G/3G/LTE.  All settings appear correct, but the phone won't access the mobile data network.  Is there something I am missing?

    Thanks for any help.

    First, check that mobile data is turned on and you have a data connection.

    1. Open your Settings app Settings and then "Wireless and Networks" or "Connections" and then Mobile data or Cellular data. On some devices, you may need to select "Data usage" before you see this. 
    2. Turn mobile data on. If it's already on, turn it off and on again.
    3. Check that there is a data indicator (for example, 2G, 3G, 4G, H) next to the signal strength bars at the top of the screen Signal.
    4. Note that sometimes this will not display if you have an active Wi-Fi connection. If this is the case, turn Wi-Fi off and check back.

    If you don't see a signal data indicator, you may be in an area without coverage. If you can, move to a different area (for example, go outside) and check your signal again.

    Note: If this happens a lot, contact your mobile service provider.

     

    Next, turn airplane mode on and off.

    1. Open your Settings app Settings and then "Wireless and Networks" or "Connections" and then tap Airplane Mode. Depending on your device, these options may be different. 
    2. Turn airplane mode on.
    3. Wait for 10 seconds.
    4. Turn airplane mode off.
    5. Check to see if the connection problems have been solved.

    If you still have problems after you complete these steps, contact your mobile service provider.

    =) if this answers your question, please hit the Accept Answer =)
  • CliffEndicottCliffEndicott Posts: 2Member New User
    thamahes2018 - Turning on the hotspot tethering didn't do anything.   Thanks though.

    Rudy21.  Mobile Data and Cellular Data are turned on.  When Wifi is active I have a signal data indicator, but as soon as I turn Wifi off it goes away.  Turning airplane mode off and on didn't do anything.

    There is NO ISSUE with the mobile service - I took the SIM card out of the phone and put it into my Samsung Galaxy and it connected to mobile data immediately (Wifi was disabled).  Then I put the card back in the Acer and restarted and everything is the same.

    Settings all appear to be exactly as they should be, but there is no access to mobile data.  When I Google it says Mobile data is turned off, but it is not.  But it is clearly some issue with the phone, not the Mobile network, and it only happened immediately after installing the new update.

  • Rudy21Rudy21 Posts: 795Ally
    thamahes2018 - Turning on the hotspot tethering didn't do anything.   Thanks though.

    Rudy21.  Mobile Data and Cellular Data are turned on.  When Wifi is active I have a signal data indicator, but as soon as I turn Wifi off it goes away.  Turning airplane mode off and on didn't do anything.

    There is NO ISSUE with the mobile service - I took the SIM card out of the phone and put it into my Samsung Galaxy and it connected to mobile data immediately (Wifi was disabled).  Then I put the card back in the Acer and restarted and everything is the same.

    Settings all appear to be exactly as they should be, but there is no access to mobile data.  When I Google it says Mobile data is turned off, but it is not.  But it is clearly some issue with the phone, not the Mobile network, and it only happened immediately after installing the new update.

    Could you try resetting the device to default configuration settings and try checking with the mobile data thing. ( Remember to take backup if any important files exist )
    =) if this answers your question, please hit the Accept Answer =)
Sign In or Register to comment.

Who's Online80

brummyfan2
brummyfan2
davidballard830
davidballard830
DraženStopić
DraženStopić
Driversss
Driversss
egydiocoelho
egydiocoelho
Helly
Helly
Idioten
Idioten
ralppp
ralppp
TrickyFox
TrickyFox
vibrantbish
vibrantbish
+70 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.