Examples: Monday, today, last week, Mar 26, 3/26/04

Acer SF314-54-31RY Hard Drive spins up/down every 10-20 seconds when Intel Optane Enabled

Hi, I have a 16gb optane module in my laptop. After installing a fresh copy of Windows 10 and successfully enabling Optane for hdd acceleration with Intel RST software my hdd now spins down and up during computer use and there are often times whenever I open up a new program or suddenly perform a function in an already opened program (such as highlighting text in adobe pdf or right-clicking in Microsoft word) the hdd seems to turn back on or accelerate (increasing spinning sound) and this is accompanied by a lag during such simple tasks. I didn't have this issue (of recurring lag when using/opening simple programs) prior to enabling Intel Optane. Apart from that, the Intel RST program shows that everything is functioning normally. I already tried disabling Link Power Management in the RST application but that didn't fix the issue.

We have discussed the problem on Intel's support forum already and their technician wrote the following:
"Please try to get a BIOS update with an updated OROM. This is necessary and could be causing issues like the ones you are currently experiencing. If not then this could point at a SATA controller issue which should be addressed by the manufacturer of your system. Please contact them so they can check this."

I have the latest BIOS Version: 1.09 installed and that doesn't fix the issue.
All Intel's drivers are also the latest version.

After a lot of time spent experimenting and searching through the Internet I've discovered that it is something to do with hdd's APM (Advanced Power Management) settings. For example, if you create a key in Windows registry at

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStorAC\Parameters\Device]

"EnableAPM"=dword:00000000

then HDD won't spin down every 10-20 seconds of inactivity. It fixes the problem, but i guess there should have been no such issue from the beginning.

Thanks in advance!

FAQ & Answers

  • JackEJackE Posts: 16,599ACE Trailblazer
    Next time open Control Panel. Search power plan. Choose edit power plan in left panel. Click on advanced power settings near the bottom. Click hard disk folder. Try click down arrow till never shut off hard disk options appear. Jack E/NJ
  • BeeOwGeeDeeAyNBeeOwGeeDeeAyN Posts: 8Member

    Tinkerer

    JackE said:
    Next time open Control Panel. Search power plan. Choose edit power plan in left panel. Click on advanced power settings near the bottom. Click hard disk folder. Try click down arrow till never shut off hard disk options appear. Jack E/NJ
    Thank you for the advice but that didn't help. The problem is somewhere deeper and is connected with SATA controller and HDD. In Linux, for example, it is possible to control an APM via slider (on screenshot).
     
  • JackEJackE Posts: 16,599ACE Trailblazer
    Win10 power plan settings don't seem polished when it comes to identifying and controlling a particular HDD's APM . Been virtually the same since Win7. Was it set to performance or balanced or power saver when setting the HDD to never shut off?  Jack E?NJ
  • BeeOwGeeDeeAyNBeeOwGeeDeeAyN Posts: 8Member

    Tinkerer

    JackE said:
    Win10 power plan settings don't seem polished when it comes to identifying and controlling a particular HDD's APM . Been virtually the same since Win7. Was it set to performance or balanced or power saver when setting the HDD to never shut off?  Jack E?NJ
    It doesn't matter also. Even on full power mode with power adapter plugged in - the hdd still spins down every second of inactivity.

    I am not a technician but a power user and to my experience it seems like the SATA controller treats an HDD like if it was an SSD and puts it to "sleep" mode every second possible to save maximum power. Maybe it is because of this exact combination of Toshiba's HDD with Intel's SATA controller or something with BIOS settings (which are very limited on this laptop).

    By the way, while being in BIOS setup screen - the HDD doesn't spin down (it is possible to hear it spinning).
  • JackEJackE Posts: 16,599ACE Trailblazer
    This only happens in RST mode, correct? AHCI is OK? Jack E/NJ

  • BeeOwGeeDeeAyNBeeOwGeeDeeAyN Posts: 8Member

    Tinkerer

    JackE said:
    This only happens in RST mode, correct? AHCI is OK? Jack E/NJ

    Not sure about this happening in RST mode only. If i disable Optane RST mode the hdd itself works slowly and is constantly in read-write activity, thus preventing it to spin down and sleep mode.
    AHCI and all drivers are ok.

    If booting from a windows 10 setup usb flash disk - hdd spins down after several seconds of inactivity on the first windows 10 setup screen.

    Also if booting from a live Linux usb disk - hdd spins down right after boot, but in Linux an APM is controllable through the APM slider (on a screenshot shown above).
  • JackEJackE Posts: 16,599ACE Trailblazer
    What about HDParm for Windows?  https://sites.google.com/site/disablehddapm/

    Jack E/NJ

  • BeeOwGeeDeeAyNBeeOwGeeDeeAyN Posts: 8Member

    Tinkerer

    JackE said:
    What about HDParm for Windows?  https://sites.google.com/site/disablehddapm/

    Jack E/NJ

    I've tried HDParm and it seems that it has done something. At least the drive doesn't spin down now even though i've deleted

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStorAC\Parameters\Device]

    "EnableAPM"=dword:00000000

    parameter and rebooted the system.

    But I still can't be sure what exactly is happening. I have an idea to reinstall Windows and to check everything again on a fresh clean install. I'll report the result ASAP.


  • JackEJackE Posts: 16,599ACE Trailblazer
    Why do you feel that you should re-install Windows? It either stops or controls the spin up/downs or it doesn't. What other registry changes did you make? Jack E/NJ
  • BeeOwGeeDeeAyNBeeOwGeeDeeAyN Posts: 8Member

    Tinkerer

    edited December 2018
    I just want the experiment to be as transparent as possible.

    I also remembered that after the first clean Windows install there weren't half of power options available for some reason (on an attached screenshot)

    (so i had to modify registry to enable them all)

  • JackEJackE Posts: 16,599ACE Trailblazer
    BeeOwGeeDeeAyN>>>I just want the experiment to be as transparent as possible.>>>

    OK. Good luck. Let us know if you discover anything interesting. :)   Jack E/NJ

  • BeeOwGeeDeeAyNBeeOwGeeDeeAyN Posts: 8Member

    Tinkerer

    So I've discovered several things. First of all after a fresh installation there are no advanced power settings in power options available and without them the laptop doesn't even go to a normal sleep mode at all. To enable all the settings you have to change a value in Windows registry as shown below:



    And still i was unable to prevent my HDD to spin down/up every seconds of inactivity when Optane was enabled. So the only working method is to change registry values as i mentioned in messages above.
  • JackEJackE Posts: 16,599ACE Trailblazer
    But you said earlier before fresh install>>>I've tried HDParm and it seems that it has done something. At least the drive doesn't spin down now even though i've deleted [registry setting]>>>

    Please explain. Jack E/NJ
  • BeeOwGeeDeeAyNBeeOwGeeDeeAyN Posts: 8Member

    Tinkerer

    I can't be sure, unfortunately, because when i ran HDParm on a fresh install - it did nothing at all! 
  • JackEJackE Posts: 16,599ACE Trailblazer
    I'm starting to suspect the Toshiba HDD doesn't play nice with optane enabled or vice versa. Does HDParm work OK when optane is disabled like the Linux app. Optane isn't enabled in Linux yet. Jack E/NJ
    https://www.intel.com/content/www/us/en/support/articles/000024018/memory-and-storage/intel-optane-memory.html

  • AN515forDeeplearningAN515forDeeplearning Posts: 1Member New User
    I bought AN515-52-F58G.
    It had the optane memory and had same problem.
    (HDD electric power often repeats on/off and I can not solve it by windows power setting.)
    So I tried BeeOwGeeDeeAyN's solution("EnableAPM"=dword:00000000),this problem never occured.

    Thank you BeeOwGeeDeeAyN!!!
Sign In or Register to comment.

Who's Online154

Acer-Harvey
Acer-Harvey
HaderMP
HaderMP
KishanMurthy
KishanMurthy
MaClane
MaClane
Migimara
Migimara
nicomunet
nicomunet
pabloeul
pabloeul
+147 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.