Examples: Monday, today, last week, Mar 26, 3/26/04

Disable keyboard backlight timeout?

Hi,
I can't find the setting to disable the timeout for the keyboard backlight.
How do I do that?

Have the Aspire 5 A515 - 52G - ... with Windows 10 and can't find the setting or shortcut to let the backlight stay on.

Best Answer

FAQ & Answers

  • brummyfan2brummyfan2 Posts: 12,869ACE Trailblazer
    edited November 2018
    Hi,
    No, that feature is not available in this model.

    Please "Yes" for "Did this answer the question", if I resolve the problem.
    https://www.userbenchmark.com/UserRun/22060540
  • F3reespiritF3reespirit Posts: 6Member

    Tinkerer

    Thanks for your replie.
    I don't want to request a feature, I want just to turn one off basically, namely the clock that is ticking down and then disables the keyboard backlight. How can I disable this, because I have to write long hours and get distracted by this "flickering" keyboard a lot. Also when I start typing I often first hit the wrong key because I can't see the right one.
  • Hi,
    Unfortunately, the setting to keep the keyboard backlight switched on is not available.
    Please "Yes" for "Did this answer the question", if I resolve the problem.
    https://www.userbenchmark.com/UserRun/22060540
  • F3reespiritF3reespirit Posts: 6Member

    Tinkerer

    edited November 2018
    Thank you,
    so how to fix it then?
    I can't type with this 700€ machine undisturbed. That is a basic task 200€ Chromebooks are able to do. Is a hack available, and if not how can I file a official complaint with all the other unsatisfied customer best? Any tips?
    Because there are a lot of people that don't like to search for a lamp every time they write long texts because the keyboard back light needs to be turned off to stop "flickering" disturbingly. That shouldn't be necessary, people are rightfully disappointed on this one.



  • brummyfan2brummyfan2 Posts: 12,869ACE Trailblazer
    Accepted Answer
    Hi,
    It's a power saving feature but I understand your frustration with it, you may contact Acer Support centre about it and they may be able to provide a solution.
    http://www.acer.com/worldwide/support/
    Please "Yes" for "Did this answer the question", if I resolve the problem.
    https://www.userbenchmark.com/UserRun/22060540
  • F3reespiritF3reespirit Posts: 6Member

    Tinkerer

    edited November 2018
    Ok,
    the guy from tech on the support line had no solution. I now wrote a mail with my arguments and ask to give it to the decision maker. Worst case I have to give the machine back because they do nothing. Best case they give a programmer some hours to fix this for them. Let's see ...
  • I hope they resolve it for your satisfaction.
    Please "Yes" for "Did this answer the question", if I resolve the problem.
    https://www.userbenchmark.com/UserRun/22060540
  • YourReckoningYourReckoning Posts: 4Member New User
    Good news guys. They finally fixed it. Atleast for my Nitro 5 they fixed it. Just go to https://www.acer.com/ac/en/IN/content/support type in your notebook model number and download the latest BIOS (V1.13 for me). After that, there should be an option called "Keyboard Backlight Timeout" in your BIOS settings which should be enabled by default. Disable it and save settings. And you should be good to go. Thank me later. :)
  • harshsingh98harshsingh98 Posts: 1Member New User
    Hi,
    I can't find the setting to disable the timeout for the keyboard backlight.
    How do I do that?

    Have the Aspire 5 A515 - 52G - ... with Windows 10 and can't find the setting or shortcut to let the backlight stay on.
    The Backlit Keyboard is not switching on. please help. I tried Fn+F9, but didn't helped.
  • F3reespiritF3reespirit Posts: 6Member

    Tinkerer

    edited April 1
    Hi,
    I can't find the setting to disable the timeout for the keyboard backlight.
    How do I do that?

    Have the Aspire 5 A515 - 52G - ... with Windows 10 and can't find the setting or shortcut to let the backlight stay on.
    The Backlit Keyboard is not switching on. please help. I tried Fn+F9, but didn't helped.
    I still have no solution for this problem. I was in support and had a guy on the phone, nothing. My keys still switch off after some seconds, and I can't fix that. So I spend around 800€ for a machine, I don't like to use now, because the blinking keys are highly distracting while writing important stuff for my company. I recommend to never buy an Acer again, because they don't seem to be able to get such small problems fixed or don't care to do so (Apple style).  Sorry

  • F3reespiritF3reespirit Posts: 6Member

    Tinkerer

    Good news guys. They finally fixed it. Atleast for my Nitro 5 they fixed it. Just go to https://www.acer.com/ac/en/IN/content/support type in your notebook model number and download the latest BIOS (V1.13 for me). After that, there should be an option called "Keyboard Backlight Timeout" in your BIOS settings which should be enabled by default. Disable it and save settings. And you should be good to go. Thank me later. :)
    Still not fixed for the Aspire 5 A515 - 52G it seems.
  • iaj92iaj92 Posts: 2Member New User
    edited October 10
     Oct 2019 and still no solution to this problem?  I recently purchased the A515-52G-52KN for $800.  This is an upgraded version with 8th gen i5 and MX250 graphics... but still no bios fix for backlight?

    Please Acer do the right thing for this laptop as many were on sale recently via Best Buy, and you will have a lot of customers unsatisfied.

    Personally, I was chosing between the Aspire 5 and the Zenbook.  Aspire 5 was better value option but might switch to Asus because of these issues... 14 days left for return, wonder how many Open Box units BestBuy will have; not a good look Acer.
  • SieberzSieberz Posts: 1Member New User
    I discovered a solution to allow the keyboard backlight to stay on fulltime. Hit the [ N ] on your keyboard, next to NumLk, GeForce NitroSense controls. Open your Advanced Settings at the top, the Gear symbol. Find the Keyboard Settings at the bottom, deselect the "Backlight off after 30 seconds". It truly is this simple if you want the keyboards backlight on all the time. If you want it off all the time however, I haven't found a solution to this just yet. I hope this helps anyone out there who has been looking for a solution.

    Cheers!
  • jimfitterjimfitter Posts: 2Member New User
    edited November 4
    Still no BIOS update for the Aspire A515-54. I am posting this flaw everywhere I can.
    Maybe with enough bad press, someone will address this. I sure am sorry I bought an Acer.
  • OldFatDogOldFatDog Posts: 1Member New User
    Good news guys. They finally fixed it. At least for my Nitro 5 they fixed it. Just go to https://www.acer.com/ac/en/IN/content/support type in your notebook model number and download the latest BIOS (V1.13 for me). After that, there should be an option called "Keyboard Backlight Timeout" in your BIOS settings which should be enabled by default. Disable it and save settings. And you should be good to go. Thank me later. :)
    Glad it worked for you! It's very irritating. Unfortunately, it didn't work for me (BIOS 1.12) on my Acer A515-54. No such option appeared.

    The weird thing is, the F8 key looks like it might be a keyboard backlight toggle. (See attached.)

    But it doesn't actually toggle anything -- the keyboard backlight still times out after 30 seconds. Any idea what this particular F8 key is supposed to do?


  • DB22DB22 Posts: 5Member New User
    edited December 3
    jimfitter said:
    Still no BIOS update for the Aspire A515-54. I am posting this flaw everywhere I can.
    Maybe with enough bad press, someone will address this. I sure am sorry I bought an Acer.
    Same here. I downloaded and installed the most recent BIOS, but the option to toggle the backlight on is still not available. I'm happy enough with the machine, but this tops the list of gripes I have. Acer machines have always performed well for me in the past. Will contact Acer tomorrow and add my complaint to yours.
  • brummyfan2brummyfan2 Posts: 12,869ACE Trailblazer
    OldFatDog said:
    Good news guys. They finally fixed it. At least for my Nitro 5 they fixed it. Just go to https://www.acer.com/ac/en/IN/content/support type in your notebook model number and download the latest BIOS (V1.13 for me). After that, there should be an option called "Keyboard Backlight Timeout" in your BIOS settings which should be enabled by default. Disable it and save settings. And you should be good to go. Thank me later. :)
    Glad it worked for you! It's very irritating. Unfortunately, it didn't work for me (BIOS 1.12) on my Acer A515-54. No such option appeared.

    The weird thing is, the F8 key looks like it might be a keyboard backlight toggle. (See attached.)

    But it doesn't actually toggle anything -- the keyboard backlight still times out after 30 seconds. Any idea what this particular F8 key is supposed to do?


    Hi,
    It's a power saving feature to preserve the battery life for laptops, you can use F8 button to switch off back light when you use the laptop in bright surroundings, you have to press Fn+F8 to switch off/on.
    Please "Yes" for "Did this answer the question", if I resolve the problem.
    https://www.userbenchmark.com/UserRun/22060540
Sign In or Register to comment.

Who's Online138

AirborneRanger73
AirborneRanger73
Alartaboon
Alartaboon
barritz77
barritz77
egydiocoelho
egydiocoelho
Jack22
Jack22
lucacaribe
lucacaribe
maternalrelic
maternalrelic
MikeToo
MikeToo
Otacir
Otacir
StevenGen
StevenGen
STOPchris
STOPchris
VitorM
VitorM
Zegoldengamer29
Zegoldengamer29
+125 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Good Design Aware 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.