Examples: Monday, today, last week, Mar 26, 3/26/04

Acer Aspire 7250: Loses access to internal Wi-Fi card

My Acer Aspire 7250-0209 (latest BIOS 1.10) has a weird problem with internal Wi-Fi cards in its half-mini PCI Express slot. It came stock with a 2.4GHZ Wi-Fi-only card based on the Atheros AR5B125 chipset. Thinking the first card might be bad, I tried a second card, a Dell 1703 2.4GHz Wi-Fi/Bluetooth combo card based on the Atheros 10K chipset. I then tried a third card, a dual-band 2.4GHz-5GHz/Bluetooth combo card based on the Realtek RTL8821AE chipset. All three cards exhibit substantially similar behavior.

The laptop is configured to dual-boot either Windows 10 (1803 originally but upgraded to 1809) or Linux (Ubuntu 18.04 with kernel 4.15.0) from separate partitions. On the first boot under either operating system after a Wi-Fi card is installed, the operating system correctly identifies it (including the Bluetooth adapter if present on the card), and configures drivers for it. Upon reboot into either operating system, the card is no longer seen at all. When the card disappears under Windows, in Device Manager enabling showing of hidden devices lists the Wi-Fi driver grayed out and a message that the device is not connected. When the card disappears under Linux, it does now show up as would be expected in "lspci", "lsusb", or "lshw". However, if the card has Bluetooth, then that part of the card works fine despite the Wi-Fi part disappearing.

If the bottom cover is opened and a card is physically removed and reinserted, again Wi-Fi works on the first boot but not again. This proves that the PCI Express slot itself is not physically damaged.

The network stacks under both operating systems are known good: if a USB Wi-Fi device (one based on the Realtek RTL8812AU chipset) is present, it works reliably. The built-in Ethernet port works correctly also. Only the internal Wi-Fi card is problematic.

My hunch is that the problem lies in the BIOS failing to properly enumerate the Wi-Fi part of the card, which is PCI, even if it correctly enumerates the Bluetooth part of the card, which is USB. The failure to enumerate the PCI Wi-Fi device occurs regardless of whether there is any USB Bluetooth device on the same card, which is always correctly enumerated if present.

Could this be a BIOS bug? Is there some workaround to force the BIOS to go out and look for PCI devices without having to physically remove and reinsert the card?


FAQ & Answers

  • First do a disk cleanup as administrator:

    Then turn off fast boot, because as you are using a dual boot system, this active option will bring you many more problems than benefits:

    Oi! Eu não sou sou a cortana! Mas estou aqui para ajudar! Hi! I'm not the cortana! But I'm here to help!
    Se você gostou da minha resposta, marque como solução clicando em promover! If you liked my answer, mark it as a solution by clicking on Promote!
    Aceite somente a resposta que ajudou a solucionar o seu problema! Please accept only the response that helped to solve your problem!
    Detection tool click here to find the serial number or partnumber of your model!                                                          

               
      egydiocoelho Trailblazer
     
    ProductKey clique aqui para descobrir o serial do windows! click here to discover the windows serial!
    Para usuários da comunidade inglesa, espanhola, francesa e alemã, usarei o google tradutor! :)
    For users of the English, Spanish, French and German community, I will be using google translator! :) 
Sign In or Register to comment.

Who's Online91

Joma22
Joma22
kmz
kmz
Lockheed
Lockheed
Squire1204
Squire1204
tahmidolee
tahmidolee
Unknowngirl15
Unknowngirl15
+85 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.