Examples: Monday, today, last week, Mar 26, 3/26/04

Acer Predator Helios 300 GPU clocks dropping...

Diabolic89Diabolic89 Posts: 23Member Troubleshooter
Just got this laptop and already having issues. I noticed my fps would randomly plummet on games and noticed it was because my GPU clock drops from 1800-1900 mhz to around 100mhz.. Wondering if i should return it and get a new one?
«13

FAQ & Answers

  • Jack22Jack22 Posts: 1,529ACE Pathfinder

    check your processor temperature, and check GPU, CPU, RAM and disk usage. Your core clock can be dropping due to CPU bottleneck or you're not providing enough RAM to the game.
    Also tell me all of your computer specs
  • Diabolic89Diabolic89 Posts: 23Member Troubleshooter
    temps are great. usage all good. im just getting a replacement..
  • Could be that new Intel VGA driver bug, it also drops frames randomly.

    Fix is using Acers Intel VGA driver instead of the latest from Windows.
    - Hotel Hero
  • Diabolic89Diabolic89 Posts: 23Member Troubleshooter
    hmm ok ill try that.
  • Diabolic89Diabolic89 Posts: 23Member Troubleshooter
    The one on acers website looks to be the same one windows grabbed.
  • Diabolic89Diabolic89 Posts: 23Member Troubleshooter
    Happened again. Dropped from 1900mhz to 139 for like 10 seconds. Then went back to normal
  • Red-SandRed-Sand Posts: 1,732ACE Pathfinder
    edited September 2018
    The one on acers website looks to be the same one windows grabbed.
    The one on Acers page is much earlier (Should be).
    Try enabling experimental features in Geforce Experience then reboot your laptop twice.
    - Hotel Hero
  • Diabolic89Diabolic89 Posts: 23Member Troubleshooter
    edited September 2018
    Red-Sand said:
    The one on acers website looks to be the same one windows grabbed.
    The one on Acers page is much earlier (Should be).
    Try enabling experimental features in Geforce Experience then reboot your laptop twice.

    They are the same. Ive tried it. Tried removing Geforce Experience as well. Nothing has worked =(
  • Might I ask what overclocking software your using? I know the 1060 mobile chip doesn't hit 1800-1900 clock speeds out of box.
    - Hotel Hero
  • Diabolic89Diabolic89 Posts: 23Member Troubleshooter
    Red-Sand said:
    Might I ask what overclocking software your using? I know the 1060 mobile chip doesn't hit 1800-1900 clock speeds out of box.
    Predator sense
  • Diabolic89Diabolic89 Posts: 23Member Troubleshooter
    I got a replacement and unfortunately this one is doing the same thing. Temps are fine and everything is set for performance. Don’t get it.
  • What are your temperatures for CPU and GPU?
    - Hotel Hero
  • Diabolic89Diabolic89 Posts: 23Member Troubleshooter
    Red-Sand said:
    What are your temperatures for CPU and GPU?
    CPU is usually 75-80 and gpu 65-70. 
  • Hmm.. what tweaks have you tried so far?

    Have you disabled hibernation? 
    Any luck finding whats running for that 10 second time period?

    I can say for sure thats not normal and Im wondering if it isnt some useless Windows task running every so often.

    Try the setup here as it helps remove windows background nonsense:



    Also what game is it your playing?
    - Hotel Hero
  • Diabolic89Diabolic89 Posts: 23Member Troubleshooter
    Red-Sand said:
    Hmm.. what tweaks have you tried so far?

    Have you disabled hibernation? 
    Any luck finding whats running for that 10 second time period?

    I can say for sure thats not normal and Im wondering if it isnt some useless Windows task running every so often.

    Try the setup here as it helps remove windows background nonsense:



    Also what game is it your playing?
    Mostly wow but I went into Nvidia control panel and changed preferred graphics card to Nvidia instead of auto and it hasn’t happened yet. Hopefully fixed it..
  • Red-SandRed-Sand Posts: 1,732ACE Pathfinder
    edited September 2018
    Let me know the results!
    Hopefully it's as simple as that!
    - Hotel Hero
  • Diabolic89Diabolic89 Posts: 23Member Troubleshooter
    Red-Sand said:
    Let me know the results!
    Hopefully it's as simple as that!
    It happened again. Not sure what else to try. I feel like since this has happened with 2 different laptops it isn’t a hardware issue.. but idk
  • You should set nvidia control panel "manage 3d settings" to "let 3d application decide" and not change any settings yourself. Leaving the gpu dedications set to auto.

    Try reinstalling nvidia gpu driver version 388.31 (older driver) make sure your using the 64 bit installer

    - Hotel Hero
  • Diabolic89Diabolic89 Posts: 23Member Troubleshooter
    Red-Sand said:
    You should set nvidia control panel "manage 3d settings" to "let 3d application decide" and not change any settings yourself. Leaving the gpu dedications set to auto.

    Try reinstalling nvidia gpu driver version 388.31 (older driver) make sure your using the 64 bit installer

    I’ve tried that already as well.
  • Diabolic89Diabolic89 Posts: 23Member Troubleshooter
    Also noticed when my GPU usage gets higher the GPU clock drops a few hundred as well...
Sign In or Register to comment.

Who's Online215

Acer-Jose
Acer-Jose
Afeca
Afeca
Aldereon
Aldereon
Cyriix
Cyriix
davelaw56
davelaw56
Jack22
Jack22
Kno63
Kno63
Kruno
Kruno
laurent_14
laurent_14
lovelyacular
lovelyacular
+205 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.