next@acer 2020

Predator 15 G9-591 is plugged in and charging but stays at 0%

WinterGaleWinterGale Member Posts: 24 Networker
So this happened without warning. I turned the laptop on and left it plugged in for a couple of hours. When I came back it was already turned off so I powered it back on and noticed that the battery sign says that it's at 0% available (plugged in, charging) but the laptop isn't actually charging. The moment I take off the charger my laptop turns off. I checked the Acer Care Center software and it says that my battery health is good. Finally, batteryreport says that the battery's full charge capacity is at 70,200mWh against the design capacity's 90,000mWh.

Any advice?

FAQ & Answers

  • asad814asad814 Member Posts: 371 Seasoned Practitioner
    have you tried the battery reset???
  • WinterGaleWinterGale Member Posts: 24 Networker
    Yeah, it didn't solve the problem. Although, I wasn't exactly sure I did the battery reset correctly (I couldn't wait for the 5 minute mark).
  • asad814asad814 Member Posts: 371 Seasoned Practitioner
    go to device manager>drivers and uninstall all battery drivers(microsoft acpi battery) then restart and then let windows to install the drivers
Sign In or Register to comment.

Who's Online1.3K

GAMING6698
GAMING6698
MarkJFernandes
MarkJFernandes
Nikiloas
Nikiloas
PDC
PDC
smoochiepook
smoochiepook
StalledArk
StalledArk
+1.3K Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We want to recognize GAMING6698's dedicated efforts in the Acer Community. GAMING6698 has become one of the main collaborators since joining the Community in November of 2019.
On behalf of all our users and the Acer Team, we thank you for your dedication!

Total Posts and Comments: 3320

Total Points:5757

Total Accepted Answers: 290

GAMING6698 Mainframe Wrangler