Aspire V5-471 keeps re-enabling secure boot after i remove power or battery

TulainasTulainas Member Posts: 3 New User

Hello!

 My laptop 'keeps me out' every time i remove power cord or battery by enabling secure boot again. (And by 'keeps me out' i mean: 'starts windows or starts windows recovery')

 How I 'fix' it:
 1) get into UEFI
 2) enable legacy bios
 3) save and exit (F10)
 4) reboot
 5) reenable uefi
 6) disable 'secure boot'
 7) put 'grub bootloader' as first boot order again
 8) save and exit again (F10)
 9) reboot again


... and then I'm good to go. EVERY SINGLE TIME!!!!!!!

 Question is: How can I EFFECTIVELY AND PERMANENTLY REMOVE Uefi's 'secure boot'?

FAQ & Answers

  • JackEJackE ACE Posts: 29,809 Trailblazer
    If you're trying to dual boot, you cannot change to legacy mode or Windows won't run. Linux must be installed in UEFI mode using a GPT partition USB stick. Jack E/NJ

    ( 0) Pre-shrink Windows partition to desired unallocated space for Linux installation. Shrink it a lot if you want
    ( 1) Make bootable GPT/FAT32(default) stick from the Linux installation iso with Rufus, a freeware download.
    ( 2) Set BIOS supervisor password(SECURITY), disable secure boot(BOOT)& enable F12 Windows boot mgr (MAIN). Save BIOS settings & exit. May not be needed with some Linux installations like Mint.
    ( 3) Shutdown & insert bootable Linux stick
    ( 4) Turn back on while immediately tapping F12. Select Linux stick to run.
    ( 5) Preferrably select a default Linux install option
    ( 6) Follow on-screen instructions to install alongside Windows.
    ( 7) Let Linux automatically set & resize partitions for Linux & its swap. Adjust for more or less space only if absolutely necessary.
    ( 8) Shutdown & remove Linux stick.
    ( 9) Turn back on while tapping F2.
    (10) Re-enable secure boot(BOOT) & select UEFI file as trusted(MAIN). Select HDD0, SSD0 or eMMC0, then <EFI>, then <ubuntu>, then grubx64.efi the UEFI file. Enter grubx64.efi in the space provided if selecting it doesn't automatically enter it. Save BIOS setting and exit.
    (11) Boot into Windows. Then shutdown again.
    (12) Turn back on while tapping F12.
    (13) If desired, put grubx64.efi ahead of Windows boot manager in UEFI bootstrapper



    Jack E/NJ
  • TulainasTulainas Member Posts: 3 New User
    edited May 2018
    allready done ( 0) Pre-shrink Windows partition to desired unallocated space for Linux installation. Shrink it a lot if you want
    done ( 1) Make bootable GPT/FAT32(default) stick from the Linux installation iso with Rufus, a freeware download.
    done ( 2) Set BIOS supervisor password(SECURITY), disable secure boot(BOOT)& enable F12 Windows boot mgr (MAIN). Save BIOS settings & exit. May not be needed with some Linux installations like Mint.
    done ( 3) Shutdown & insert bootable Linux stick
    done ( 4) Turn back on while immediately tapping F12. Select Linux stick to run.
    done ( 5) Preferrably select a default Linux install option
    done ( 6) Follow on-screen instructions to install alongside Windows.
    done ( 7) Let Linux automatically set & resize partitions for Linux & its swap. Adjust for more or less space only if absolutely necessary.
    done ( 8) Shutdown & remove Linux stick.
    done ( 9) Turn back on while tapping F2.

    (it had been running ok, but then something happened and started doing that secure boot thing like since two months ago)

    i'll try:

    (10) Re-enable secure boot(BOOT) & select UEFI file as trusted(MAIN). Select HDD0, SSD0 or eMMC0, then <EFI>, then <ubuntu>, then grubx64.efi the UEFI file. Enter grubx64.efi in the space provided if selecting it doesn't automatically enter it. Save BIOS setting and exit. 
    (11) Boot into Windows. Then shutdown again.
    (12) Turn back on while tapping F12.
    (13) If desired, put grubx64.efi ahead of Windows boot manager in UEFI bootstrapper

  • TulainasTulainas Member Posts: 3 New User
    edited May 2018
    This is the only thing I see.

    Where to select/enter "grubx64.efi"?

     Am I missing something?

    (I really don't care about windows)
  • JackEJackE ACE Posts: 29,809 Trailblazer
    ***Secure boot must be enabled!*** It still looks disabled me. It also looks like you have two instances of the grub bootloader. grubx64 is for the 64-bit version. Which Linux installation version were you trying to use? Ubuntu? Mint? Debian? Fedora? SuSE?, Linpus? There are many!   Jack E/NJ




    (10) Re-enable secure boot(BOOT) & select UEFI file as trusted(MAIN). Select HDD0, SSD0 or eMMC0, then <EFI>, then <ubuntu>, then grubx64.efi the UEFI file. Enter grubx64.efi in the space provided if selecting it doesn't automatically enter it. Save BIOS setting and exit. 
    (11) Boot into Windows. Then shutdown again.
    (12) Turn back on while tapping F12.
    (13) If desired, put grubx64.efi ahead of Windows boot manager in UEFI bootstrapper

    Jack E/NJ
Sign In or Register to comment.

Who's Online1.1K

billsey
billsey
compass1
compass1
cristian_kms
cristian_kms
Crux
Crux
EvidentRecker
EvidentRecker
JoãoVictor2004
JoãoVictor2004
NeonMan88
NeonMan88
SDK96
SDK96
Spidex
Spidex
StevenGen
StevenGen
Yibo_de
Yibo_de
+1K Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We are honored to have Leostat in the Acer Community. With their dedication, support and effort, Leostat has become one of the main collaborators. On behalf of our Acer Community Team and all of our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1979

Total Points:6432

Total Accepted Answers: 248

Leostat Community Aficionado