Examples: Monday, today, last week, Mar 26, 3/26/04

Acer Aspire Switch 10, webcam won't be detected

WaaweWaawe Member Posts: 14

Tinkerer

edited April 2018 in Switch Series
Hola, like other unlucky fellows, after the update to Windows 10, the camera of my Acer Aspire Switch 10 can't be detected. I have already applied the patch suggested in a dated post, yet to no avail. I have experimented with drivers which detect my device as Intel Imaging Signal Processor 2400 or AVStream Camera. I have also tried different drivers for Camera Sensor OV2720. The results? After running the camera application, either the camera is not detected or it is but the image is black and after capturing the app freezes. Do you have some advice for the poor man?

Waawe
«1

FAQ & Answers

  • JackEJackE ACE Posts: 19,792 Trailblazer
    Search settings for "restore point" that the Win10update should've automatically created.

    Nastavení vyhledávání pro "bod obnovení", který měl Win10update automaticky provést.

    Jack E/NJ
    Jack E/NJ
  • WaaweWaawe Member Posts: 14

    Tinkerer

    Sadly, this function has been off. There aren't any restore points. :-(
  • JackEJackE ACE Posts: 19,792 Trailblazer
    Is the camera also gone in Device Mgr imaging? Jack E/NJ
    Jack E/NJ
  • WaaweWaawe Member Posts: 14

    Tinkerer

    No, it's there. Detected as Intel Imaging Signal Processor 2400 or AVStream Camera, depending on the drivers.  (See the appx.)
  • JackEJackE ACE Posts: 19,792 Trailblazer
    So they are detected! Does Device Mgr show any red or yellow driver warnings? Have you tried to let Win10 search for updated drivers while connected on-line? Jack E/NJ
    Jack E/NJ
  • WaaweWaawe Member Posts: 14

    Tinkerer

    No warnings, everything looks perfect, drivers updated, yet, when I run the camera application, I get an error message, such as the one posted above. Seemingly I would need an old driver running flawlessly under Windows 8? Google tells me quite a few users have had similar problems with laptops of different brands. Sadly, I haven't been able to find a remedy. 
  • JackEJackE ACE Posts: 19,792 Trailblazer
    Try this freeware download for pc camera software, viewplaycap. It's a compressed rar file. Detects both internal and external cameras. Jack E/NJ    www.kkmoom.com/pc.rar 

    Jack E/NJ
  • WaaweWaawe Member Posts: 14

    Tinkerer

    Dear JackE, thank you a lot for your effort, I appreciate it lots. I tried out Viewplaycap. When the Intel Image Signal Processor 2400 driver is loaded, the viewplaycap freezes after the launch of capturing. When the AV Stream Camera driver is loaded, the viewplaycap seemingly starts capturing, yet yielding a corrupted file which can't be played. (see the appx.)
  • WaaweWaawe Member Posts: 14

    Tinkerer

    Are there any other devices except for the imaging device and camera sensor to be considered? I've so far experimented with the drivers of these two items only. 
  • JackEJackE ACE Posts: 19,792 Trailblazer
    What are you using to open the "corrupted" viewplaycap file? Jack E/NJ
    Jack E/NJ
  • WaaweWaawe Member Posts: 14

    Tinkerer

    You were right. Now, I have tried VLC player, and it would play the file. The sound had been recorded OK, yet there is no video shown.
  • WaaweWaawe Member Posts: 14

    Tinkerer

    More and more evidence suggests there will be AV Steam Camera inside?
  • JackEJackE ACE Posts: 19,792 Trailblazer
    >>>Now, I have tried VLC player, and it would play the file. The sound had been recorded OK, yet there is no video shown. >>>

    What is the file extension name on the file that ViewPlayCap made? Jack E/NJ
    Jack E/NJ
  • WaaweWaawe Member Posts: 14

    Tinkerer

    it's an .avi
  • JackEJackE ACE Posts: 19,792 Trailblazer
    Have you tried the other format(s) and resolutions that might be available in your version of ViewPlayCap? Jack E/NJ
    Jack E/NJ
  • WaaweWaawe Member Posts: 14

    Tinkerer

    I have tried videocapturing (.avi and .asf) and taking a snap(.bmp, .jpg), no picture, sadly.
  • JackEJackE ACE Posts: 19,792 Trailblazer
    Have we yet tried to uninstall the cameras from Device Manager --- exit --- then re-boot and let Windows re-detect and re-install the drivers? Jack E/NJ
    Jack E/NJ
  • RoedeerRoedeer Member Posts: 2 New User
    Dear Jack, I'm sorry for being unresponsive due to Easter holiday. Yes, the uninstall of the drivers and the devices has been performed a few times by now. Maybe, a clear installation of the Windows might be the way? 
  • JackEJackE ACE Posts: 19,792 Trailblazer
    OK. Make sure the machine is completely shut off. Then turn it on and immediately press and hold the ALT key while tapping the F10 key. A recovery screen should appear. Follow directions to reset the machine to a factory-fresh state as in the video below. Jack E/NJ





    Jack E/NJ
  • RoedeerRoedeer Member Posts: 2 New User
    JackE, thanks a lot for all you have done for me. I guess I will give it a break. Maybe wait for Windows 11 or buy a real adult laptop. I don't want to do all that backup stuff at the moment.

    You've been very helpful anyway. Cheers. 

    Waawe 
Sign In or Register to comment.

Who's Online in this Category0

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos