Examples: Monday, today, last week, Mar 26, 3/26/04

Setting NVME M.2 SSD to primary boot device with OS windows 10

Pathfinder01Pathfinder01 Posts: 7Member New User
I have the Acer E5-774G-596Q

Did the research on if I was able to install the Samsung NVME 960 EVO M.2 500 GB.
Do have version 3 X 2 lane available.
Installed the driver, migration wizard and Samsung Musician, cloned the stock WD Hard drive no problems.
All tests good as far as performance considering  1 have 2 lane available vs 4 still extremely faster than the Hard drive boots in less than 20 seconds to desktop loaded vs 1-2 minutes.
My problem is that I can only seem to boot from the SSD when the SATA HD is removed. When I go into BIOS and select the SSD for priorty 1 boot, it still boots from the SATA HD .
On screen one of the BIOS the SSD is HDD0 followed with the Product Samsung 960 Evo. HDD1 followed with no name or info.
When windows is loaded and I try to assign a new letter to disk management the info is opposite Disk0 is WD HD DISK1 is SamsungSSD and it will not allow me to change the SSD to C because the HD is using it which i believe is the issue.
SSD is also not shown/recognized when viewing under file explorer/this PC/Devices and Drives when the WD is installed as well. 
Without the WD Drive installed the Samsung is assigned Drive letter C and correct as viewed

I also removed the HD from the SATA HD bay and ran only the SSD NVME M.2 and it runs awesome as expected. The drive letter assigned becomes C with expected benchmark performance etc no issues.
put the WD hard drive back in expecting it to be placed and assigned a later drive letter (E) etc. but it goes back to becoming primary boot device regardless of selecting the Samsung for primary

I could run the system without the WD Hard Drive but would like the added storage of 1 TB for media files etc. not requiring fast loading

What am i missing?
I am not that much of a computer expert but not e literate either when it comes to figuring out computer hardware. 

Any suggestions or help is appreciated.

Thanks







Best Answers

  • Pathfinder01Pathfinder01 Posts: 7 New User
    Accepted Answer
    Jack

    Tried what you suggested with no change or success with some items.

    I had removed the NVME M.2 SSD ,rebooted and the Bios information populated for the WD Hard Drive correctly at HDD0, Windows boot manager as boot priorty 1, HDDO WD Hard Disk Priorty 2 booted up fine.

    Removed Western Digital Hard Disk and installed the NVME M.2 SSD rebooted and Bios information populated for device correctly at HDD0, Windows boot manager as priorty 1, HDD NVME Samsung M.2SSd Priorty 2 booted up fine.

    Added the WD Hard Drive in combination with the SSD rebooted the Bios information for HDD0 Populated for the NVME M.2 SSD correctly. HDD1 shows no information which you would assume would be the WD Hard drive. Boot priority set as windows boot manager priority 1,HDD0 NVME Samsung M.2SSd Priorty 2, HDD1 No Info as Priorty 3, when windows loaded the WD Hard disk was the drive that booted.

    After all of this, I set the Bios back to default settings. Enabled post (F12 Boot Menu) in the main menu of Bios.( I would of thought this was the same as the boot title options in Bios but it appears not to be).
    Rebooted, hit F12 both drives can now be selected and populate information.
    Windows boots correct and information for the drives is also now populated in the windows explorer menu.

    I can now utilize both drives as planned, just have the extra task of using the F12 boot manager every time I boot up until I hear of a way to be set up automatically.

    Thanks for you help.





  • JackEJackE Posts: 7,354 Pathfinder
    Accepted Answer
    Congrats! Glad it finally worked out for you. I have no idea why setting the BIOS to default and show F12 after all this would've made a difference. Perhaps magic. Would you care to try to repeat all this from scratch to see if it's reproducible? 8^) Jack E/NJ

Answers

  • JackEJackE Posts: 7,354ACE Pathfinder
    edited February 7
    My first guess would be to turn off the BIOS secure boot option, setting a supervisor password if I had to in order to turn it off. Did I guess right? Jack E/NJ
  • Pathfinder01Pathfinder01 Posts: 7Member New User

    PS BIOS is latest version 1.27 all windows updates current


  • JackEJackE Posts: 7,354ACE Pathfinder
    Go into the BIOS security section. Set a supervisor password so you can disable secure boot. Don't forget the password. Reboot back into the BIOS menu with the password. Turn off secure boot. Then try to boot from the m.2 as first in the boot order with the HDD hooked up. Jack E/NJ 
  • Pathfinder01Pathfinder01 Posts: 7Member New User
    Followed your recommendations however there is no change boot up and down times are quite long with the WD HD installed.

    I have tried the boot priorities with windows boot manager as 1 and 2 as well as HDD0 Samsung SSD as 1 or 2 with no noticeable change.
    The boot manager from my understanding is created by the Samsung Migration wizard during the hard drive cloning process.
    HDD1 is my WD Hard Drive although it does not show up in the bios it is currently hooked up and during all previous pics.



  • Pathfinder01Pathfinder01 Posts: 7Member New User
    No change same Issues.


    Thanks

    Signing off for tonight,will be back tomorrow.

  • JackEJackE Posts: 7,354ACE Pathfinder
    OK. I think you should try to change the boot order back to the WD as first. Then boot from the WD as usual and try to set a BIOS supervisor password so you can disable secure boot. If you can do this with the m.2 connected, see if you can also change the boot order back to the m.2 as first. Then try to save these BIOS settings and reboot with both drives connected. Jack E/NJ
  • Pathfinder01Pathfinder01 Posts: 7Member New User
    Accepted Answer
    Jack

    Tried what you suggested with no change or success with some items.

    I had removed the NVME M.2 SSD ,rebooted and the Bios information populated for the WD Hard Drive correctly at HDD0, Windows boot manager as boot priorty 1, HDDO WD Hard Disk Priorty 2 booted up fine.

    Removed Western Digital Hard Disk and installed the NVME M.2 SSD rebooted and Bios information populated for device correctly at HDD0, Windows boot manager as priorty 1, HDD NVME Samsung M.2SSd Priorty 2 booted up fine.

    Added the WD Hard Drive in combination with the SSD rebooted the Bios information for HDD0 Populated for the NVME M.2 SSD correctly. HDD1 shows no information which you would assume would be the WD Hard drive. Boot priority set as windows boot manager priority 1,HDD0 NVME Samsung M.2SSd Priorty 2, HDD1 No Info as Priorty 3, when windows loaded the WD Hard disk was the drive that booted.

    After all of this, I set the Bios back to default settings. Enabled post (F12 Boot Menu) in the main menu of Bios.( I would of thought this was the same as the boot title options in Bios but it appears not to be).
    Rebooted, hit F12 both drives can now be selected and populate information.
    Windows boots correct and information for the drives is also now populated in the windows explorer menu.

    I can now utilize both drives as planned, just have the extra task of using the F12 boot manager every time I boot up until I hear of a way to be set up automatically.

    Thanks for you help.





  • JackEJackE Posts: 7,354ACE Pathfinder
    Accepted Answer
    Congrats! Glad it finally worked out for you. I have no idea why setting the BIOS to default and show F12 after all this would've made a difference. Perhaps magic. Would you care to try to repeat all this from scratch to see if it's reproducible? 8^) Jack E/NJ
  • WeeveSterWeeveSter Posts: 15Member New User
    Hey not sure if I read that maybe you could set the boot priority and "Windows Boot manager" as the first device in boot priority. Have you tried that?
  • WeeveSterWeeveSter Posts: 15Member New User
    I'm considering doing this but how can I tell if the motherboard supports the m2 pci experess 3.0 x4 lanes?

    Mine is

    Aspire A515-51.


  • WeeveSter said:
    I'm considering doing this but how can I tell if the motherboard supports the m2 pci experess 3.0 x4 lanes?

    Mine is

    Aspire A515-51.


    WeeveSter said:
    I'm considering doing this but how can I tell if the motherboard supports the m2 pci experess 3.0 x4 lanes?

    Mine is

    Aspire A515-51.



    Hi,
    I have replied in other thread :)
  • Pathfinder01Pathfinder01 Posts: 7Member New User
    WeeveSter

    I followed brummyfan2's info on this link to determine if my motherboard was capable.

    https://community.acer.com/en/discussion/497241/acer-aspire-e5-575-52jf-m-2-nvme-support/p1

    As far as boot order. In the Bios it is set up as the primary boot drive however it still boots from the hard drive. To correct this i had to enable the F12 option for the boot manager. Selecting the NVME M.2 drive here allows me to boot from the Samsung 960 Evo first (500 GB). Having this drive installed on this system does not unlock its full potential but still very fast. I posted a pic of the read writes in one of the previous comments. 

    I have PCI Express Version 3 x 2lane
Sign In or Register to comment.

Who's Online121

azaidi697
azaidi697
brummyfan2
brummyfan2
Caslusfilho
Caslusfilho
Daveke
Daveke
kjprice37
kjprice37
palkansh
palkansh
Sharanji
Sharanji
ZM1783
ZM1783
+113 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Announcements

Free 25 GB of Dropbox Space



Register your Acer device and get 25GB of space free for 1 year!

Acer Store Deutschland


KOSTENLOSER VERSAND - AUSGEZEICHNETER SERVICE

Facebook

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.